Answered

Arc TV sound cuts in and out.



Show first post

688 replies

Userlevel 2
Badge +2

I’ve just bought an Arc and 2 One SL’s. When streaming Netflix or ITunes movies the audio cuts for a split second every now and then. Similar to some of the others on this page. I’ve done the override on my Apple TV to force the audio output to Dolby 5.1 only. Still happens. (Don’t even mention Atmos, I don’t think my TV supports that. When I force the Apple TV to play Stereo only I have no issues. Just for Dolby 5.1 or what ever the source suppliers. What do I do ? Looks like it’s a common issue on here. Do I need to return the entire system ? 

It’s not Sonos.. it’s the firmware that needs to be updated corrected by the tv manufacturers. Sony has resolved this issue with their update. System works excellent now with Sony tv. You didn’t mention the tv brand you have but I suspect it’s Samsung (?). They have not got it straight yet. 

Badge

I had posted earlier in this thread regarding the same issue, have then gone a long period without an issue but it came back and looks to be due to the power cable being a poor fit, the slightest knock and either sound becomes  intermittent or there is no sound at all as it pops fully out 

There is already a different thread about this (arc loose power cable), may not be the issue causing intermittent sound for others in this thread, but it is for me

 

I currently have Playbar and would love to upgrade to the Arc but as I have a Samsung telly and don’t want to change that, I haven’t taken the plunge. Am I wise to hold off or should I buy and be prepared to return it when it goes into Norman Collier mode? Advice would be appreciated. Thanks.

I currently have Playbar and would love to upgrade to the Arc but as I have a Samsung telly and don’t want to change that, I haven’t taken the plunge. Am I wise to hold off or should I buy and be prepared to return it when it goes into Norman Collier mode? Advice would be appreciated. Thanks.

If the TV has HDMI, then I would perhaps suggest you go get the Sonos Arc and bypass the TV with HDFury’s Arcana

Setup as shown in this diagram (just ignore the projector link):

 

 

Updated and still getting the issue. Was really noticeable while watching Kong vs Godzilla on HBOMax last night. Really thinking about getting rid of the this Arc!!!

When will we get the resolution we deserve??

I’ve just bought an Arc and 2 One SL’s. When streaming Netflix or ITunes movies the audio cuts for a split second every now and then. Similar to some of the others on this page. I’ve done the override on my Apple TV to force the audio output to Dolby 5.1 only. Still happens. (Don’t even mention Atmos, I don’t think my TV supports that. When I force the Apple TV to play Stereo only I have no issues. Just for Dolby 5.1 or what ever the source suppliers. What do I do ? Looks like it’s a common issue on here. Do I need to return the entire system ? 

It’s not Sonos.. it’s the firmware that needs to be updated corrected by the tv manufacturers. Sony has resolved this issue with their update. System works excellent now with Sony tv. You didn’t mention the tv brand you have but I suspect it’s Samsung (?). They have not got it straight yet. 

Sony has a fix??? That’s news to me!!! Still not working for me!!!

X900H

Sonos Arc, Sub, 2 x Sonos One

Userlevel 2
Badge +2

I’ve just bought an Arc and 2 One SL’s. When streaming Netflix or ITunes movies the audio cuts for a split second every now and then. Similar to some of the others on this page. I’ve done the override on my Apple TV to force the audio output to Dolby 5.1 only. Still happens. (Don’t even mention Atmos, I don’t think my TV supports that. When I force the Apple TV to play Stereo only I have no issues. Just for Dolby 5.1 or what ever the source suppliers. What do I do ? Looks like it’s a common issue on here. Do I need to return the entire system ? 

It’s not Sonos.. it’s the firmware that needs to be updated corrected by the tv manufacturers. Sony has resolved this issue with their update. System works excellent now with Sony tv. You didn’t mention the tv brand you have but I suspect it’s Samsung (?). They have not got it straight yet. 

Sony has a fix??? That’s news to me!!! Still not working for me!!!

X900H

Sonos Arc, Sub, 2 x Sonos One

Sony released a firmware update for my A8H on 12/3 and it fixed the audio dropout issues.  I had to re-boot my tv to factory settings to get it to work, though.  I dont think that’s been the case for everyone. There was another A8H firmware update v6.5042 on 2/23 to address other issues.  You should confirm you have the most recent firmware for your tv (which is v6.0466 I believe if you have a US X900H model).  Contact Sony via phone or chat if you have the most recent firmware and you are still experiencing dropouts - they can walk you through the proper settings to get it to work.

I’ve just bought an Arc and 2 One SL’s. When streaming Netflix or ITunes movies the audio cuts for a split second every now and then. Similar to some of the others on this page. I’ve done the override on my Apple TV to force the audio output to Dolby 5.1 only. Still happens. (Don’t even mention Atmos, I don’t think my TV supports that. When I force the Apple TV to play Stereo only I have no issues. Just for Dolby 5.1 or what ever the source suppliers. What do I do ? Looks like it’s a common issue on here. Do I need to return the entire system ? 

It’s not Sonos.. it’s the firmware that needs to be updated corrected by the tv manufacturers. Sony has resolved this issue with their update. System works excellent now with Sony tv. You didn’t mention the tv brand you have but I suspect it’s Samsung (?). They have not got it straight yet. 

Sony has a fix??? That’s news to me!!! Still not working for me!!!

X900H

Sonos Arc, Sub, 2 x Sonos One

I have the exact configuration as yours and I have zero issues. 

Have looked into the HDFury Arcana option, if you also need an hdmi multi input for skyq and blu ray player etc that adds up to an additional £350 ish not to mention adding quality hdmi cables to all inputs required. How badly do we want to have Dolby Atmos?

Userlevel 1
Badge +1

@Corry P 
Corry, I’ve now tested over the past 2 weeks. It seems the issue is not completely gone when running Dolby Atmos through an Apple TV4K (in my setup). Additionally I’ve got the Arc and Samsung The Frame 2020 TV.

Watching Ted Lasso with Dolby Atmos on Apple TV+ on my Apple TV4K makes the sound cut for a few seconds every 15 minutes or so. The same when watching Netflix on Apple TV4K.

Watching local streaming TV with Stereo PCM, no problem.

 

Using the integrated Netflix app on the Samsung TV with Dolby Atmos, no problem.

Unfortunately Apple TV+ app doesn't support Dolby Atmos on the Samsung TV (yet?).

 

I read in another post, that the issue occurs when the TV switches to Dolby Digital Plus, but why would it switch to the DD+ in the first place ? Is this between playing Atmos and DD+ content / movies ?

 

I am quite unsure why the Apple TV makes mistakes, and who’s fault it is. Maybe you can enlighten us ?

I tried @tru3north advice to delete the Netflix app on my Apple TV4K and re-install it. After that I haven't been able to see the Dolby Atmos support logo’s on any movie. Everything is shown as 5.1, however when playing a movie, Dolby Atmos is supported and is streamed to Sonos Arc (as far as I can see in the Sonos app). I wonder if this has anything to do with feedback error or some kind of synchronising of data.

One other thing I noticed is that by starting any Netflix content, there is a short ‘no audio’ for a few seconds while the standard Netflix logo is being played before any title. 

Everything is updated to the latest firmware.

PS: I’ve submitted a diagnostics just when the cut-out appeared, but I forgot to note down the number. If you’d like me to try out different options or settings, please let me know.

@hi-tone don’t worry about not seeing the Atmos symbol in descriptions. Like you said, you are still getting Atmos. Netflix support told me that. The symbol appears and disappears without rhyme or reason. 
 

The question is does the audio cut in and out? You said you tried my suggestion. But you didn’t say if it fixed the audio. You mentioned no audio during the Netflix logo intro. But does the audio eventually come, and if it is all ok after?

Userlevel 1
Badge +1

@tru3north

Unfortunately it did not fix the issue. There is sound missing for 1-2 seconds when the Netflix logo appear after selecting a movie, then the sound kicks in, but it still cut-out the sound after every 15 minutes. Not only on Netflix, so it is generic.

Userlevel 5
Badge +14

Hi @hi-tone 

If you get Atmos at all from the Arc, then all is set up as it should be, and any issues after that are due to either content, the source (Apple TV), the physical connection, or the TV’s handling of external audio feeds. The TV’s handing of audio seems most likely, in your case.

Dolby Digital + is how you can get Atmos over HDMI-ARC rather than eARC. It should not switch mid playback, and if you watch content that only has compressed Atmos, rather than uncompressed, DD+ will be used, regardless of your connection.

Please unplug your TV from power for at least 30 seconds. If that doesn’t sort the issue out, you’ll likely need to wait for Samsung or Apple to release a software update. 

Feel free to get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system, and double check what’s happening here.

I assume the quiet Netflix logo is due to devices (presumably the Arc, but maybe the TV too) determining what kind of stream is being played at the start - if sound is played before it’s understood what format it’s in, you get some very nasty noises.

 

Reply