LG C9 and Sonos Arc


Userlevel 2
Badge +1

Hey all, my Arc was delivered this morning and I've had a chance to hook it up to my LG C9 directly via eARC and ran a few tests regarding Atmos and other features.

Built in apps:

  • Netflix - Reporting Dolby Atmos (DD+) for Atmos content.

  • Disney+ - Reporting Dolby Digital Plus 5.1 (though this is likely due to the current throttling taking place in the EU)

  • Amazon Prime - Reporting Dolby Atmos (DD+) for Atmos content.

Xbox One:

  • HDMI Audio set to Bitstream out and Bistream Format set to Dolby Atmos has no delay, finally! Displays Dolby Atmos in Sonos app.

PS4:

  • Like with the Xbox, there's no delay on Bitstream HDMI audio

NVidia Shield Pro:

  • Netflix - Reporting Dolby Atmos (DD+) for Atmos content.

  • Amazon Prime - Reporting Dolby Atmos (DD+) for Atmos content.

  • Disney+ - Reporting Dolby Digital Plus 5.1 (though this is likely due to the current throttling taking place in the EU). After connecting up to a US VPN it's reporting Dolby Atmos (DD+) for Atmos content.

  • PLEX - This is where it gets slightly annoying. Playing TrueHD content it reports Stereo 2.0. Setting Passthrough to HDMI reports Dolby Atmos (TrueHD). For DTS content you need to switch the Passthrough setting to Optical which in turn causes TrueHD to playback in Dolby Digital Plus 5.1.

Apple TV:

  • iTunes Content - Reports Dolby Atmos for Atmos content. Non Atmos content reports Stereo 2.0. With Change Format > On and New Format > Dolby Digital 5.1, I receive Dolby Digital 5.1 from non-Atmos iTunes content. I ran this test using Beetlejuice and Avengers Assemble.

  • Netflix - Reports Dolby Atmos for Atmos content.

  • Amazon Prime - Reports Dolby Atmos for Atmos content.

  • Disney+ - Reporting Stereo 2.0 for all content bizarrely. Setting audio output on the Apple TV to Dolby 5.1 allows all content to playback in 5.1 rather than stereo.

My C9 is running firmware 04.80.03 with the following settings:

Sound Out

HDMI ARC selected

Digital Sound Out set to Passthrough

eARC set to ON

Additional Settings

DTV Audio Setting set to Auto

HDMI Input Audio Format set to Bitstream.

 

If there's anything else I can test or any questions, let me know!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

134 replies

Badge

I've go an lg b9 and when I play something that is Atmos it shows on the tv as playing Dolby vision and then in the sonos app it shows dd+ I don't think that is Dolby Atmos is it?. If I unplug the arc and play the same Netflix prog through the tv speakers it says Dolby vision and underneath Dolby atmos

Userlevel 2
Badge +1

I've go an lg b9 and when I play something that is Atmos it shows on the tv as playing Dolby vision and then in the sonos app it shows dd+ I don't think that is Dolby Atmos is it?. If I unplug the arc and play the same Netflix prog through the tv speakers it says Dolby vision and underneath Dolby atmos

What device are you play content from?

Badge

The tv 

 

Userlevel 2
Badge +1

The tv 

 

If it’s playing Atmos content it should show in the Sonos app that it’s playing Dolby Atmos (DD+) or (Dolby Atmos (TrueHD). What are your audio settings on your B9?

Badge

ok so i have 

sound out hdmi arc. when i click  into hdmi arc the settings are

Digital sound out is auto (have tried setting it to passthrough and no different)  

eARC is set to on

 

when i go into netfrix options it has English (original) ( atmos) ticked.

When i look at the sonos ap it says arc is playing dolby digital plus 5.1

is it simply a labelling thing? nothing actually says ATMOS

 

Userlevel 2
Badge +1

ok so i have 

sound out hdmi arc. when i click  into hdmi arc the settings are

Digital sound out is auto (have tried setting it to passthrough and no different)  

eARC is set to on

 

when i go into netfrix options it has English (original) ( atmos) ticked.

When i look at the sonos ap it says arc is playing dolby digital plus 5.1

is it simply a labelling thing? nothing actually says ATMOS

 

What is it you’re watching on Netflix so I can test it out on my set?

This is exactly the same set of gear that I have (except still deciding on the Arc, and a Nintendo Switch). Been chasing lip sync problems for a while with my current soundbar, a Yamaha YSP-2700. 

So a few questions:

  1. Are you using a HDMI switch on one of the C9 inputs? And if so, is it introducing any problems with eARC to the Arc?
  2. How bad is the overlap with the insanely low C9 stand?
  3. How does it sound?
  4. Ugh, that Plex issue….

(edit - actually I suspect that the Shield/Plex problem might go away when Arc adds multi-LPCM. I also wonder if the AppleTV Disney+ problem just requires a force close of the app, or an AppleTV reboot).

Userlevel 4
Badge +3

This is very strange as I have the C9 and Apple TV 4K and in Disney I get 5.1 no issue and on prime i am only get 2.0 stereo?! So it seems I am getting something different to you even with the exact same set up?

Userlevel 3
Badge

Thanks Zophop - I also have a C9 and unfortunately Arc has been held up in delivery so won’t come until tomorrow. Couple of questions:

 

  1. If you stream content through the inbuilt Apple TV app, is it coming through as Atmos or DD 5.1?
  2. Do you have a Sky Q box hooked Up to the Tv and if so, any lip sync type issues?
  3. Odd the Disney + app isn’t coming through as Atmos, will hopefully sort itself out 

Sounds like it’s pretty much play and play for the C9 which is good!

Badge

ok so i have 

sound out hdmi arc. when i click  into hdmi arc the settings are

Digital sound out is auto (have tried setting it to passthrough and no different)  

eARC is set to on

 

when i go into netfrix options it has English (original) ( atmos) ticked.

When i look at the sonos ap it says arc is playing dolby digital plus 5.1

is it simply a labelling thing? nothing actually says ATMOS

 

What is it you’re watching on Netflix so I can test it out on my set?

6 underground..just as a test

Badge

Here is what it shows in netflix

 

 

Userlevel 2
Badge +1

This is exactly the same set of gear that I have (except still deciding on the Arc, and a Nintendo Switch). Been chasing lip sync problems for a while with my current soundbar, a Yamaha YSP-2700. 

So a few questions:

  1. Are you using a HDMI switch on one of the C9 inputs? And if so, is it introducing any problems with eARC to the Arc?
  2. How bad is the overlap with the insanely low C9 stand?
  3. How does it sound?
  4. Ugh, that Plex issue….

(edit - actually I suspect that the Shield/Plex problem might go away when Arc adds multi-LPCM. I also wonder if the AppleTV Disney+ problem just requires a force close of the app, or an AppleTV reboot).

  1. I’m not using an HDMI switch at the moment, but I’ll definitely be picking one up soon so I don’t have to keep swapping cables. If you’ve got a recommendation for a switch I don’t mind picking one up and testing it.
  2. Can’t comment sadly, I’ve got my C9 on the wall precisely to avoid this but I imagine it overlaps by at least an inch.
  3. It’s definitely an upgrade over my Playbar, I’ve not had a chance to watch a full movie on it yet as I’ve been testing various configurations but what I have watched of Blade Runner 2049 has been wonderful.
  4. The Plex issue is disappointing, but luckily it’s not the end of the world. It actually outputs DTS to the Arc however the Sonos app warns that it doesn’t support DTS and plays no audio. I did try rebooting the Apple TV and force closing the Disney+ app but still had the same problem. I imagine the problems due to a combination of the throttling in the EU and the lack of LPCM support on the Arc, when that releases it should in theory work perfectly with the Apple TV.
Userlevel 2
Badge +1

This is very strange as I have the C9 and Apple TV 4K and in Disney I get 5.1 no issue and on prime i am only get 2.0 stereo?! So it seems I am getting something different to you even with the exact same set up?

What’s your audio settings on the Apple TV set to? That’s really odd!

Userlevel 4
Badge +3

This is very strange as I have the C9 and Apple TV 4K and in Disney I get 5.1 no issue and on prime i am only get 2.0 stereo?! So it seems I am getting something different to you even with the exact same set up?

What’s your audio settings on the Apple TV set to? That’s really odd!

They are set to change audio NO and Atmos on! So the Atmos stuff on amazon is showing 2.0 and Disney Atmos is showing 5.1

Userlevel 2
Badge +1

Thanks Zophop - I also have a C9 and unfortunately Arc has been held up in delivery so won’t come until tomorrow. Couple of questions:

 

  1. If you stream content through the inbuilt Apple TV app, is it coming through as Atmos or DD 5.1?
  2. Do you have a Sky Q box hooked Up to the Tv and if so, any lip sync type issues?
  3. Odd the Disney + app isn’t coming through as Atmos, will hopefully sort itself out 

Sounds like it’s pretty much play and play for the C9 which is good!

  1. Using the inbuilt Apple TV app Atmos supporting content comes through as DD 5.1.
  2. I’ve not got a Sky Q box to test with as I’m a Virgin Media customer. The fact that the sync issues with the Xbox & PS4 seem to be solved hopefully bodes well for lip sync and the Sky Q.
Userlevel 2
Badge +1

Here is what it shows in netflix

 

 

That’s really odd, I’ve just tested with 6 Underground and my Sonos app is reporting Atmos

 

Badge

That is bizarre. I just turned earc off set pass through to no and played it. Turned them back on again and i now have atmos..Thanks for testing this for me zophop its much appreciated. So its all working on my B9 if anyone wants anything testing :-)

Userlevel 2
Badge +1

That is bizarre. I just turned earc off set pass through to no and played it. Turned them back on again and i now have atmos..Thanks for testing this for me zophop its much appreciated. So its all working on my B9 if anyone wants anything testing :-)

Brilliant, glad to hear it’s working for you now matey!

Userlevel 2
Badge +1

This is very strange as I have the C9 and Apple TV 4K and in Disney I get 5.1 no issue and on prime i am only get 2.0 stereo?! So it seems I am getting something different to you even with the exact same set up?

What’s your audio settings on the Apple TV set to? That’s really odd!

They are set to change audio NO and Atmos on! So the Atmos stuff on amazon is showing 2.0 and Disney Atmos is showing 5.1

So bizarre. What region are you in if you don’t mind me asking?

Userlevel 4
Badge +3

This is very strange as I have the C9 and Apple TV 4K and in Disney I get 5.1 no issue and on prime i am only get 2.0 stereo?! So it seems I am getting something different to you even with the exact same set up?

What’s your audio settings on the Apple TV set to? That’s really odd!

They are set to change audio NO and Atmos on! So the Atmos stuff on amazon is showing 2.0 and Disney Atmos is showing 5.1

So bizarre. What region are you in if you don’t mind me asking?

I am based in the UK

Userlevel 3
Badge

Thanks Zophop - I also have a C9 and unfortunately Arc has been held up in delivery so won’t come until tomorrow. Couple of questions:

 

  1. If you stream content through the inbuilt Apple TV app, is it coming through as Atmos or DD 5.1?
  2. Do you have a Sky Q box hooked Up to the Tv and if so, any lip sync type issues?
  3. Odd the Disney + app isn’t coming through as Atmos, will hopefully sort itself out 

Sounds like it’s pretty much play and play for the C9 which is good!

  1. Using the inbuilt Apple TV app Atmos supporting content comes through as DD 5.1.
  2. I’ve not got a Sky Q box to test with as I’m a Virgin Media customer. The fact that the sync issues with the Xbox & PS4 seem to be solved hopefully bodes well for lip sync and the Sky Q.

Cheers - bit frustrating the built in Apple TV app only outputs in 5.1 - hopefully they will fix this through a patch

Userlevel 2
Badge +1

This is very strange as I have the C9 and Apple TV 4K and in Disney I get 5.1 no issue and on prime i am only get 2.0 stereo?! So it seems I am getting something different to you even with the exact same set up?

What’s your audio settings on the Apple TV set to? That’s really odd!

They are set to change audio NO and Atmos on! So the Atmos stuff on amazon is showing 2.0 and Disney Atmos is showing 5.1

So bizarre. What region are you in if you don’t mind me asking?

I am based in the UK

I’ve just reset my Apple TV and I’m still getting Atmos in Netflix and Amazon but only 2.0 in Disney+, so weird. 

Userlevel 3
Badge

https://www.google.co.uk/amp/s/www.imore.com/dolby-atmos-support-apple-tv-app-coming-lg-smart-tvs-later-year%3famp
 

Looks like built in Apple TV app will be getting Atmos support later this year

Userlevel 5
Badge +8

 

 

If there's anything else I can test or any questions, let me know!

When your TV is off, and you power TV on, how long before you hear sound from Arc?

I have LG series8 (previous model), when I power on takes about 2 seconds before I see a picture on TV, and then another 4 or 5 seconds before I see a green LED flash on Arc and I hear sound from Arc.

I previously had a Playbar connected via optical, and I would hear sound as soon as picture appeared, so I’m curious where the delay is.

TIA!

Userlevel 7
Badge +26

Thanks for sharing and helping out @Zophop!