F.A.Q.

Troubleshooting Sonos on WiFi

Troubleshooting Sonos on WiFi
Userlevel 7
Badge +18

Hi Folks, 

I’ll share some general advice about how Sonos products connect to your network, and the kind of network problems that can result in dropping rooms, to help you understand and solve some challenges with your Sonos system.

Updated 21/4/23

 

2.4 & 5GHz bands (and WiFi 6)

A few older Sonos devices will only connect to the 2.4GHz band, whereas most will connect to the 5GHz band broadcasted from your router. A full list of which devices will connect to 5GHz can be found here on our Supported WiFi modes and security standards for Sonos products page, under “Products that can connect to 5GHz WiFi networks”. Era 100 and Era 300 will connect to 802.11ax (WiFi 6) or 802.11ac (WiFi 5).

Home Theatre products will not connect to 5GHz, as the 5GHz radio is reserved for talking to the surrounds and Sub(s).

Sonos will perform best on 5GHz as it is faster, has lower latency and has less congestion. 2.4GHz still has it’s advantages, however, as physics dictates that it has a better range and a stronger solid-matter penetration ability (it gets through walls, ceilings and furniture easier), so do not be too concerned if your router informs you that your Sonos device is utilising it. Due to the amount of varied use of 2.4GHz, it can be important to ensure that you do not use channels that overlap with other nearby sources (1, 6 & 11 are the only channels that do not overlap - it’s best to stick with these).

Although we used to recommend splitting the bands on your router so that they had different credentials, we now recommend letting the router do it’s work with band steering - this way, one set of credentials can get all your devices connected to the best band for them (this will vary with model and location/reception). If in doubt, please get in touch with our technical support team.

 

Mesh Networks

If you have a mesh WiFi system to extend the range of your WiFi, and your original router is still present, you must either:

  • Configure your router to act as a modem only. Some have a specific option for this (like Virgin Media in the UK), but on most router’s you’d need to disable the DHCP server. If you still need to use the WiFi coming from your router, or if you connect devices via ethernet to it, this is not an option. Doing this will allow you to use the usually more advanced routing features on your mesh (as compared to those on a free, ISP-provided router).

    or
  • Configure your mesh system to be in ‘Bridge/AP mode’ - otherwise it acts as a router and you now have two logical networks running on one hardware layer (this is commonly referred to as Dual DHCP). To find out how to do this, perform an internet search for “[name of your mesh system] mesh bridge mode”. I’ve listed a few common ones here:

 

Netgear Orbi mesh: https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point

Linksys Velop mesh: https://www.linksys.com/us/support-article?articleNum=243548

Tenda mesh: https://www.tendacn.com/faq/3123.html

Eero mesh: https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-

Google mesh: https://support.google.com/wifi/answer/6240987 - In my experience Google mesh systems can be difficult about going into Bridge mode. Please contact Google if you have trouble with this.

 

Extenders / Boosters / Powerline adapters / Sky Q

Another challenge, with networking and Sonos, is WiFi boosters and extenders. Sonos does not support these as they halve your available bandwidth (due to being half-duplex) and often block multicast transmissions which gets in the way of the Sonos system from operating smoothly. 

Powerline line adaptors can also induce additional issues as they are subject to noise present on your mains power supply (‘noise’ is created by some LED dimmers, for example).

In the UK, Sky Q boxes can be a challenge with Sonos, as they repeat the WiFi from a Sky router (but not from other routers). If a speaker connects to one of these (common with Sonos Home Theatre products) it can result in the speaker being missing from the Sonos app. One option would be to use SonosNet by connecting one or more Sonos devices (not Era - Era does not use or create SonosNet) to the network with an ethernet cable. For other options, I recommend contacting our technical support team.

 

Sonos and Ethernet

To bypass some WiFi configuration issues, you can connect any one (or more) Sonos devices to the network with an ethernet cable (Sonos Move & Roam excluded). Wired Sonos products (other than Era models) will transmit a ‘Sonos only WiFi’ for use by your other Sonos devices (Sonos Move, Roam & Era excluded). This all happens automatically, but sometimes your speakers need a power cycle (unplug them from the wall socket, and plug them back in again after 30 seconds) to help them along. Wiring Sonos will not resolve anything if you have two routers on your network (as described in the Meshes section). Each Sonos player that picks up the ‘Sonos only WiFi’ from the wired Sonos speaker will rebroadcast it, thus extending the range for speakers out of range of the wired one(s). 

When you wire a Sonos product, you go from a configuration like this:

Sonos using your WiFi​​​​

to one like this:

Sonos using Sonosnet

It is worth pointing out, however, that the bandwidth available on 2.4GHz (which SonosNet uses) is limited. If you’re going to group a lot of rooms together, we recommend having one wired unit for every 5 non-wired units, and these wired units would ideally be evenly distributed in your home.

As long as you have good WiFi coverage, your router’s WiFi will often be a better option. As became evident with the release of the Era speakers, we are now moving away from SonosNet which was only really needed back when routers were not the more capable devices that they are today.

 

WiFi Noise / WiFi interference

Sometimes it’s just not a network configuration issue. All WiFi devices (not just Sonos) like to have at least 1 meter / 3 feet of space from all other WiFi devices (and devices that are not on your WiFi but may use similar frequencies). In my experience, one of the most common solutions to a ‘WiFi problem’ has been to physically move a speaker/Boost/Bridge farther away from the router it’s wired to. A common misconception is that the closer the device is to the WiFi broadcasting unit the better - this is not the case. Sometimes speakers are kept very close the router, but this is far from ideal - these devices should not be located less than 1m apart from each other. We have a helpful guide on reducing wireless interference. Close by glass or metal surfaces can reflect WiFi back at a device and also create interference. 

Interference is, I would say, the biggest cause of problems, like dropped rooms, or music interruptions, for Sonos users.

Many non-WiFi devices will use 2.4GHz - mobile/cellular telephones, baby monitors, smart meters, CCTV cameras, DECT phones, microwave ovens - the list goes on. This is another reason why 5GHz can be a better choice for your Sonos system to connect to - less congestion, more channels, more bandwidth, better experience.

 

Home Theatre

As mentioned above, Home Theatre Primary devices (like Ray, Beam or Arc) will connect to 2.4GHz WiFi or SonosNet. However, their surround speakers and Sub(s)/Sub Mini will connect directly to the HT Primary over a dedicated, low latency 5GHz channel. So, if you ever experience audio interruptions on your surrounds or Sub, keep in mind that the cause could be interference near the HT Primary just as much as it could be interference near the surrounds/Sub.

Audio interruptions of TV audio heard on the Home Theatre Primary itself have nothing to do with interference or networking - this is most commonly fixed by forcing the TV’s software to restart by unplugging the TV for a couple of minutes.

 

Network Configuration (IP Reservation and IGMP Filtering)

Sonos needs no more from your network than many other devices, but it can often help to reserve IP addresses for the devices that commonly connect to your network, including Sonos.

Normally, connecting devices send out a broadcast asking to be assigned a unique IP address so that they can be found and recognised on the network. If, for whatever reason, the router loses track of which clients have which addresses (if it reboots but the devices keep their IP, for example) it can start distributing out IP addresses that are already in use. This can result in the Sonos app asking a particular speaker (by it’s IP) if it is still online and ready to operate, but because the speaker is in fact a smart refrigerator, it doesn’t reply, resulting in a room dropping from the Sonos app.

To combat this, reserve IP addresses in your router’s settings pages for all the devices that commonly connect. This will greatly reduce the chance of such an occurrence, and has often been the answer to many user’s woes.

How to do this exactly will depend on your router, but the option is typically found in the Network or DHCP section of the settings. If your router has a Basic/Advanced settings division, this will most likely be in Advanced. Please consult your router’s manual. For a typical installation, your router’s own IP address will be, for example, 192.168.0.1, 192.168.1.1 or 10.0.0.1 (though other addresses are possible and common). The “DHCP pool” will be a range of addresses that the router will distribute to client devices, which will often range from 2 to 254 on the last number of the address. I recommend narrowing this somewhat to perhaps 30 (or higher if needed) to 254, then reserving addresses for regular client devices (including Sonos) between 2 and 29.

After making any such changes, it’s a good idea to reboot the router and then the devices that connect to it, but from then on things should be pretty stable.

Not all routers have IGMP Snooping/Filtering, but if yours does, it’s a good idea to turn it on. This feature prevents multicast (more than one destination) data packets on the network that are not destined for Sonos devices from clogging up your speakers’ network input buffer with data it doesn’t want. IGMP-capable network switches can also be bought cheaply, but will only help a Sonos system using SonosNet, and should be fitted between the router and any Sonos devices wired to it.

 

Controllers

It may be that you cannot connect to Sonos not because your Sonos system is having trouble connecting to the network, but because the device you’re running the Sonos app on is unable to communicate with the System (or parts of it).

Although this can be caused by a few things, the most likely are the following:

  • Multiple Access Points - WiFi boosters and Extenders tend not to work very well. Often, you can only connect to rooms that also connect to the same extender your phone is on, or can’t connect to them because your phone is on the main router’s WiFi. We don’t support the use of these products for this reason. Mesh systems are not affected by this. In the UK, Sky Q boxes repeat WiFi from Sky routers in this way.
  • Guest WiFi - You cannot run Sonos on a Guest WiFi, nor can the Sonos app connect to a Sonos system if the controller is connected to a Guest WiFi.
  • On iOS devices - make sure you give the Sonos app permission to access devices on the Local Network (more info on our Sonos app permissions help page)
  • On iOS devices - make to to disable Private Address in the iOS connection options for your WiFi network.

 

Help

Sometimes, no matter how much you know, the speakers themselves have to be ‘consulted’ as to what is going wrong before you will find a resolution. In such situations, the only solution is to get in touch with our technical support team who can receive your Sonos system diagnostics which will tell the agent all about what your system has experienced. If you’re going to call/chat with our tech agents, please try to recreate the issue you are experiencing just before getting in touch, if you can, and try not to reboot any players - reboots clear the system logs and as a result the diagnostics contain less information. 

 

I hope this helps you to understand a bit of what’s going on when no steps taken seem to be working for you. As always, we’re more than happy to assist with getting your Sonos system stable, so please either get in touch with our tech support if nothing works, or write here on the community if you need more guidance.

 

 

Edit: Updated to include additional mesh options, Roam and some other details.

Edit: Updated to include iPhone Local Network and Private Addresses options as they can affect connecting to Sonos

21/4/23 Edit: Changed some advice regarding WiFi bands to reflect software improvements, added Network Configuration and Home Theatre advice


92 replies

This is ridiculously complicated for a system that costs what Sonos does and purports to do easily.

I just spent 2 hours trying to change the network my 4 sonos speakers connect to.   Error after error for something that should be easy enough.  Im done with it.  Piece of trash 

I’m not sure what is really that complicated about wiring one Sonos device only to the new router and rebooting all other speakers, Then opening the mobile App (connected to the new router WiFi). Wait just a minute, or two, for all speakers to show - then add the new WiFi SSID/Password to all via ‘Update Networks’ in the Apps network settings.

Oh and perhaps don’t forget to remove the old WiFi credentials from the system too (if no longer needed). This WiFi switchover must take all of 10 minutes.

I’ve done it three times. Followed the new router - installation instructions FAQ. Never had an issue. 

Fantastic article.  I appreciate the depth of it.  Unfortunately it did not help with my issue.  I have a Meraki MS220-48LP switch with ERSTP disabled and STP blocking disabled with a suggested bridge of 4096.  I also have two Meraki MR28 access points in a mesh network on the same channels (2.4 and 5.0 GHz radios).  I have 9 Sonos pieces on the network  three of them amps and all wired to the network.  My bar, sub, and two rear channels along with a Five are wireless.  This evokes the SonosNet but I see all devices wired and wireless on my Meraki network.

Here’s the issue.  If I open my Sonos app on my Mac via a wired connection, I see all Sonos hardware.  If I attempt to use the app when on the WiFi, they disappear.  My iPhone app shows nothing via WiFi as well.  Why?  Obviously it has something to do with my WiFi.  What am I missing? 

Userlevel 7
Badge +23

Fantastic article.  I appreciate the depth of it.  Unfortunately it did not help with my issue.  I have a Meraki MS220-48LP switch with ERSTP disabled and STP blocking disabled with a suggested bridge of 4096.  I also have two Meraki MR28 access points in a mesh network on the same channels (2.4 and 5.0 GHz radios).  I have 9 Sonos pieces on the network  three of them amps and all wired to the network.  My bar, sub, and two rear channels along with a Five are wireless.  This evokes the SonosNet but I see all devices wired and wireless on my Meraki network.

Here’s the issue.  If I open my Sonos app on my Mac via a wired connection, I see all Sonos hardware.  If I attempt to use the app when on the WiFi, they disappear.  My iPhone app shows nothing via WiFi as well.  Why?  Obviously it has something to do with my WiFi.  What am I missing? 

Make sure broadcasts and multicasts (eg mDNS and SSDP) can pass between the WiFi and the wired network. (I am assuming they are all on the same subnet which is also a requirement).

controlav, that was it!  The Meraki AP has a Firewall & Traffic Shaping section which contained an Outbound rules policy to deny Any IPv4 to Any Local LAN Destination Port.  I changed DENY to ALLOW and - bam! - everything came up!   Thank you so much for the help!

Had a ‘could not find sonos product’ after I installed an Eero6+ mesh WiFi. My modem is an Arris NV6468MQ and I disabled the Arris Wifi so that radio signal didn’t conflict with the Eero. My Eero system works great, but I could not reconnect Sonos by the traditional method of ethernet to router. After an unsuccessful 1+hr call with Tech Support, I tried connecting the amp to a standalone Eero unit via ethernet and Viola!, it works perfectly. This ethernet connection has to be on one of the remote Eero pods to work (not the one hard wired to the modem). Even though my Eero system uses the same login and pw credentials to connect, it is a different network so this problem is solved!

Userlevel 7
Badge +18

Hi @Nickytoes 

I suspect that the issue is due to the fact that disabling WiFi on your original router is not enough - did you either disable the DHCP server on the original router, or put the Eero system into Bridge/AP mode? You must do one or the other to avoid DHCP conflicts on the network.

https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-

I hope this helps.

Thank you. I initially installed the Eeros system without disabling the router and everything connected but Wifi didn’t seem to be any stronger. Then I configured the modem/router to bridge mode and that failed. I called the ISP and they stated they don’t support Bridge mode, so they made changes, but it appears DHCP is still enabled, but they disabled the 2.4 and 5ghz radios and now the signal via Eero works great. This is when I couldn’t re-connect to Sonos. By connecting my Sonos amp to one of the Eero nodes (not the one connected to router), this allowed the entire system to be visible upon opening my S1 app without any further adjustment. Thank you for clarifying the other options above and I’ll keep it for reference if I run into any problems. 

Userlevel 6
Badge +11

No isp will support bridge mode as the router will not accept updates and they don’t like that they have no control 

I have a huawei cpe pro 2 from three and i also bought cpe pro 3 which I own

i have setup both as bridge mode and my eero pro 6 system controls dhcp etc

my arc is connected to the main eero via a switch and have no issues with any of my Sonos products 

Userlevel 7
Badge +18

Hi @Nickytoes 

Please be aware, therefore, that your Sonos system will rely entirely on the quality of the wireless connection between the main Eero node and the secondary one that the Amp is wired to. Make sure it is located somewhere where the signal from the main node is sufficiently strong (some people locate them where the WiFi signal is weak, which is not what you want to do).

It certainly counter-intuitive, however - as @skullc states, wiring to the main node should be the answer (or just using WiFi, now that you have a mesh).

I hope this helps.

Hey, wanted to share a solution.

I was working fine for a while, but then my Arc would no longer show up in my Sonos app on my iPhone.  I was also experiencing some momentary audio dropouts (TBD if this is resolved, it was rare).

I’m running a Ubiquiti UDM router/AP.  I noticed when I was looking at the clients that the Arc was connecting on the 5Ghz network and not the 2.4GHz.  I was confused because I thought it only used the 2.4GHz channels, but reading forums found that it uses 5GHz channels for inter-Sonos communication.

I think band-steering on my Ubiquiti AP was trying its darndest to shift the Arc onto the 5GHz spectrum.  Once I turned it off, the Arc stayed on the 2.4GHz wifi and I no longer had any problems connecting to it from the app.

I had the same problem and my solution was toe enable wifi on my arc (which I disabled since it’s connected with lan). The rears connect directly to the arc with 5GHz which make sure a they are in sync. 
 

on my Google wifi the rears are now reported as connected with wire (bridging via arc)

Userlevel 1
Badge +1

I want to share my experience as just another datapoint for something I changed that has now made it rock-solid in my home (so far anyways!). My Sonos system has always struggled with dropouts, disconnections, etc. I used to have Bridge and Boost to help over the years, then just the Boost for SonosNet. I still had issues, but less of them. And I use Roon … which was also just awful with Sonos.

I just recently replaced my old mesh system (SmartThings WiFi Mesh that got broken by Samsung and Plume recently) with a Deco XE75 Pro x3. I love love love the new/strong WiFi mesh network with this setup as it resolved a lot of various issues I had … however, for Sonos it got WORSE! I was so unhappy … I really thought this was going to help. BUT .. I didn’t give up. I thought “what if I go ALL WiFi with Sonos and get rid of the Boost and SonosNet?” So I did my research and saw this post amongst many on how you can setup Sonos with either a wired or wireless network, and how it can actually work great if everything is just wireless (i.e. get rid of SonosNet and/or the Boost!). So I did this … I removed the Boost and went all WiFi for Sonos with my new mesh system. And I cannot remember the last time it was this stable … and fast! Everything is speedy, and even Airplay now works well for me whereas in the past Airplay always gave me problems.

Needless to say, I just wanted to share this in case others may want to try this approach to see if it happens to resolve your issues. So far I am really happy with this ALL WIFI setup (fingers crossed that it continues). ☮️

Userlevel 7
Badge +22

I had the same problem and my solution was toe enable wifi on my arc (which I disabled since it’s connected with lan). The rears connect directly to the arc with 5GHz which make sure a they are in sync. 
 

on my Google wifi the rears are now reported as connected with wire (bridging via arc)

Sadly the Sonos option “Disable WiFi” is not a correct indication of what it actually does when selected.

What it actually does is “Disable Radio” and that would be the radio used to connect to the Sub /Surround speakers as well as WiFi.

I’ve been trying for days now to connect my Play 1 to WiFi since switching ISP.

I go through the steps in the app to reconfigure network settings, press play/pause and volume up but just hangs when connecting to device and times out.

I’ve been trying for days now to connect my Play 1 to WiFi since switching ISP.

I go through the steps in the app to reconfigure network settings, press play/pause and volume up but just hangs when connecting to device and times out.

Sometimes rebooting the router, speaker and mobile device can fix the issue - the steps to follow are the ones mentioned here:

https://support.sonos.com/en-us/article/connect-sonos-to-a-new-router-or-wi-fi-network
 

If the issues persist after rebooting all, then it maybe best to contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

Thanks for the reply.  I’ve tried the reboots so may have to get in touch with support.

Reply