F.A.Q.

Troubleshooting Sonos on WiFi

Troubleshooting Sonos on WiFi

Show first post

87 replies

This is ridiculously complicated for a system that costs what Sonos does and purports to do easily.

I just spent 2 hours trying to change the network my 4 sonos speakers connect to.   Error after error for something that should be easy enough.  Im done with it.  Piece of trash 

I’m not sure what is really that complicated about wiring one Sonos device only to the new router and rebooting all other speakers, Then opening the mobile App (connected to the new router WiFi). Wait just a minute, or two, for all speakers to show - then add the new WiFi SSID/Password to all via ‘Update Networks’ in the Apps network settings.

Oh and perhaps don’t forget to remove the old WiFi credentials from the system too (if no longer needed). This WiFi switchover must take all of 10 minutes.

I’ve done it three times. Followed the new router - installation instructions FAQ. Never had an issue. 

Fantastic article.  I appreciate the depth of it.  Unfortunately it did not help with my issue.  I have a Meraki MS220-48LP switch with ERSTP disabled and STP blocking disabled with a suggested bridge of 4096.  I also have two Meraki MR28 access points in a mesh network on the same channels (2.4 and 5.0 GHz radios).  I have 9 Sonos pieces on the network  three of them amps and all wired to the network.  My bar, sub, and two rear channels along with a Five are wireless.  This evokes the SonosNet but I see all devices wired and wireless on my Meraki network.

Here’s the issue.  If I open my Sonos app on my Mac via a wired connection, I see all Sonos hardware.  If I attempt to use the app when on the WiFi, they disappear.  My iPhone app shows nothing via WiFi as well.  Why?  Obviously it has something to do with my WiFi.  What am I missing? 

Userlevel 7
Badge +23

Fantastic article.  I appreciate the depth of it.  Unfortunately it did not help with my issue.  I have a Meraki MS220-48LP switch with ERSTP disabled and STP blocking disabled with a suggested bridge of 4096.  I also have two Meraki MR28 access points in a mesh network on the same channels (2.4 and 5.0 GHz radios).  I have 9 Sonos pieces on the network  three of them amps and all wired to the network.  My bar, sub, and two rear channels along with a Five are wireless.  This evokes the SonosNet but I see all devices wired and wireless on my Meraki network.

Here’s the issue.  If I open my Sonos app on my Mac via a wired connection, I see all Sonos hardware.  If I attempt to use the app when on the WiFi, they disappear.  My iPhone app shows nothing via WiFi as well.  Why?  Obviously it has something to do with my WiFi.  What am I missing? 

Make sure broadcasts and multicasts (eg mDNS and SSDP) can pass between the WiFi and the wired network. (I am assuming they are all on the same subnet which is also a requirement).

controlav, that was it!  The Meraki AP has a Firewall & Traffic Shaping section which contained an Outbound rules policy to deny Any IPv4 to Any Local LAN Destination Port.  I changed DENY to ALLOW and - bam! - everything came up!   Thank you so much for the help!

Had a ‘could not find sonos product’ after I installed an Eero6+ mesh WiFi. My modem is an Arris NV6468MQ and I disabled the Arris Wifi so that radio signal didn’t conflict with the Eero. My Eero system works great, but I could not reconnect Sonos by the traditional method of ethernet to router. After an unsuccessful 1+hr call with Tech Support, I tried connecting the amp to a standalone Eero unit via ethernet and Viola!, it works perfectly. This ethernet connection has to be on one of the remote Eero pods to work (not the one hard wired to the modem). Even though my Eero system uses the same login and pw credentials to connect, it is a different network so this problem is solved!

Userlevel 7
Badge +18

Hi @Nickytoes 

I suspect that the issue is due to the fact that disabling WiFi on your original router is not enough - did you either disable the DHCP server on the original router, or put the Eero system into Bridge/AP mode? You must do one or the other to avoid DHCP conflicts on the network.

https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-

I hope this helps.

Thank you. I initially installed the Eeros system without disabling the router and everything connected but Wifi didn’t seem to be any stronger. Then I configured the modem/router to bridge mode and that failed. I called the ISP and they stated they don’t support Bridge mode, so they made changes, but it appears DHCP is still enabled, but they disabled the 2.4 and 5ghz radios and now the signal via Eero works great. This is when I couldn’t re-connect to Sonos. By connecting my Sonos amp to one of the Eero nodes (not the one connected to router), this allowed the entire system to be visible upon opening my S1 app without any further adjustment. Thank you for clarifying the other options above and I’ll keep it for reference if I run into any problems. 

Userlevel 6
Badge +10

No isp will support bridge mode as the router will not accept updates and they don’t like that they have no control 

I have a huawei cpe pro 2 from three and i also bought cpe pro 3 which I own

i have setup both as bridge mode and my eero pro 6 system controls dhcp etc

my arc is connected to the main eero via a switch and have no issues with any of my Sonos products 

Userlevel 7
Badge +18

Hi @Nickytoes 

Please be aware, therefore, that your Sonos system will rely entirely on the quality of the wireless connection between the main Eero node and the secondary one that the Amp is wired to. Make sure it is located somewhere where the signal from the main node is sufficiently strong (some people locate them where the WiFi signal is weak, which is not what you want to do).

It certainly counter-intuitive, however - as @skullc states, wiring to the main node should be the answer (or just using WiFi, now that you have a mesh).

I hope this helps.

Hey, wanted to share a solution.

I was working fine for a while, but then my Arc would no longer show up in my Sonos app on my iPhone.  I was also experiencing some momentary audio dropouts (TBD if this is resolved, it was rare).

I’m running a Ubiquiti UDM router/AP.  I noticed when I was looking at the clients that the Arc was connecting on the 5Ghz network and not the 2.4GHz.  I was confused because I thought it only used the 2.4GHz channels, but reading forums found that it uses 5GHz channels for inter-Sonos communication.

I think band-steering on my Ubiquiti AP was trying its darndest to shift the Arc onto the 5GHz spectrum.  Once I turned it off, the Arc stayed on the 2.4GHz wifi and I no longer had any problems connecting to it from the app.

I had the same problem and my solution was toe enable wifi on my arc (which I disabled since it’s connected with lan). The rears connect directly to the arc with 5GHz which make sure a they are in sync. 
 

on my Google wifi the rears are now reported as connected with wire (bridging via arc)

Reply