Sonos Beam and Bose QC headphones in Samsung TV


Userlevel 3
Badge +2
I have the Beam working via HDMI on my TV and when I switch in my headphones to connect to the TV via Bluetooth, it works initially and TV says disconnecting Anynet+ device (the Beam) but then it seems to immediately reconnect the Beam and so not allowing me to switch to the Bluetooth headphones. Any ideas on how to get this working without having to switch Anynet off and on in the menu all the time? My Samsung is a 2015 UHD model.

154 replies

Pretty much the same than ppl statement - in 2021, product designed without basic interaction capabilities that compete product allows without further tweaks is a down vote on the market. I’ll return my Sonos Arc for other compatible product that could allow a seamless experience across devices. Cheers.

Surprisingly, this issue has been there for 2+ years and it’s still there. I just bought an Arc yesterday (5/2/2021)and got problem with my Bose headphone being hijacked after few seconds.

 

Someone said due to spec of CEC/HDMI bla...bla. and turning off Any+net, ... Then why Samsung HW-Q800A/ZA soundbar has no such problem? The Samsung soundbar also connected to TV via the same wire and same port (eArc), why it allows me to switch among TV Speakers, Headphone, and Soundbar seamlessly?

 

I like Arc sound more than Samsung’s, but I have to return the Arc due to this annoying problem. I use headphone a lot at night, so I can accept this issue. Blaming on TV doesn’t make sense because others  can produce theirs soundbar with the same technology and have no such problem

Likewise for a Samsung TU8000 and an Arc.  With Anynet+ enabled, the Bluetooth headphones will connect and be disconnected instantaneosuly.  As frustrating as it is, it is part of the CEC/HDMI.  My solution was simply to disable Anynet+ unfortunately.

Thanks, I have tried the optical output connected to a Bluetooth transmitter. Unfortunately the Sonos soundbar hijacks it away from the optical output too. No dual output.  
 

I could connect the the TV to the soundbar using the optical cable, but then I’m not sure what would happen to the Atmos surround sound, i assume the remote control would still adjust the volume, but some other functions might be lost. Any thoughts on that? 

Thanks, to do that I have to stop watching whatever is showing on my TV,  navigate to settings>general >external device manager>Anynet+ and then toggle it off. When I finish, I have to go through the same process to enable the Sonos soundbar again.
 

To take out the HDMI cable takes one step, and a fraction of the time. It’s like DOS v GUI.
 

I’m not sure how everyone on this forum can get the message across to Sonos. Maybe there’s someone like Steve Jobs there, who could explain it better to the development team. 

But you will ‘likely’ end up with having to then find your mobile device, open up the Sonos App, goto ”Settings/System/[Sonos HT Room]” and toggle off HDMI-CEC control to listen to the headphones and have to then toggle the setting back on afterwards. I don’t see the point.
 

Changing the setting on the TV (with the option that exists for it already) seems the better of the two IMHO.
 

The other alternative is to use the optical-out Port perhaps (if your TV supports dual audio-out) and connect that to a BT transmitter. I don’t personally see this as something Sonos need to fix, but it’s possibly something the TV manufacturer(s) needs to resolve with the HDM-CEC protocol standard.

Thanks, to do that I have to stop watching whatever is showing on my TV,  navigate to settings>general >external device manager>Anynet+ and then toggle it off. When I finish, I have to go through the same process to enable the Sonos soundbar again.
 

To take out the HDMI cable takes one step, and a fraction of the time. It’s like DOS v GUI.
 

I’m not sure how everyone on this forum can get the message across to Sonos. Maybe there’s someone like Steve Jobs there, who could explain it better to the development team. 

This is also my only reason for signing up to this forum. I am pulling out the HDMI cable every second night so I can use my headphones. Every time I do it I shake my head at the Sonos engineers and the product development team. Are we customers that irrelevant? This thread has gone on for a couple of years and no fix in sight. 

Perhaps try simply switching off HDMI-CEC in the TV settings to listen to the audio through headphones, no need to keep removing the HDMI connection… even if Sonos engineers did do this, they would likely give you a ‘Settings’ switch to toggle off CEC and as it’s already there in your TV settings, you are perhaps best to select that ‘existing’ option.

This is also my only reason for signing up to this forum. I am pulling out the HDMI cable every second night so I can use my headphones. Every time I do it I shake my head at the Sonos engineers and the product development team. Are we customers that irrelevant? This thread has gone on for a couple of years and no fix in sight. 

Hi All, just joined this community to share my frustration on this. 

It’s simple: 1. allow us to connect our headphones to the beam, or 2. let us use the tv’s bluetooth functionality.

As others have raised already, other CEC connected soundbars are not having these issues with ie Samsung or LG tv’s, so surely there must be a way to fix this with an update. I am sure the Sonos team would agree that pulling out hdmi cables or having to go into advanced tv settings to shut off CEC is not a solution, but rather a workaround to a problem.

Also, I’ve read through all messages here and it surprises me that there hasn’t been an official response from Sonos on this in 2 years?

Thanks all for raising your concerns on this thread-let’s make sure the Sonos engineers read this...

 

This needs a fix, it's ridiculous. 

…. (never mind)

 

That's a little to complicated for girlfriend and daughter. Also my settopbox loses his connection.

Userlevel 7
Badge +17

You could turn off HDMI-CEC (Anynet) any time you want to use your headphones.

Just installed my Beam and found out this “feature"….

Disconnect the HDMI seems to solve the issue so is a manual HDMI switch a solution?

Simply turn on headphone; accept yes on tv (Everytime...Why not automatically Samsung? another frustration) and press manually the button of the HDMI switch behind the beam. When finishing; turn off the headphone and press the button on the switch.

Looks like a solution??

 

 

This remains a ‘feature’ of CEC, which Sonos has no control over changing the specifications of. 

Just discovered this, what a nightmare. Please just make it optional as a minimum. 

Really disappointed 

Same here.

should've been fixed already 😫

Just discovered this, what a nightmare. Please just make it optional as a minimum. 

Really disappointed 

In their attempt to “idiot-proof” device setups, they’ve willfully broken the ability for us to use another audio output on our TVs.

 

Please Sonos, just make it an option we can change. You can keep your dumb feature as default. Some of us with brains can handle it.

Userlevel 1

I just bought a Sonos Arc and am experiencing the same issue. Still thinking about returning, this is unacceptable and I do not understand why Sonos does not do anything about it.

 

There are several other posts in the forum reporting similar issues, so this should be dealt with a higher priority.

As a result of this “feature”, I decided to sell my Sonos Beam. Its a shame but I just could not accept these workarounds, not for that price

So, got my Beam recently and finally discovered this fun “feature” which led me here.

My setup is a Beam plus Samsung KS8000 (2017 model)

 

Even Samsung’s “Multi-output audio” accessibility feature is overridden by this damn thing. Connecting an optical to BT transmitter is the only way to go. Fortunately in my case, I already own one of these… but I understand the frustration of being told to go buy something else.

 

For those that want to solve the issue this way, I recommend this one. It has APTX low latency support and also allows two pairs of headphones at the same time, should you ever want that.

 

https://www.amazon.com/gp/product/B00QV77YIC/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

I should add one thing to this. This device (as well as seemingly every other similar one, I checked) requires your tv sound output to be set to PCM. This is disappointing, as the Beam sounds a lot better with the Dolby Digital output. My TV does not let me have separate output settings for SPDIF and ARC, unfortunately. If other ones do, you’re in better luck.

 

So I’m still stuck toggling a setting in the menu, if I want to use the headphones but also have DD sound on the Beam.

Been having an eye on the Beam (since I purchased my Samsung Q70R TV last November) because of its small footprint, sound quality and doubles-up a smart speaker in the family room.

Having my son’s bedroom close by, we use Bluetooth headphones quite often in the evening and this issue prompted me to hold off on buying the Bean.

After seeing stoonk’s post, I decided to make the jump since an update was fixing the issue.

Unfortunately, even with the latest update installed on my TV, the audio source switches back to the Beam seconds after selecting my XM3s.

Right now, I’ve opted to go with the optical setup for the Beam as a workaround.

So, if you consider purchasing the Beam and use Bluetooth headphones, take note that the issue might be stillpresent with your Samsung TV.

So, got my Beam recently and finally discovered this fun “feature” which led me here.

My setup is a Beam plus Samsung KS8000 (2017 model)

 

Even Samsung’s “Multi-output audio” accessibility feature is overridden by this damn thing. Connecting an optical to BT transmitter is the only way to go. Fortunately in my case, I already own one of these… but I understand the frustration of being told to go buy something else.

 

For those that want to solve the issue this way, I recommend this one. It has APTX low latency support and also allows two pairs of headphones at the same time, should you ever want that.

 

https://www.amazon.com/gp/product/B00QV77YIC/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

Seems like an older thread, I was having this issue with a 2019 samsung tv about a month ago, was annoyed and gave up.

 

Tried again today after a software update from samsung and it is fixed. now watching netflix via headphones with the kids sleeping...

I have Samsumg Q950 82” TV with Beam and also Sony XM3 headphones. I find it completely crazy that Sonos does not follow standard CEC protocol and requires me to use separate Bluetooth transmitter for headphones (connected to optical out) because of this stupid “feature”.

Sonos, please disable stealing sound output from TV every 5 seconds. Modern TV:s have good output selection features built in, there is no good reason to override this.
At least let users choose if they need this or not.

 

 

 

Reply