Unable to connect with Sonos. Fix it - After upgrading to S2

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

69 replies

Userlevel 2
Badge +1

Just a quick update - They didn’t stay connected through the night.

I have opened and escalated the case with Sonos Support.  Others are reporting the same Wi-Fi disconnects.  It’s just a matter of time before an update is released.

Stay tuned...

Hi there!

I have reported this as a potential bug, but I wanted to see if anyone else has noticed this.

Ever since upgrading to S2, my iOS controller will not stay connected if the Sonos app is force closed.  To reconnect the app, I have to reset the app and join existing system.

As long as the Sonos app is not forced closed, all is well.  As soon as it’s force closed...issue.  I did not have this issue with S1.  I have performed the troubleshooting steps which lead me to this observation.  It’s been a few days now with no issues since leaving the app open.

Thank you for any insight provided.


G’day @BrainSel did you have any suscess with your problems. I've had the same issue ever since the S2 update. In my case I have also lost the ability to use my LG magic remote for 2020LG CX oled with my playbar. I have done practically everything to try to get it going with no luck. 

Userlevel 2
Badge +1

Hello @DhavalD., I have not had any success with my situation.  I did speak with Sonos Support a couple of times for lengthy troubleshooting sessions.

I think I know why this isn’t getting resolved as quickly as we’d like.  Their Teams don’t have access to any equipment or labs in their offices.  This is a very repeatable issue and if they were able to “lab it”, we may see quicker resolution.  The Support Rep was willing to reconfigure his personal setup at home, but he realized we don’t have the same products.

To Sonos’s credit, they were willing to send me a Playbar and Boost to see if the issue could be resolved with hardware.  I declined both as I believe this to be a software issue with the Linux-based OS running on these devices...specifically with Wi-Fi.  Everything else is fine with my setup, it’s the Wi-Fi that stops working after a couple hours following a reboot.

I firmly believe that Sonos will resolve this with an update.  I’m patient with this as the impact for me isn’t as bad as others.

Has there been any update to this issue from Sonos?   I’m having exactly the same issue with my Playbase and One.   I was on with Sonos support for quite a while hard wiring the device to the router etc etc but after all of that it still drops out.

Good old google brought me here and it seems exactly the same as the issue being discussed here.  I’ve had my Playbase for years with no issue and my WiFi network is very strong with no other devices reporting any issues at all.   Yet after the S2 upgrade almost immediately i’m having drop outs every few hours and i now can hardly use my One.   Fingers crossed on a fix soon.

Userlevel 2
Badge +1

Hey @Pedro C! updates yet.

Sonos is very aware of the issue.  We’re all just waiting for the fix to be released.

If I receive any news, I’ll post it here.  

Hang in there.

Thanks for the reply.  As a further update I got a longer Ethernet cable and wired in my play base permanently at the weekend and it’s still dropped out 3 or 4 times since so definitely not my network.   The new One I bought is almost unusable now as just drops all the time

Userlevel 4
Badge +12

Hi @Pedro C,

I would like to take a look at your system; I would like you to take a diagnostic on the Sonos system and reply with the confirmation number.

Here’s how: Settings > Help & Tips > Submit Diagnostic.


Userlevel 2
Badge +1

Well, I made a discovery today.  Instead of rebooting the Playbar to get back connected, I decided to try pressing the + and play/pause button, then connecting to the SONOS Wi-Fi network from my iOS controller, then letting it time out.  Low and behold, after switching back to my home network, the Playbar and Sub are back on the network.  

Because I didn’t reboot the Playbar, there should be some good logfiles showing what’s happening.  This is definitely a Sonos issue, not a home network issue.  Diagnostic 1681910631 has been submitted.

Userlevel 2
Badge +1

Just a quick update - After 24 hours, the Playbar and Sub are still online.  Here are the exact workaround steps I took:

• Launch SONOS S2 App on your controller and verify it’s not connected

• Enter Setup on the Playbar by pressing Volume Up and Play/Pause at the same time > the orange light should start blinking

• Enter Wi-Fi Setup on your controller - For example, on iOS devices this is Settings Wi-Fi

• Wait for the SONOS Wi-Fi network to appear

• Connect to the SONOS Wi-Fi network and do nothing else, just wait patiently a few minutes for it to time out

• After the timeout, you should be connected back to your home network automatically - if not, connect back to your home network

• Return to the SONOS S2 App and see if it’s connected


I don’t know why this works, but it sounds like a bug. I’ll report back any further discoveries.

Hope this helps!!

Userlevel 2
Badge +1



@Kyle A 



@Pedro C 


Possible workaround in my last post.  😬

Userlevel 2
Badge +1

Just a quick update - It has now been 48 hours and the Playbar and Sub have stayed connected to the Wi-Fi network.

I’m working with Sonos Support so they can determine why this works after applying the workaround.

Stay tuned...

Great detective work BrainSel 😁

will try this over the weekend when back home but sounds very positive 

@BrainSel I tried your solution but the app still won't connect. I'm literally having to unplug my playbar everyday for 10 seconds then resync it to app (S2). Absolute nightmare and I'm probably going to ruin my power cable by yanking it out every damn day. Sonos please sort.



@BrainSel It didn’t work for me either. On the bright side, some how my LG magic remote has started working to control the volume. Looking forward to getting it working so I can go back to playing music on it from Spotify. 

Userlevel 2
Badge +1

@SinfulMax @DhavalD 

Boo...sorry to hear this.

Prior to this discovery, I did a factory reset on my Playbar and Sub and deleted the S2 App.  This isn’t for everybody so judge your own setup to see if that’s a painless first couple of steps.  My setup isn’t that complicated, so for me it was pretty easy.

So...I would try:

• Factory reset all applicable components

• Delete and reinstall the S2 App

• Go through the entire setup process

• Wait until it disconnects

• Perform the steps in the workaround


Sonos Engineers are looking at this.  My system has been online for almost 4 days issues.


I hope this helps.  I feel like we’re getting closer to a good workaround.

@BrainSel out of curiousity what password did you use to try and connect to the Sonos WiFi. I just typed in my normal house WiFi password, I realise it doesn't really matter since we're timing in it but just wondered.


Userlevel 2
Badge +1


No password should be required.  Wait until you see SONOS as the SSID.  There will be a crazy long SSID that has Sonos in it, but wait until the short SONOS network appears.


Hope this helps!

I left my Sonos app open rather than force close. Opened it properly there the now and it still says unable to connect. Tried the setup, only the long Sonos SSID comes up.


I sadly have the same issue. I wanted to try your solution but have a Beam instead of Playbar. Any idea how to enter setup mode? Pressing volume up and Play doesn’t work. Thanks!

Userlevel 2
Badge +1


So close!!

Does that Sonos_xxxxxxxxxxxxx SSID eventually change to SONOS?  How long did you wait?  It might take a minute or two.

Let us know!

Userlevel 2
Badge +1


For the Beam, it looks like you press and hold the ♾ button until you see an orange blinking light.


Hope this helps!

Userlevel 2
Badge +1

Just a quick update - Mine disconnected again after staying connected for 4 days.  I did the workaround and it’s back online.

@SinfulMax - it took a couple of tries, but eventually the SONOS SSID appeared.  It took about a minute to switch from Sonos_xxxxxxxxxxxxx to SONOS.


Sonos Engineers are fully aware of the disconnect issues.  It’s only a matter of time before an update is released.

Hi so I'm literally sitting for 30 mins at a time trying to sync this so even tonight when I disconnected power source for 10 secs and reset S2 app it didn't resync. Ended of mirror sharing Amazon app with TV to play music. I'm so fed up with it can't control playbar volume unless through Chromecast.

@BrainSel thanks for that info - I’ll give that a try next time. 

Out of interest is anyone else’s home network a MESH set up? Strangely I have found the S2 app seems to ‘find’ the Sonos when I am in different areas of the house even though my WiFi network is the same across the whole house.  Even then this is intermittent and doesnt always work. 

I am by no means a network expert so I have no idea if my MESH setup is indeed making a difference here, but I never had any issues on the old S1 application. 

I am going to try resetting the app and unplugging all my Sonos speakers and router next time and resetting them up from scratch but I’m not hopeful based on everyone else’s feedback. 

Userlevel 2
Badge +1

Just a quick update - Sonos released an update today!  I’ve applied it to my system...let’s see what happens.

Obviously, all products need to be online before updating.  Power-cycling the Playbar or Beam, then verifying the other components are online might be the best thing prior to attempting the update.

Good luck everybody!!