Answered

What should I try next to keep paired Play One's connected reliably?

  • 12 October 2022
  • 9 replies
  • 104 views

Hi there,

I’ve got 9 speakers around the house. A paired set of Play Ones in the kitchen are consistently AWOL when I want to start playing something. I’m looking for suggestions on the next changes I should try.

Maybe it’s the speakers, maybe it’s my network config, maybe it’s wifi interference.

I’ve had problems in the past with keeping any speakers connected and have tried several configs with varying success. Only having two speakers that disconnect/disappear regularly is the best it’s been, but still pretty annoying.

Setup:

1x Playbar & 2x Play:1 in front room HT setup on main floor

2x Play:1 stereo pair in middle of main floor in dining room

1x Play:1 in middle of main floor in office

2x Sonos One stereo pair in kitchen at back of house on main floor

1x Play:5 1st gen in basement at back of house

My home network is a Unifi system with 4 access points so lots of options for configuration and lots of rope to hang myself with.

One AP in mid main floor, one at front of house on top floor, one at back of house in basement, and one in the separate garage.

The main floor AP has plenty of 2.4GHz power to cover the property but neighbours are close and we have lots of interference so the idea is other APs are only for short range 5GHz. I also have the garage AP using a low power 2.4GHz channel for an IOT device in there.

All speakers are on a separate Sonos-only SSID that is only available on the 2.4GHz radio in the AP on the main floor. As I remember it, support told me that was better than just letting the speakers choose whichever AP they preferred. Is there a drawback to having different speakers connecting to different AP? In the Unify config I can constrain a speaker to a specific AP by it’s MAC address if that helps.

I have stuck with the S1 controller to avoid losing the Play:5 but if there’s actually some benefit to S2 I’d consider upgrading. Everything on the main floor is S2 ready. I’ve seen release notes and posts that talk about 5GHz support in S2 but it isn’t clear that 5GHz support _is not_ in S1. The neighbours haven’t discovered 5Ghz so there’s not as much interference.

I gave up on Sonosnet years ago. Maybe it’s time to try again. I have a wired ethernet connection available to the Playbar in the front room but it’s a long way and multiple walls (some plaster) to the kitchen Sonos Ones. It wasn’t stable the last time I tried it. I can dedicate one of the 3 usable 2.4GHz channels to it, but I can’t convince the neighbours to shut off their interference.

So, what would you do?

  1. Switch back to Sonosnet and hope
  2. Upgrade to S2 and hope
  3. Futz around with something* to get more speakers on 5GHz (*please specify what!)
  4. Other (* please specify!)

Thanks for reading this far.

icon

Best answer by acodring 13 October 2022, 00:00

View original

9 replies

If you prefer to keep your Play:5 as part of the existing system, then I would stick with S1 at this point in time and kick the idea of switching to S2 further down the road, until you decide to upgrade that one speaker. 

For the time being, I see no harm in trying to run the system again on SonosNet, by wiring a standalone, or master device to the primary Orbi hub - the Play:1 for example. (that’s assuming that Orbi primary is the network router and that you are not using the hubs in bridged mode). Ensure the wired device is set at least one meter away from your Orbi hub/other wireless devices.

Select a SonosNet channel that’s not used/least-used by your Orbi Hubs and as you do not have any portable Sonos products, also remove the network credentials from the Sonos App network settings. See this link: https://support.sonos.com/s/article/3488

That network removal will stop your speakers hopping between the SonosNet signal and your Orbi WiFi network.

See if that perhaps improves the connection of all your Sonos products.

 

...trying to run the system again on SonosNet, by wiring a standalone, or master device to the primary Orbi hub - the Play:1 for example. ...

See if that perhaps improves the connection of all your Sonos products.

Thanks for the encouragement. In the past I always focused on the Playbar for the wired Sonosnet connection but as I thought about different places I could wire a speaker I remembered that there was an abandoned ethernet port in the office, from back in the old days of wired computers. It’s a much more central location in the house, so a better placement.

I connected the Play:1 there and watched as all the other speakers kicked over to Sonosnet over a few minutes. So far so good. If everything stays connected over the coming week I’ll be a very happy listener.

Thanks again!

PS: I had to google ‘Orbi’ to realize it’s a different network vendor. My system is from Unifi. Same same but different.

Ah sorry about the Orbi/Unifi mix up - my mistake, but yes just a different vendor. Hope all continues to work okay for you on SonosNet.

“Unifi” is a Ubiquiti product. Ubiquiti gives the user lots of options that can help or “hang” the user.

Overall, I prefer SonosNet. Wire as many players as is practical. Some of the Ubiquiti access points provide a passthrough network connection. Take care when using this with a SONOS player. I’ve had trouble when attempting this. Perhaps this was a temporary Ubiquiti issue (they update often). It will take a couple minutes for the storm to build.

One issue when using WiFi for SONOS is access points that change channels or hand off clients to other access points. Unless a player is regularly relocated, locking a player to an access point is a good idea. Use 20MHz channel 1, 6, or 11 on 2.4GHz, not “Auto”.

I assume that either the ISP’s gateway is bridged or you’ve disabled it’s WiFi. Otherwise, make sure that it is using a different SSID from the Ubiquiti.

Avoid the temptation of a SONOS Factory Reset without further consult. Although there could be some accidental improvement, this will not be a permanent solution.

Userlevel 7
Badge +21

I love my Ubiquity gear but I find it frustrating to use with Sonos. I could dial back a lot of the new features in the Ubiquity gear to get it working with Sonos but even then the Ubiquity updates can lead to breakage.

Far better to wire a Sonos or several Sonos, or if that is not simple then add a Boost and skip all the incompatibilities.

If you are using any Ubiquiti managed network switches, make sure that they are set for “STP”.

“...Wire as many players as is practical. ...

I didn’t realize I could wire more than one speaker at a time. I’ll look into that. If you’ve got documentation links or keywords I can search on that’d be helpful.

There is usually no great advantage with wiring the surround speakers because they will build a private 5GHz direct link with PLAYBAR. If any of the others are near a network port, wire that speaker. Any combination of wired/wireless is supported. SONOS will build it’s own private mesh (“SonosNet”), taking advantage of any wired players and ignore Ubiquiti’s WiFi. It’s not applicable in your case, but ROAM and MOVE are always WiFi. If you come across a suggestion to turn OFF any SONOS WiFi, don’t do this for any of your units. The option is misnamed and will turn of the unit’s radio (not just “WiFi” access), causing no end of grief in a system such as yours. 

Actually, Ubiquity is similar in this respect. You can configure access points to mesh wirelessly, but the system works best if all of the access points are wired.

Go to http://[IP address of a player]:1400/support/review and check the Network Matrix at the bottom. Red cells indicate potential wireless issues. Unfortunately, the most recent SONOS players don’t provide much useful data for the matrix, but it’s worth a look.

Also, you can go to Settings → System → About My System. WM: 0 indicates a player is using SonosNet, WM:1 is using WiFi. After one or more players are wired, all of your players should switch to WM: 0. If you have a MOVE, it will be WM: 1. (You cannot have a ROAM, in an S1 system and ROAM will always be WM: 1) Note that this is a static view. You need to refresh the page in order to view the most recent data.

Userlevel 2
Badge +1

On my UniFi network I configured a separate SSID/Wi-Fi network for all my Sonos devices ensuring that the “Proxy ARP” setting was switched off.

That setting being enabled disrupts how paired devices communicate.

They’re still on the same LAN - in terms of IP broadcast - so still directly visible to the Sonos app on any computer, phone, etc. UniFi’s Proxy ARP turns out to be essential for the other devices if they’re big users of multicast, so it’s best not to just turn it off on your main SSID.

Reply