Answered

Alexa app not discovering any sonos speakers

  • 5 October 2017
  • 26 replies
  • 16635 views

Trying to integrate my 4 sonos speakers with my alexa app and its just not working. I search for devices as instructed and my nest heating is appearing as are my hue bulbs but no sign of sonos.

I have updated both the sonos and alexa apps.

Anyone any thoughts?
icon

Best answer by Edward R 10 March 2020, 11:18


We have noticed this topic gaining some traction of late. If you are having issues with the above, please check the following. 

  • Ensure that you are in one of the Support Regions for Alexa on Sonos. 
  • If you are, next try the advice in this post: 

    I had the same issue. Here's how I managed to re-add the speakers.
    First, I changed the names of all my speakers from say "kitchen" to "my kitchen".
    Then I disabled the skill, re-enabled and started a new device discovery. Nothing.
    Then I changed the names back, and suddenly they were discovered upon rescan

  • If still not able to resolve this problem, please check this thread: Resolving the majority of issues with Alexa on Sonos. 

    If you are still having issues after trying all of the above, please feel free to start a new topic, or respond below with a diagnostic confirmation number and we will look into this for you at our first opportunity. 
View original

26 replies

This is happening to me too.
Me too ..
Userlevel 7
Badge +20
Just to check the obvious: did you add the Sonos skill to Alexa?
of course ... and disabled several times to retry ...
I have the same issue on both Android app and web 😞
Userlevel 7
Badge +26
Hi everyone. Alexa control for Sonos is only available in certain countries, so if you're not in the US, UK or Germany, this isn't supported at the moment.

A few steps to work with are here.

Also, make sure that all Sonos devices and software are on 8.0. Check under Settings > About Sonos in the Sonos app. Your players will all show the version number. Make sure to check each device, not just the app.
Me too. I'm in the US.
I'm still having issues and my system + all my speakers are on version 8.0. Any other tips?
I'm having the same problem.. everything is updated, but Sonos is not discovered.
I’m havin this problem too. Wondering if maybe it’s because I have a boost?
Userlevel 2
Badge
A long shot - I'm sure you're fine on this, but are your Sonos devices on the same network (including addressing schemes) as the Alexa device(s) ?
Figured it out. Or maybe it’s better to say it figured itself out. I think the problem is actually due to app differences on the iPhone and iPad. I was doing the setup on an iPad and not getting anywhere. Switched to iPhone app and worked fine.
Setting up Sonos on the Echo dot - software all upgrades to 8.1 however the Alexa App can only see one Sonos device out of 5. My Network does have a number of switches with Wifi Access points connected into different switches on that large Layer 2 network however things is on the same class C. the Sonos device found is connected into the same dumb switch but I can't see any of the others that are not. All but two of my Sonos devices are my wired network. It feels like a networking issue at this point. Is there a way to manually enter the IP's of the devices or force a more aggressive scan?
Userlevel 2
Badge
Can you ping the Sonos devices (assuming you know the IP addresses or can get them from your router). I think Sonos needs UPnP and multicasting to discover (I'm not an expert on Sonos networking), so worth ensuring nothing is blocking that.
Sonos is not discovered for me either...anyone figure it out yet?
I’m in the UK, set up the Sonos One, but also having frustrating issues with Alexa skill discovering Sonos as a devise (only Amazon devises). I can use the sonos as the Play one, but without Alexa integration.

I have reset my router, plugged it into my router, unplugged & plugged the power and even deleted & reinstalled apps on many occasions.

Can anyone help please?! I don’t have any more hair to lose
Userlevel 7
Badge +20
Hi all.

I suggest that you follow the steps I've listed in the answer in this post and then let us know if you still have issues. The other cause for the issues that some of you are mentioning is when you are logged into another Amazon account on another app but within the same device. Let us know. :)

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239
Just wondering if those still experiencing Sonos/Alexa connection problems are trying to connect incompatible devices. There is a difference between a Sonos Play 1 and a Sonos One. Only the latter can be paired to work with Alexa. To connect a Play 1 to Alexa you also need an Echo.
I'm having problems but I've also created an odd situation. We're wrapping up a remodel that has been ongoing for almost 9 months. During that time some of my Sonos components were in storage, while the others were setup in the temporary home we're in. At one point I setup an echo Dot and then (I think) it discovered the one Sonos that was active at that time...at the temporary home.

The remodel is nearly done so I setup four of my Sonos components in our real house. I still have our Play 3 at the temporary home. Both locations are under my same Sonos account, but clearly on different wifi networks.

Yesterday my new Echo Show arrived at our almost completed actual home and I tried to add my two Play 5's, one Play 1 and Connect to the Echo Show. Oddly the only one it "found" was the one at the other house that is a few miles away and clearly on another network. On top of that I don't think we even have an active echo in the temporary house. What I do know is that the Echo Show didn't find the four components that were in the same house on the same network as it...and associated with the Sonos account that I linked. I tried deleting the one from the other house and deleted and reinstalled the Sonos skill, but no luck. It keeps adding the one at the other house and can't find the ones on the same network as it. I'm seriously confused...and I'm sure you are too after reading this. 😕
Userlevel 7
Badge +20
I've listed the main causes of Alexa issues within the Answer to this post, can you work through them and let us know how you get on?

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-she-is-playing-on-kitchen-but-no-sound-comes-out-6800126/index1.html#post16210022
Thanks and I'll give it a try next time I'm at the house!
Badge
Enabled Sonos skill and link to your Account.
I had the same issue. Here's how I managed to re-add the speakers.
First, I changed the names of all my speakers from say "kitchen" to "my kitchen".
Then I disabled the skill, re-enabled and started a new device discovery. Nothing.
Then I changed the names back, and suddenly they were discovered upon rescan
Userlevel 2
I had the same issue. Here's how I managed to re-add the speakers.
First, I changed the names of all my speakers from say "kitchen" to "my kitchen".
Then I disabled the skill, re-enabled and started a new device discovery. Nothing.
Then I changed the names back, and suddenly they were discovered upon rescan


After trying every other fix, and having reset everything possible, this was the only solution that worked for me. Thank you.

I had the same issue. Here's how I managed to re-add the speakers.
First, I changed the names of all my speakers from say "kitchen" to "my kitchen".
Then I disabled the skill, re-enabled and started a new device discovery. Nothing.
Then I changed the names back, and suddenly they were discovered upon rescan


Same issue here after hours of frustration.   Thank you!

Reply