Poor speech clarity with Playbar


Hi Guys,

I've had the playbar for about 5 years. It works fine when listening to music but when it come to movies, the speech is not always audible. For this reason I stopped using the player and consider changing to another brand. Before I do so, I would appreciate any recommendations to address this issue.

For the record the playbar is connected to my projector and I usually watch movies off of a mini pc.

Thanks in advance,
Daniel

15 replies

Userlevel 7
Badge +20
I normally have to increase the volume of my PlayBar volume when switching from Music to TV, have you tried just turning the volume up? 😛 If you are experiencing normal background sound but low voice, then I suggest you enable 'Speech Enhancement' as per this article: https://support.sonos.com/s/article/1948?language=en_US
Hi thank you for the reply, I have tried the volume, speech enhancement and the night settings with little to no effect.
Userlevel 7
Badge +20
Have you checked the Audio settings on your movie source?
I use my headphones now to watch movies and the audio is fine. So I don't think the issue is the movie source. Most times I stream Netflix off of the mini pc
Userlevel 4
Badge +6
I use my headphones now to watch movies and the audio is fine. So I don't think the issue is the movie source. Most times I stream Netflix off of the mini pc

I had the same issue, unfortunately not much to add other than my experience. Constant turning up during dialog, turning down during loud scenes. Kind of a pain especially when kids are sleeping as you need to be quick with the remote. I adjusted every setting, different sources, different apps to no avail. In the end swapped out playbar for a 2.1 set up and this fixed it for me and saved my sanity (I also had issues with the sonos sub sound but that's a different topic).

Lots of threads on this issue if you search FWIW.
I'm with UKMedia on this. If you're sending only a stereo signal to your PLAYBAR, then you wouldn't be getting the optimum sound from the center channel, but it would sound great on headphones.

While you're watching a movie, open up your controller, go to ...More and select Settings, then About My Sonos System, and see what it says under the the area dedicated to the PLAYBAR, after the words Audio In: If it says Stereo, you need to adjust the settings on your mini pc so it is sending a Dolby Digital signal to the PLAYBAR/TV set.
Userlevel 4
Badge +6
Sonos moderators why did you silently delete my response?
Userlevel 7
Badge +20
Sonos moderators why did you silently delete my response?

Hi there,

Your posts were caught by the spam filter, we're not deleting your posts manually.
Which I'm going to guess has been turned up recently, due to the increase in spam we've been experiencing. 🙂
ok so I checked and under Audio In it says 'Stereo.' The playbar is hooked up directly to the project via the optical cable so the mini pc recognizes the projector and not the sound bar. Not sure if this makes a difference but any advice on how to proceed from here will be appreciated.
This raises several questions:

First off, what is a project? Is that a projector of some type? Can you provide a make and model, please? And perhaps a link to an online manual so that we can look at some data for ourselves?

Does it pass a Dolby Digital signal through it, from HDMI in to optical output?

How is the mini pc connected to the projector? Is it via HDMI, or is it in another way (perhaps via component?)

Does the mini-pc and the app that you're using to play a show to send to the projector have audio options that you can set? What is the app? Is it something from Netflix?

If the connection between the mini-pc and the projector is an HDMI signal, there should be some way for you to set the audio options on the mini-pc so that it's sending a Dolby Digital signal to the projector. If it's a component hookup, not so much.

Once you have the audio options on the mini-pc set properly, we can move on to looking at the projector as a potential issue. The problem with the mini-pc is the audio options might be in the app, or they could be in the operating system's settings, or even in the settings for whatever device you've got pushing the signal out, if that's a separate video card. What kind of mini-pc is it? What OS is it running? Is the video generation part of it built in, or was it added at a later point in time?

Yours is a pretty special and unusual case, there aren't that many people who visit these forums that use a PC to drive their video, most people use cable boxes or satellite boxes, or game consoles, which are infinitely easier to deal with.
Sorry by project I meant projector. Its an Epson 3020e Projector. The optical cable from the play bar is connected to the projector and the Intel Nuc (mini Pc is connected to the projector via an HDMI cable. From the PC I can stream from the Netflix app directly or from a downloaded movie on VLC it doesnt matter, there are still issues with the sound.

I also have a cable box hooked up to the Projector and the sound quality on that is good so I guess the issue is with the PC. I have no clue how to set the Dolby digital signal on the PC though.

Link for Projector Manual: https://files.support.epson.com/pdf/plhc3020/plhc3020ug.pdf

Link for Intel Nuc: https://www.intel.com/content/www/us/en/products/boards-kits/nuc/kits/nuc5i7ryh.html
Thanks for all of that, most helpful.

Since I'm primarily a Mac guy, I'm not as familiar with VLC, having not touched it for at least 5 or 10 years now. When you open up VLC, is there somewhere that you can set audio settings? Looking at the tech specs for that computer, it does look like it handles up to 7.1, through the HDMI, so that's good. But it might be worth going in to the OS (what OS does it run, Windows of some kind?) and checking to see what the OS is set to, as than might feed back into the settings that VLC present to you.

And I'd ask someone who has more knowledge with VLC to step in here. I'm stabbing in the dark at this point 🙂
Userlevel 2
Badge +3
Maybe try this:-

In the new settings window on the left-hand side, locate Audio > Output modules > DirectX, then select your Output device (Sonos?). Once this is done, set the “Speaker configuration” to 5.1 or 7.1 (depending on your content), Save, and then restart VLC. It may show Dolby Digital in the Output Modules and not DirectX, if so select it then set “Speaker configuration” to 5.1.

Reply