"It looks like [room] isn't available right now"

I have three Sonos devices in my current setup, all connected to Google Assistant (GA). Two are Google One: gen 2's and I'm seeing some interesting behavior on one called "Master Bath."

To be clear:
  • GA works most of the time on each of them
  • In each case, GA is fully responsive through the target speaker, but says the device itself is "not available right now."
  • "Master Bath" is a unique name on the network
  • Master Bath is visible to the Google Home app and to the Sonos app when this happens
  • There is no outage currently reported at
Several times, I have started music (e.g. Ok, Google, play Led Zeppelin or stream MSNBC, etc.). Then, when I say, "Ok, Google, stop," it replies, "It looks like Master Bath is not available right now." Other times, it has been quiet (I stop the playing through the Sonos app in order to get it to stop), and I say, "Ok, Google, play Jack White," and it might also reply "It looks like Master Bath is not available right now." And I wonder, "If that's true... how is Master Bath replying to me right now?"

Any thoughts?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

I have same problem, only had it two days. Now doing my head in. Money back job
Userlevel 7
Badge +26
Hi folks, this sounds like something best troubleshot over the phone or with our support team directly. They'll check out the network connection to that player and make sure there isn't anything else happening. The contact details for the team can be found here.

Has anyone got any success with the support team for this kind of problem? I've been having the same issue, and the French support team could not help by email. However, staying on the phone may be quite inconvenient, and possibly useless since this is an intermittent problem.

Also, I'm not sure this would be a network problem, since it is only happening with Google Assistant (not Alexa). Plus, controlling through the Sonos app works perfectly.

Any input would be appreciate. I may try a factory reset, or calling support if you still think that's the best way to go. Thanks!
I've experienced this error message a lot ever since I switched from Alexa to Google Assistant, and I've still not figured out completely what causes it. Eventually I did however figure out that it seems to be related to regrouping, and especially after playing radio. It seems like Google Assistant on Sonos believes that speakers are still part of a group even after the group has been split up or rearranged. At first all commands will be redirected to the previous group leader (even though they're not grouped together anymore), and then you eventually get the dreaded "It looks like the ...-room isn't available right now".

It doesn't seem to happen after playing Spotify, though – it seems to be radio-related – at least in my case. But I play radio all the time, so this happens practically every day ... The cure for me is to regroup so that the previous group leader becomes a subordinate member of a new group, and then ask Google Assistant to play Spotify on the new group leader speaker. After that I can usually regroup the way I want, and everything works fine for a while.

If I regroup so that the previous leader becomes a subordinate member of a group and ask it to play a radio station instead of Spotify – I think that is when the not available-error starts to occur, and the only way out of the situation for me seems to be to make it play Spotify. (And I think the previous group leader must be affected by this command to make it work.)

The behaviour of this error message has changed a lot over the months that Google Assistant has been out, and for a long while (most of June) I didn't encounter it at all. That lead me to believe that it had been fixed, but after the update about a month ago – when the volume control commands became messed up – this error returned and behaved exactly the same way as it did before.
Userlevel 7
Badge +20
Hi folks,

There's currently an outage affecting Google Assistant on Sonos systems. You can check out status page for updates.
Just wanted to point out that my post has nothing to do with the outage, though. At the moment nothing works because of the outage, but my post refers to the way it has been for the last month and further back.
I’ve been having this problem on and off for the past month or so as well. However, on my part, it affects any command from GA to Sonos, including Spotify (so it’s not just TuneIn). Unfortunately I can’t test regrouping my speakers, as I only have a pair of Sonos Ones working together in stereo.
Userlevel 7
Badge +20
Hi folks,

There's not much troubleshooting to be done while there is an outage in process. We're receiving reports that the outage is over. If you continue to have any issues, please give us a call. Our phone team can take over troubleshooting from here.
Userlevel 1

The same periodically happens to me - sometimes I am able to get the Google Assistant to play music on Sonos One and sometimes I get “sorry, the room … is not available” response. Like 1 out of 10 times it’s not available.

I have the same problem? Did anyone work out  fix for this ? - FYI My Google Home Speaker works flawlessly - The Sonos Ones says  - “Playing X from Youtube Music”  then  “looks like {ROOM} isn't available right now”


Everything else seems to work fine - even when I ask GA things like - Whats the time?

Any solutions on this? 

Any solution here? I am having this issue throughout my system.

My setup:

2x Nest Mini (GA)
1x Sonos One (GA)
2x Sonos Play:1
1x Sonos Amp
1x Sonos Play:5 (2nd gen)


Sonos itself works flawlessly when using Sonos app, or Spotify connect. Googe home speakers (Nest mini) works great as well. But when asking any of the GA devices to play music on anhy of the sonos “rooms”, I get the mentioned error message “sonos is not available right now”, alternatively “(sonos room name) is not available right now”.

  • The setup was working for a few hours when first configured, but then entered this state.
  • I reconfigured everything (disconnected sonos speakers from GH, and reconnected), after which it was working for a few hours, the back to this. 
  • I then reconfigured the sonos system to use my WIFI, instead of one device being connected via ethernet. This made it work again, for minutes/hours, then back to this.

In addition to this my Sonos One which is running GA gives sporadic “I cant connect to internet right now” smessages when trying to access the GA.

There is nothing wrong with my internet - I know this because I can play music from the same Sonos One (using sonos app) while it apparently “cant access internet” according to the GA.

I find countless references to this/these bugs in the Sonos and Google forums, but no mention of actual fixes. I find this ***** to say the least, and I now regret investing so deeply in a closed eco system with this bad support.


Please Sonos, get your act together and reply in these threads - with actual information or ways to troubleshoot this. Do not ask us to give you a phone call, as we know this will not solve anything.

Thanks in advance.

Userlevel 7
Badge +22

Folks just don’t understand these are not Sonos Support forums but a Sonos Community forum, mostly populated by Sonos users with some very limited visits by a few Sonos Staff. Even then the forums provide little assistance to the Staff who are trying to identify posts with issues.


The Sonos contact page has several direct to Support options, some staffed 24x7, phone lines in many countries (check the flag icon to avoid an expensive call) and even e-mail when you want to pass a lot of data or a record of what was said.


Just wait for the issue, submit a diagnostic and directly contact support with the ID number it gives you. Of course you can post here and hope the support folks find your post at the tail end of some other topic.

@FishFlu , Welcome to the Sonos Community and thank you for bringing your concerns here. I can see that per Stanley_4’s advice that you have reached out to Sonos for troubleshooting assistance. Feel free to follow up here with any results to your troubleshooting steps and/or resolutions for your issues.

Sure did, and will do. Hope to get this sorted, as its slowly killing me from the inside. 🦉🎊🤪

(SOLVED) Update from my end: After contacting Sonos support they told me that my system had "no access to cloud services”, based on my supplied diagnostics. Unfortunately they couldnt tell me anything else, nor help me troubleshoot further as a reslt of this.

After digging around in my router settings, and contacthing my ISP (recently moved, and got a new fiber agreement), I found that I was not assigned any public IPv4 address. I only had an internnal IPv4 due to address shortage. I made them remedy this, and got one assigned.

After this was fixed, all my issues were fixed. Google assistant now working flawlessly on Sonos One, and all GA can play Spotify / TuneIn on all sonos speakers.

What I find strange is that the GA service on Sonos One and getting GA to play on sonos worked “sometimes” witouth a public address. If this is indeed a requirement (apparently is, when Google services tries to access my local sonos network from the cloud) I would expect it to NEVER work when no public address is available.. But somehow it worked for a few minutes every time I set it up, and sometimes once or twice the day after.. 


TLDR: Apparently you need a public IPv4 address for GA to communicate with Sonos, even though Sonos itself and GA itself does not require such.