Confused by SMB and music library problem

  • 13 January 2023
  • 2 replies

Hi All,

Until last week I was able to access my music library from an unpowered external HDD through my TP_Link Archer VR2800 router.  I replaced the unpowered HDD with a Seagate external powered HDD, removing the reference to the existing library and tried to create the new reference.  No go.  Classic symptoms of the SMB v1 issue that is being discussed.

I am running a Windows 10 laptop that has no trouble talking to the router or the Seagate HDD.  I can access/play movies/music from there.  SMB v1 is disabed on my laptop so the router must be using SMB v2.

My Sonos system (3 x Ones, Play:5 and a Beam) are all upgraded to S2.  S2 has no SMB v1 capability.  This upgrade occurred a while ago (many months to a year if I recall).

So everything is running SMB v2. Moreover, the library was working fine last week with the unpowered HDD.  Now I can’t add the library on the Seagate HDD and I can’t add the library reference to the old HDD.

Saying it’s a simple SMB issue doesn’t feel right...what am I missing?

I’ve tried referencing using HTTP but cam;t get that to stick.  Doe anyone have detailed instructions please?

Many thanks,




2 replies

This may be nothing to do with SMB.  There is a known bug at the moment with Sonos accessing music libraries stored o USB disks.

Userlevel 7
Badge +21

What Path are you using for the Seagate?  Have you set a username and password for Sonos Access, it may not be required though?

Have you checked here?


I recently set up a Synology NAS.  Had a few issues so ended up setting up a Sonos “user” and just gave it read access to the Music folder.  WOrks a charm