Anyone had issues streaming music or updating sonos devices?

  • 1 December 2020
  • 8 replies

Several issues with my Sonos today, I’ve 2 Play:3 and a Playbar on the Sonos S2 app and tried to play some music - didn’t matter which service I used Amazon Music or YouTube Music both returned the same error that music couldn’t ne added to the queue when I tried to play, also had an intermittent 701 error.

Tried to run the Sonos update got the 1101 error.

Uninstalled the Sonos app on all devices and factory reset all Sonos devices - in order to start the set-up from scratch.

Create a new Sonos network - same error on Amazon Music and when trying to update the system, can’t even add YouTube Music now.

Can use it with the TV (including with the Play:3’s as surrounds) have had it play Sonos Radio (although that’s of no interest to me) - but am finding it really frustrating that it doesn’t seem to work with the main music providers at the minute.

Anyone else having issues or encountered this problem?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +22

I had a lot of issues, assigned Sonos static/reserved IP addresses then powered them down, booted the router and controller and powered the Sonos back up. It may not fix everything but it will eliminate one source of problems that have vexed many here.

I’ve tried a few more things but it still seem like the main problem I’m having is errors trying to add streaming services or errors trying to actually stream music from them - have tried Amazon Music, Spotify, and YouTube Music and can’t get any of them to work. TV sound from speakers is fine and have had Sonos Radio through there.

Never had any problems until recently, although mostly used Google Play Music which now pushes you to YouTube Music. 

Errors range from errors on authorizing to 701 or 1101 error and failure to queue music.

It certainly suggests issues with the signal reaching your speakers properly. 

Stanley’s suggestion is a good one, but you could do a quicker, albeit more temporary, test to see if that is the issue. Unplug all Sonos devices from power. While they are unplugged, reboot your router. Only once the router comes back up should you plug back in the Sonos devices.

You may also want to read the wifi interference FAQ, it is entirely possible sources outside your control are impacting up your local network. 

I’d be surprised if it is wifi interference - certainly the Playbar is less than 30cm from the router and the Play:3s are in the same room. Router we have is an Asus RT-AX92U and we’ve had the set-up as it is now for about a year but this is only a new issue, but I’ll try another reboot tonight anyway.

Also I don’t think wifi interference would cover why we get errors trying to add services (namely spotify and youtube music currently). Don’t know if it would cover why it can’t do the Sonos update either, although all devices are on version 12.2.1 (build 61183170) which as far as I can tell looks to be the latest one. To be honest I don’t think we’d ever had an issue before the last update.

As well TV sounds works ok, and so seemingly did Sonos Radio. The speakers are set-up with the Play:3s acting as surrounds for the Playbar but we’ve never had a problem until recently streaming music.

Interference or dupe IP addresses can indeed be the root of several weird problems.

But another user had issues with an ASUS router. I can’t explain the logic in it but may be worth investigating, if the former advices do not solve it:

I tried another reset last night, as still not been able to get in touch with any Sonos support.

Looking at ASUS / Sonos related issues I found this article:
So I’ve also updated the setting suggest but with no affect.

I’m reluctant to start messing with router firmware as I run my own software development business from home and the only thing with an issue is the Sonos - so I don’t want to mess anything else just to try and address that at this stage. As everything else is working I’m still a bit Occam’s razor about the whole thing at this stage, especially since this only seems to have started happening since they updated to spam their Sonos Radio at everyone. If there is a way to get more diagnostic information about what the Sonos is doing I’d think that worth a look at.

Anyway after last nights reset I couldn’t even get devices connected, so couldn’t even use the soundbar for the TV, I’d get an 800 error when it tried to link the device to my account. This morning it has now allowed it to go through and complete the linking with the account (so at least I have TV audio with the soundbar again), but I now get the 800 error trying to check the app version when attempting to add the first of the Play:3s.

At every point there is an issue it seems to be when attempting to interface with the online services such as account linking, updating, or adding or using streaming services.


And as if by magic - all now seems to be working again. Allowed me to connect devices, no issues checking for updates, and I’ve been able to connect a music service and stream music.

Not had to touch the router firmware.

Wish I knew what changed but just seems to have started working again after a few flaky days.

I’ve been having the EXACT same issue with the same router, if you find out what actually changed let me know...I’m going crazy trying to figure it out.