error code 30-tried everything

  • 17 November 2020
  • 11 replies

We have 6 Sonos speakers: Three Play: Ones and three Sonos Ones. 
Using S2 app. 


3 of the speakers work. 3 say they need to be updated but we get stuck in error 30. We have tried:

deleting and reinstalling the app

turning them off and on

rebooting the router

plugging them directly into the router

Factory resetting them all


We spoke with Sonos support for an hour today and got nowhere because they kept telling us to repeat the steps we’ve already done.  We feel like we are stuck with really expensive doorstops. 

Please help before I throw them all away. I would return them to Costco, but the only 3 that work came from there.






Best answer by Airgetlam 17 November 2020, 05:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

It’s hard to tell from your post, but were the Sonos devices unplugged while you rebooted the router?  If not, try that first. Leave all devices powered down and connect one of them to your router with an Ethernet cable, then plug that single device in to power. Once it comes up in the controller, try updating just that one device. 

I wouldn’t recommend any factory resets, in fact I consider it unfortunate that you received that instruction from Sonos. Generally speaking, at best it masks the issue, and has the unfortunate side effect of erasing all of your settings, since they’re stored on the speakers and not on the controller.

Try connecting (or adding, since they’ve been factory reset) one at a time, doing the update after adding each one, so we can see where it starts failing. 

It’s going to take time and effort to work through this, but I feel confident that it can be done.

Some questions that might help those of us who don’t have access to Sonos ticket and diagnostic systems:

What is the make and model of your router?

Is your normal setup wired (SonosNet) or WiFi?

Are three speakers updated, and three not? Or do all six need to be updated?

Thank you for your response, Bruce. To answer your questions:

  1. no, the speakers weren’t unplugged when we unplugged the router. We will try that today. 
  2. our router is the Linksys Velop system 
  3. our Sonos system is all wireless
  4. 3 are updated, 3 will not update. 

I’m going to try your suggestion today.  We are all so fed up with how complicated this update is that we are ready to sell the whole system and try something else. I love to have music playing all the time, and now I have speakers that don’t work at all. Frustrating. I hope your solution works! 

Sonos often doesn’t play well with other company’s mesh networks, I’d encourage you to go to a ‘wired’ system, where one speaker or a BOOST is wired directly to your Velop base unit. I think you’ll find less issues that way. 

Some details in the standard and boost modes FAQ, but perhaps not enough. Feel free to ask questions here, there is a group of users that have pretty extensive knowledge about optimal Sonos setup. 

The problem with that solution is that I don’t want a speaker in the room where the router is. For the most part, our system works. It’s just when there is an update that we get stuck. This happened the last time there was an update and we have no idea how we solved the issue that time around. 

I would try experimentally wiring one speaker to your router as Bruce suggested.  See if it works much better.  If it does you can buy a Boost.

We tried unplugging the router while all speakers were unplugged. Plugged In router and then plugged in speakers one at a time. 2 Play: One speakers updated. The 3rd will still not update (error 30) even when plugged in to router. The other speakers are working. 

There could be a hardware fault with that speaker, not something that can be handled in the forum. Your best bet is to call Sonos Support directly to discuss it.

Thanks. We now are getting error code 1101 on the last speaker that won’t update. It doesn’t matter if it’s hard wired or wireless. 

Please help. We are 7 hours into this. 

Please read my last post.

Thanks. We will call Sonos, but we already did (1 hour call yesterday) and got nowhere. 

I have this problem in the room where I have more than 2 speakers in the group (in one of my rooms, I have a 5.1 setup). All other speakers update flawlessly except for this room where three of the units consistently fail. The two workarounds I’ve used that have worked are:

  1. Connect the speakers with a network cable. Unplug and plug them back in. Wait for them to restart then rerun the update. I’ve had to do this one speaker at a time (turn off the other two) because I don’t have a long enough cable, or I’ve moved them to the room with the network equipment.
  2. Unplug the four speakers in the bundle. Plug two of the speakers back in. Once fully booted, run the update. Unplug the two updated speakers and plug in the other two. Wait until they boot and rerun the update.

Let me know if this helps.