Answered

Sonos Playback in Alexa Routine


Adding music to a wake-up routine, trying to get the playback device or "Alexa will respond from" to be my Sonos speakers, but only see Amazon devices available for selection. Only other choice is to respond from "the device you speak to," but that throws an error when the routine executes and no music plays from my Sonos. Thoughts?
icon

Best answer by Blue Hornet 6 July 2019, 12:05

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

Userlevel 7
Badge +20
Hi

At this moment in time, Sonos devices can call Alexa Routines but can't be included within the Actions of the Routine. You could use IFTTT and the Applet to play a Sonos Favorite as an alternative.
The answer is incorrect. I've had this working for the last twelve months. I'm only here because I just changed my routine to play a different station from tune in and it is now playing on the Echo. The routine says "play on..." But I now cannot edit which device to play this station on. Are you suggesting that an Alexa update has removed this feature?
Ok, just remembered the answer. In the routine select "Music" then add the song or station and add "On your Sonos speaker name" so in my case, it says "Soma FM Groove Salad On Lounge" without the quotes. Then I select Tune In as my provider.
The reason this wasn't working for me earlier is that the radio station I was trying to use was "Dark Side Lounge on Lounge" for some reason Echo does not like the word "Lounge" in my station name, probably because it is the same name as my speaker 😀
Userlevel 7
Badge +20
The answer is incorrect. I've had this working for the last twelve months. I'm only here because I just changed my routine to play a different station from tune in and it is now playing on the Echo. The routine says "play on..." But I now cannot edit which device to play this station on. Are you suggesting that an Alexa update has removed this feature?
Hi Blue Hornet

Where are you located, the ability to select a Sonos Device is not available in the UK.
See my next answer. I am in the UK and it is working fine.
Userlevel 7
Badge +20
That's interesting, I don't have the option "On your Sonos speaker name"
It is not an "Option" - as explained, you just add the speaker name to the end of the station name.
Userlevel 7
Badge +20
It is not an "Option" - as explained, you just add the speaker name to the end of the station name.
I didn't know this was available, thank you for this. 🙂
Not all heroes wear capes, Blue Hornet. Thanks for the answer, I’ve got it working on my set now!!
Badge
The trick also worked for me (I'm in Canada). However Alexa still says "Audio actions in routines are currently not supported on this device" before the music starts playing on my Sonos One. Is there also a workaround for that? 🙂

Genius!  Thank you!

Badge +2

Doesn't work.

As soon as I put "on my speaker name" after the radio station, it says : sorry we couldn't find any results, please try another search.

 

How do I get it working.

None of my routines work by the way.

Userlevel 7
Badge +20

Doesn't work.

As soon as I put "on my speaker name" after the radio station, it says : sorry we couldn't find any results, please try another search.

 

How do I get it working.

None of my routines work by the way.


Can you try a different radio station or select a track, it’s still working for me.  

 

Edit:

 

Can you post the phrase you are getting the error with and I’ll test that.

Badge +2

Can you try a different radio station or select a track, it’s still working for me.  

 

Edit:

 

Can you post the phrase you are getting the error with and I’ll test that.

Here are some screenshots:

 

 

I saw a video from someone on youtube and he had more options on the "Alexa will respond from" page

Maybe the problem lies there ?

Badge +2

So I now made another routine, this time I choose something from spotify instead of tunein and I've tested it from within the Alexa app and that seems to work, but I still have to test it with the Sonos speaker, 

when I test the other routine, the one with radio 2 from tunein, she responds that she can't play tunein from this device

Badge +2

I’ve signed out and deleted the Alexa app, then re-installed it.

Still no routines working, pfffff

 

I’ve read somewhere that Sonos will not work with Alexa routines,
but before my switch to Google assistent, it would at least work with the featured routine called “Good Morning”, now back for the 3rd time on Alexa after re-installing the app,

no routines work.

 

Can’t understand it.

 

Also the radio 2 skill only works half. Before I could say “play Radio 2”

Now I can only use the skill with either “open Radio 2” or “Start Radio 2”

“Play Radio 2” gives me BBC Radio 2, which is the wrong station

“open” or “start” give me the right station, which is VRT Radio 2

 

So that’s not a big deal, but also strange that it worked before with “play Radio 2”

 

Any help would be great !!
Thanks in advance.