Repair ZP120



Show first post

286 replies

Userlevel 1
Badge +2
I am still puzzled as to why your shorted diodes don't blow the fuse. Wonder if the common core inductor just before the diodes has been blown open?
Good news on your Play5, never tried to fix one. I have a Play3 that shuts down after a few minutes. That I will save for another day.
Gruv2ths,

I couldn't detect visually any cracks in the solder joints of caps on the logic board. I don't have the oscilloscope or skill to troubleshoot the noise I'm hearing. I'm an old analog guy and digital control circuits are new to me. I'll wait until I can locate another logic board to try as a replacement. If you or anyone else on the forum has a logic board they want to sell then please let me know.
Userlevel 1
Badge +2
Pdog,
What I meant was, look for cracked ceramic caps.
I have a spare logic board.
Will message you.
Userlevel 1
Badge +2
Pdog,
You can take a radial leaded ceramic cap and touch its leads to the various ceramic cap leads while the noise is obvious and see if any of them seem to like the parallel capacitance and the noise is damped. Just a thought.
Hello gruve2ths excellent jobb back there.
I have a zp120 it goes flashing orange and white when play is pressed. I have changed the driver IC 14pin on the logic card and that broblem was solved internet connection and volume ok but still not get any sound from the speakers!! I'm not sure that i soldered all the pins from the new 14 pin IC on the logic board .... is there any chematic or can i measure it some way.
Userlevel 1
Badge +2
Hi Sotisg69,
Well if you’re original problem is gone but now you have a new problem, I would definitely resolder the pins of the new IC. Maybe take a magnifying glass and see if you have good solder flow on each pin, and more importantly make sure you have not bridged and pins with solder.
After that when you push play, make sure your 36V test point on the bottom of the power board goes from 15V to 36V.
If all that is ok, there is a pre-amp chip between the logic board and the power amp ICs. It has a mute pin that you can see if it is stuck. But it’s unlikely. More likely your already on the right track.
Hi Gruv2ths.
After i´m push play its still 15V at 36V testpoint?
Hi Gruv2ths,

I had some fun trying to bridge a 0.1ufd cap across some of the caps on the logic board. It's not a practical thing to do on the small package caps but the principal of the problem-solving action is sound give the noise I'm hearing. Unfortunately my efforts had no impact. I don't think it is cap filtering issue. What I did discover, however, was when I disconnected the three amp antennas from the logic board, and therefore shut down the Sonos net, the noise almost entirely disappeared. The amp was hardwired by Ethernet cable to my music server and the amp had been broadcasting to the other Sonos units. I could still hear the noise faintly but not enough to make the amp unusable which was the case before. Unfortunately I don't want to use the amp as a stand alone amplifier unconnected to a net. I then tried connecting the amp by another Ethernet cable to a Sonos bridge. The Sonos net went into action, but the noise returned which I didn't expect. I thought the Ethernet would just be an in and out connection through the amp with no impact on the noise. In any case, it appears that the issue is in the logic board and not as simple as a damaged cap.

I'm not sure whether I want to sink any more money into the amp at this point.
Another thought, since the bridge was sitting near the amp maybe that wasn't a "fair" set-up. Even with the amp's antennas disconnected, maybe the amps logic board was picking up enough wi-fi signal from the bridge to start processing the Wi-fi signal and triggering the noise issue. I've packed everything up now. Maybe tomorrow I'll try again with the amp much further away from the bridge. However, even if the logic baord stops processing a Wi-Fi signal and the noise disappears (just a theory), it still leaves me needing a new logic board.

It's all fun though!
Userlevel 1
Badge +2
sotisg69
Hmmm, well that's not good. The 36V is what biases the output section.
So we need the 36V.
Can you check to make sure the CPU GND test point is 0 ohms to the RTN36V test point. If not they need to be shorted together.
The controller for the 36V and the 36V gate drive circuit is on the riser card between the power and logic boards. Near the transformer on the riser board. (the transformer is part of the gate drive for he 36V supply)
That is as good a place as any to start.
Let me look at one I have and will see if I can make a test aid.
Userlevel 1
Badge +2
Pdog,
Wow this is a new one for me.
A few thoughts.
- I have noticed that when removing the antenna connectors from the wifi card it is exceedingly easy to mess up the termination given all the glue holding them in place.So you might want to try connecting the antennas one at a time and see if one of them makes the problem worse then the others. These things will work without all 3 antennas connected.
- Another thing you can try is to remove the wifi card all together and see what happens. Then just run it with the ethernet, for that test.
Good idea. I'll try removing the Wi-Fi card tomorrow and see what happens.
Gruv2ths, thanks for the quick reply.
The CPU GND test point is 0 ohms (shorted) to the RTN36V test point but i notised that i dont have power after the transformer on secondary side See picture attachedthe

.
Gruv2ths,

Bingo! It's the Wi-Fi card. With it removed the "static-like" noise is gone - even with a Sonos bridge (radiating RF) sitting next to the amp.

The Wi-Fi card is tricky to remove from the logic board. There is a mechanical clip on each side of the card and glue has to be removed to free it. There is also a small square foam pad glued between the Wi-Fi board and the logic board to secure the Wi-Fi card even more securely. I mention that should anyone else try to remove the Wi-fi card from the logic board.

The amp is connected to my music server by Ethernet cable and there is a pass through Ethernet connection to my bridge which then creates a Sonos net with my other units. As long as my amp doesn't need W-fi, I'm ok. Everything sounds and works fine. BTW, without the Wi-Fi card in the amp, the front controls on the amp are disabled. Fortunately a remote controller will still perform those functions.
Userlevel 1
Badge +2
Pdog,
Glad you got down to root cause.
Didn't know about the wifi card disabling the front button panel.
Thanks for the heads up on that.
Userlevel 1
Badge +2
sotisg69,
FYI-You won't see a voltage on the transformer secondaries unless you are in AC mode with a tru-RMS meter.
And the DC measurements need to be made with the black lead of your meter to either RTN36 or CPU_GND (they are shorted together as you mentioned)
A few observations, if your AMP shows up on your phone then you must have 3.3V, 8V(5V after the liner reg) and 15V. You most likely have your meter referenced to the wrong point.
Another though is that the logic card probably turns on the 36V supply through the driver chip that you replaced. So if you're not sure the solder is correct on that chip, i would concentrate there. Can you take a high res pic of the chip on the board for us to take a look at? We may be able to inspect your solder if the pic is clear enough.
I misled you. I forgot to reconnect the ribbon cable from the front panel controls! It attaches to the logic board directly below the Wi-Fi card. The controls now work fine. Your reply made me rethink what I had done. 🙂
Gruv2ths thanks for the suggestions you got a point there. This pickture was taken before i soldered the new chip

you can se that some of the pins on the logic board in the midle are missing :(:( so i wonder if you can se on another board where the pins from the 14pins Ic are conected on the logic board so i can conect it with cables.
Userlevel 1
Badge +2
sotisg69
Oh my! Well that's not good.
What I would do is take some isopropyl alcohol with an acid brush and clean away the flux and see what is left. Also Tin the pads that are left once clean.
I will take a pick if a good board. Give me a little time.
Userlevel 1
Badge +2
Sotisg69,
Hope this helps.
Hello gruve2ths excellent jobb back there once again. Iknow i almost kill it
I can se that the pin 8 from Ic goes to R15543
pin 9 ? the same?
pin 10 R15544
but i missing
pin 3,4,5 and must be sure 10,11,12
Please !:P
Userlevel 1
Badge +2
sotisg69,
You have to zoom way way in to the pictures that i attached to see traces.
As you can see most of the pins of that IC via down underneath the pads so no visible traces can be found. I suspect the inputs to that chip all come from the controller. The outputs are likely that connector next to the chip.
Gruv2ths
Is there a another way to figure that out?
I will do som measurment tomorow and let you know .
😃
Hello gruve2ths.
Do you think you can help me locate the missing pins3,4,5 ,11and 12

.
Best regards Sotis
Userlevel 1
Badge +2
Sotis,
Sorry this took a long time.
So can't help you with all the pins, but but was able to find continuity for a few.
The continuity is between the driver ICs output to the 32 pin connector next to it.
(look at the silk screen around the connector, you will find the pin number guide there)

IC Connector
2 4
4 5
8 23
Sounds like you just may need to get the 36V power converter enable connected.
Maybe if the above doesn't help, You can look at the datasheet for the IC and look at the input pins and see which ones go high when you push play. and go from there.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings