Boost will not connect to new Asus RT AX-88U router

  • 29 November 2021
  • 45 replies
  • 359 views

Badge

I recently replaced my home router with a Asus RT AX88U router. After setting up my router using the same wifi name and password, I started my Sonos app. All my speakers were recognized and connected. The only component that would not reconnect was the Sonos boost. I tried a factory reset and the boost went through its startup, led flashing white / orange, then changed to a slow flashing green. The boost will on connect and I am at a loss. Thanks in advance for any help.

 

Andrew


45 replies

If you have ‘Airtime Fairness’ and/or ‘QOS’ enabled in the Asus router settings, see if switching off those features resolves the issue for you.

Badge

Airtime fairness is disabled

Badge

The boost is connected directly to the router via Ethernet cable. The Sonos app does not see it.

See this thread too.. 

Also … Did you first add the Boost (whilst unwired) to the existing system, via ‘Add Product’ in the Sonos App “Settings/System” and then wire it afterwards?

Badge

QOS is off as well

If not done already, may find it best to setup the Boost uncabled initially, then cable it afterwards… see this link:

https://support.sonos.com/s/article/417

Badge

The boost was operating fine with my old router. When I replaced the router, I connected the boost using the Ethernet cable to the new router. All the wifi speakers restored after configuring the new router. The boost simply did not come back on line. I am reading that there may be some compatibility issues

Badge

So I tried reverting back to my old router. The Sonos boost will not be recognized there now.

it worked perfectly fine prior to the upgrade.

Go to Settings/System/About. Are all the units showing WM:1 or WM:2? If so they're all on the WiFi. 

Temporarily wire a speaker. Wait a few minutes. Check that About now shows all as WM:0. 

Wire the Boost as well. If it doesn't show up, factory reset it and add it again. 

You can then unwire the speaker. 

Assuming you have no Move or Roam, delete the WiFi credentials from the system. 

Badge

Thanks Ratty

My units are showing on WM:1

BTW, I have a playbar, sub, sonos1 and a sonos move

When I tried connect the sonos one with an ethernet cable, all units disappeared and my app indicated that there was no connection. When I removed the ethernet cable, the playbar and sub returned. 

One last note, on my router, I have disabled the 5G network.

 

 

With the One wired all the rest, except for the Move, should have moved over to SonosNet, and hence the router’s wired segment. Strange that they disappeared.

Is the Asus router the sole source of a WiFi signal, or do you also have mesh units or extenders?  

There’s some things to perhaps try mentioned in this earlier thread…

 

Badge

So I just spent some time with Sonos Support and it appears my problem lies in the fact that the Asus router has a 2.4 and 5G network. The boost when connected has been running on the 5G network. The move is connected to the 2.4 network. In Canada, the move is only capable of running on the 2.4 network. I will be contacting Asus to see if I can force the boost to run on the 2.4 network which will then allow me to access all speakers. Otherwise, I have to switch networks on my controller to see the different speakers. 

Sorry, but not a lot of this makes sense. The Boost doesn’t run on any kind of WiFi. It’s either wired to the network or connects wirelessly over SonosNet. You can’t ‘force the Boost to run on the 2.4 [WiFi] network’, because it doesn’t use WiFi.

If a controller on one of the WiFi bands can’t see the Boost the fault is in the router. Some don’t correctly forward discovery multicasts/broadcasts between network segments. Having dual bands is not a ‘problem’ at all per se. 

 

I also don’t understand the comment about the Move not working on 5GHz in Canada.

Badge

Ratty

I don’t understand it either but will be contacting Asus to see if I can get further.

In Canada, the Sonos Move only operates on the 2.4 frequency. Restricted for whatever reason. 

To stream my music, I currently am using an Ipad or android cell phone. When I open the sonos app, and my Ipad is connected to the 2.4 network, all I can see for components is the Sonos Move. If I switch my Ipad to the 5G network, I can see the Sonos Boost, play bar, sub and sonos 1. For whatever reason, I cannot get all the components onto the same network. Sonos Support recommended that I contact Asus to see if additional parameters need to changed in my router so that all devices can be available on the 2.4 network. 

Hope that clairifies things slightly

Userlevel 7
Badge +17

You are taking about this Sonos device, aren’t you?

 

Badge

Yes sir. 

Badge

And BTW, Asus support just told me that the problem is with Sonos. 

And Sonos says the problem is with Asus. 

I guess, I will keep on battling and see where it gets me.

Badge

So in reality all the Sonos devices are connected to my router. The problem I am having is that to utilize the Sonos Move I have to have my Ipad connected to my 2.4 network. To utilize all my other Sonos products, I have to have my Ipad connected to the 5G network. I cannot connect my Ipad to all devices at once.

Userlevel 7
Badge +17

Just to be clear: your Boost is cabled to your router and can only be seen by devices that are on the 2,4Ghz network?

There’s been more reports of routers not being able to fully connect between 5Ghz, 2,4Ghz and cabled parts of the same network. Recent incidents are BT in the UK and KPN in the Netherlands. Your problem sounds like is lies with Asus.

Badge

My boost is connected to the router and can only be seen by devices on the 5G network.

The move can only be seen on the 2.4 network 

So I cannot access all at once from the same controller, in my case, ipad, at the same time.

Earlier in your posts @Drewmyster you mentioned you had ‘disabled’ your 5Ghz WiFi band - did that not solve the issue, as all would then run on the 2.4Ghz band? It sounds to me however that @ratty hit the nail on the head here, when he said some routers don’t correctly forward discovery multicasts/broadcasts between network segments.. it sounds like this Asus router is one of those.

I noticed too, In one of the linked threads mentioned earlier, that @GuitarSuperstar mentions this…

"Is Smart Connect enabled on your router?” 

I’m guessing here, but I think he was suggesting that router feature needs to be ‘off’, but perhaps try it ‘on’ and ‘off’ to see if that setting might make a difference.

It sounds like a multicast/broadcast discovery issue to me and one that Asus perhaps needs to solve, I think. 

Badge

You are correct, I disabled the the 5G network by turning on the radio portion. This I assume only prevents the transmission and receiving of this frequency. When I did this, I could connect all my components except the Sonos boost. When i connected the boost, all components disappeared with the exception of the Sonos move.

As for the smart connect, when this was enabled, all I could see on my iPad was the Sonos move. With smart connect, I am not able to see which network I actually am on. The router simply assigned things. 
 

The only way I can see all components is by having my iPad connected to a specific network, so when connected to the 2.4 network, I could only see the Sonos move. When connected to the 5G network I could see the boost, play bar, sub and Sonos 1. 
 

I cannot connect to all the components on on network which results in not being able to stream the same music to all my components throughout my home.

Hopefully that makes sense. 
 

Yes it makes sense - it sounds like multicast/discovery of devices are just working on the separate network segments, but the packets are not passing between the segments - I can think of a way to perhaps solve it, but it means running all or your Sonos products on your routers 2.4Ghz band and set aside the Boost. Here’s my suggestion…

At your own risk …What you could do, is switch off the ‘Smart Connect’ feature and rename the 5Ghz band. So if your SSID is named ‘localnetwork’ (just as an example). Then simply rename the 5Ghz band by adding -5G to the SSID name, so that it becomes ‘localnetwork-5G’. Leave the 2.4Ghz band named ‘localnetwork’.

Then ensure the 2.4Ghz band SSID (localnetwork) is the only network SSID listed in the Sonos App in ‘Settings/System/Network/Manage Networks’ area .. all should then run on your routers 2.4Ghz band only and if you connect your mobile controller to that band you should then see all your devices.

Then if you want other (non-Sonos) network devices to use the 5Ghz band, you can go onto move those over to the ‘localnetwork-5G’ band.

…But.. personally speaking, I think Asus should be the ones to fix this issue with their router firmware.

Badge

Thank Ken, that’s pretty much what I have been doing. 

im reluctant to scrap the Sonos boost because it keeps all components with the exception of the move on the same band. Prior to the boost being installed I had issues whereby a comment would disconnect and switch bands. That resulted in me potentially having the playbar on one band and the sub on another. The boost keeps everything on one band with the exception of the move.
 

I could also sell my Canadian version of the Sonos move and buy the US version. Lol

I’ll pick away at this in my spare time. 
 

Thanks for everyone’s input.

Reply