Sonos Move Wifi Connect Issue

I see this question a lot in the community and I can’t believe this is still an issue in 2023!  Expanded wifi networks is nothing new and why has Sonos not figured this out?  I dumbed down my network to only have 1 AP up and forced it to 2.4GHZ but the Sonos Move REFUSES TO CONNECT TO WIFI!  It is beyond frustrating.  I use Aruba for my APs and have 6 connect amps on the same SSID that I am trying to connect to.  Everything works great but the friggin’ Move doesn’t want to be a part of the system.  It worked fine until I migrated all of my devices over to one SSID.  Previously they were spread out on a few SSIDs and playing nicely.  I factory reset this thing, made sure my controller/android app/ios app is on the same SSID but I still get no joy.  Please help me so I don’t throw this thing in the street and beat it with a bat.


Best answer by AZ-Joe 26 June 2023, 18:27

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Perhaps check the 2.4Ghz band is set to 802.11b/g compatibility and that the security mode is WPA2 personal and see if that resolves the issue. Also that there is only one DHCP server operating on the network subnet with address availability.

Sonos System Requirements

Mine is WPA2-Personal.  My APs are Aruba IAP 215’s.  They support b/g and other specs.  Only 1 DHCP server on the network.  I can see the MAC registered on the router and verified the IP is on the same subnet as the other Sonos devices.


Unless it’s a multicast ‘discovery issue’ by your Sonos controller - Sonos uses SSDP to discover your devices on the same network subnet.

I did find this suggestion below and a mention of Aruba (albeit I’m not familiar with Aruba personally speaking) - maybe this will assist you if you have an Aruba router?

  • Log in to the router
  • Go to Firewall Settings → Multicast
  • Enable Multicast. (Uncheck "Require IGMP Membership reports for multicast data forwarding" and choose "Enable reception of all multicast addresses" in Multicast Policies.)  Click "Accept".
  • Go to Network.
  • Click the Configure button for the LAN zone (default name?) Click the Advanced tab and check "Enable Multicast Support". Click OK. Click the Configure button for the WLAN zone (default name?) Click the Advanced tab and check "Enable Multicast Support". Click OK. Click "Accept".
  • This should automatically modify the Zone-to-Zone rules to "Allow" the traffic for IGMP for the LAN and WLAN zones (under Firewall.)

If the above is not helpful, then perhaps just see what happens when you connect the Sonos controller device and the Move not only to the same AP, but to the same WiFi band too… If that sorts it, then there might be a multicast discovery issue across the different Aruba AP’s, maybe in conjunction with your router… that’s just a guess on my part. It’s more likely though if you have (at least) one of your 6 C:A’s wired to the LAN and running those on SonosNet, rather than your WiFi, as that would explain why those Amps are working okay.

Great information.  Didn’t know it used SSDP.  I have a crappy NetGear router that will soon get replaced with something much better but in the mean time, I will play with the Multicast settings on the APs to make sure they are not filtering requests and responses.

And - My Connect amps are wired to the same network that is extended on the Wi-Fi SSID.  I did play around with forcing one amp to only use Wired network to see if the Move would see it but that didn’t help.  I don’t use SonosNet, just Wi-Fi.  Great suggestions.  This was very helpful.

Userlevel 7
Badge +17

Remember the Move only uses wifi, not Sonosnet.

Userlevel 5
Badge +12

Not relevant to the Move but although You may not use Sonosnet IIRC the moment you wire one of your connect amps there will be a Sonosnet out there waiting to he used.

Nope, nothing to do with SonosNet as it’s likely a multicast discovery issue (SSDP), but SonosNet would perhaps explain why the Amps are working and the Move isn’t.

Userlevel 7
Badge +21

I have had issues with my Moves stubbornly keeping a connection to a distant Access point where there is a far better one close by.  I’ve had to power cycle them in the past.


I have had issues with my Moves stubbornly keeping a connection to a distant Access point where there is a far better one close by.  I’ve had to power cycle them in the past.

At one point the OP says they had the controller and Move linked to the same Access Point - but not necessarily the same band - so that’s why I’m thinking there might be a multicast issue here with the Aruba hubs and the fixes I’ve seen on the forum and online, tend to hint at that being the problem - many solve it by switching devices to use SonosNet but clearly that’s not an option with a Move - here’s hoping the settings mentioned above apply to the Aruba access points too, but it could be a case they need an Aruba router to sort it all out - I’m not too sure 🤔? I’m not familiar with Aruba at all.

So, I re-enabled Wi-Fi on the one connect amp that I disabled Wi-Fi on and the Move immediately popped up as unconfigured in my Room list.  It really shouldn’t be this hard.  Thank you to everyone for the information and suggestions.