Answered

How do I turn off Spotify Autoplay in Sonos

  • 12 November 2021
  • 4 replies
  • 592 views

I hate Autoplay. A few weeks ago I had a clean install on my computer (Macbook) and then installed Spotify and connected to my Sonos system to listen to some nice music. As it turns out after a while, Autoplay is enabled in Spotify by default. No worries, I disabled it in the Spotify settings. In the very rare occasions when I listen to music on my Macbook (not through Sonos) it respects my choice just as I expect. However, in the meantime Sonos seems to have remembered that Autoplay is ON and since then everytime I listen to anything through Sonos started in Spotify, Autoplay is enabled and it starts to play random music after my playlist or album has ended. (Did I mention I hate autoplay?!) It’s all the same if I play music through Spotify using my iPhone. I looked everywhere in the Sonos app both on my Macbook and on my iPhone, but can’t seem to find any switch for that. Damn! Where do I click?

icon

Best answer by Ken_Griffiths 12 November 2021, 23:11

View original

4 replies

It appears, according to this news article linked below, that this is something that Spotify have put in place, so maybe this is one for Spotify to answer, as it applies to all ‘connect’ devices and not just Sonos. 

https://www.theverge.com/2021/11/10/22774897/spotify-connect-autoplay-default-speaker-music-streaming

Also see this thread in the Spotify community:

 https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Connect-Autoplay-DISABLED-but-still-ACTIVE/td-p/5279608

When playing using the Spotify app you are barely using the Sonos system at all, just Spotify Connect enabled speakers made by Sonos. There cannot possibly be a setting for this in the Sonos app or anything Sonos can do about it. 

Thanks for both! It makes sense now. I mean it absolutely doesn’t make sense for Spotify to do this, but Autoplay was off when using it on its own (not connected to Sonos), that’s why I thought it would be a Sonos thing.

Thanks for both! It makes sense now. I mean it absolutely doesn’t make sense for Spotify to do this, but Autoplay was off when using it on its own (not connected to Sonos), that’s why I thought it would be a Sonos thing.

A perfectly reasonable conclusion on the evidence you had, but not actually true.  It surprises me, too, that Spotify Connect could differ in this way.

Reply