Google assistant on Sonos one not responding



Show first post

58 replies

I had a similar issue. Since a week, Sonos stopped understanding basic commands like Play Joe Fm on Tune-In or Volume Up or Down. It did react on the Hey Google wake up but didn’t understand a thing after that.

Here is how I fixed it:

I browsed to:

https://myactivity.google.com

Make sure you are logged in with the correct google account.

On that page you see a list of all the commands you ever gave to your google assistant and browsing history.  To make it easier and only see assistant commands, you can press the Filter button and select Assistant.  It will then only show assistant commands.

The long history list seems to confuse Sonos.  So press the “thrash can” button next to Today and all the other dates.  I had to press many times because it keeps the history day by day and there is no delete all history button.

After that, select the main “My Activity” menu on that page and select “Activity Controls”

Uncheck the two boxes in Web & App Activity.  It pauses the recording of all your activity.

This fixed the problems and I could again have a meaningful conversation with my Sonos One.

For example a command like Volume 1 or Volume 2 did not work anymore at all.  Since I went through the above steps, these work again.

Despite the fact that I disabled “Include voice and audio recordings” in the “My Activity” section, it still seems to register all commands in the history.  So I may need to clear this in a month from now again.

It would be great if the Sonos team checks why this activity history is such a problem with the Sonos One. Because it isn’t a problem with other devices like Google’s own Home devices.

This is soooooo annoying!

I am having the same issue. My setup:

iPhone 11 pro

Netherlands

Language English USA

Sonos One

What helped:

Deleting all my Google history including the Google assistant of course.

The restarting the Sonos One and pressing the play button.

Problem is that sometimes it works and sometimes it just doesn’t.

I agree. Even after doing the history clear. It is still hard to have the Sonos understand the volume commands. It worked so well initially. Just got another update from Sonos but still same problem.

Hi, 

 

 

looks like I’m having the exact same issues with our new Sonos one as described above. 
 

A while ago we bought a beam and the voice control with google assistent (in dutch) works perfectly. We use google home with niko home control so we ask GA a lot. We wanted a microphone upstairs as well so we bought a Sonos one to place in the hallway. The Sonos one literally responded once to a command but after that she only responded to “hey google” and after that nothing happened anymore. In the history I can see “unknown message”. The beam however understands this commands perfectly fine. 
 

I tried some things mentioned on this forum (delete history, restarting, language,..) but nothing seems to help. 

Guess I just wait here for a solution! :(

 


 

 

I found something interesting. You have noticed that the Sonos is flawless in understanding Hey Google. After that doesn't understand a thing. It seems that the first few seconds after the confirmation tone, it does not seem to listen at all.

 

Lately, I wait about 3 seconds after the confimation tone to say the command. It appears to understand things much better using this method. Of course it is still a far cry from the real Google assistance experience. 

This trick doesn’t seem to work with mine, however the speaker finally managed to understand something and she started playing a toilet flushing sound as a response 😩😩😩 it’s sort of progression i guess... 

 

Same problem for me. I specifically bought the sonos because they’re been heavily advertising it as supporting google assistant, but honestly, it’s completely useless at this point. For two weeks I’ve been able to get Google to respond only once or twice correctly to what I was asking, and 100% of the time the responses are so delayed that it’s completely useless. I’m talking like 30-60 seconds from the time I say my request to the time the google assistant finally responds. And, like I said, 90-95% of the time those responses from google are ‘There was a glitch, please try again in a little while’ or ‘Something went wrong, please try again.’

 

Has Sonos acknowledged this problem at all? They really shouldn’t advertise a service on their product that’s this broken. Sadly, I’m likely going to be taking this piece of garbage back to the store for a refund, which is a shame as I really would enjoy it if not for this one specific problem. 


I have a google home mini and sonos one in the same room, when I turn off the mic on google home mini and use Sonos it misses nearly 50% of the commands.

 

In contrast, google home mini has no problem at all. 

In my activity history, the commands missed by sonos are mentioned as “Unknown voice command”.

 

It is shocking to see that a 15 euro speaker can do a better job and so many people are having the same problem since months.

Reply