Sonos cannot see Synology DS920+ Media Servers

  • 16 November 2022
  • 11 replies
  • 89 views

Badge

I have changed from a Windows Server2012 to a Synology DS920+.

Sonos can successfully index its Media Library from a music share on the Synology NAS with or without the SMB1 NTLMv1 tweaks mentioned frequently in this forum. From that I agreed that Sonos has successfully removed the SMB1 issue. I am using the S2 controller.

 

Because I have a very large music collection, only a subset (wife’s classical) is on the share and is available via the Sonos Media Library. I successfully accessed the full collection via  MediaMonkey configured as a media server on the Server2012.

I’ve set up both the Synology Media server and a Plex Media server, neither of which appear in the Sonos music sources list. They do appear (and work) on all other devices on my LAN (PCs and TVs).

A Twonky Media server on an antique Zyxel NSA310 likewise does not appear as a source on Sonos.

Currently the only way that I have found to access my whole connection is to run MediaMonkey configured as a media server on a PC, with the Synology Media Server as its source. Sonos can see this and play the contents from the Sonos S2 Controller (PC and/or Android based). It does however require the PC to be left on, which wasn’t an issue with the Server2012.

Why is it that Sonos cannot see these other media servers? I have tried both with and without the SMB1 and NTLMv1 tweaks, which I think are irrelevant in this case.


11 replies

I use a DS920+ as a media server for my collection about 3000 M4b, m4a and Mp3 Audiobooks.  Sonos is able to see and use the library as a Twonky server, or as a media library or as a plex server - or as all three at once - no problems at all.    I cannot give you any special advice, the setup and usage were exactly as expected and cause no difficulty at all

Badge

Ok - that gives me some hope! I now need to chip away and find out what the subtle difference is between your setup and mine.

I set up the DS920+ from scratch. There was an initial upgrade. After initial setup I did the optional (pull, not push) upgrade to the latest, latest OS. I did apply the SMB1/NTLMv1 tweaks which makes me think I might have had some initial issues with the Sonos Media Library use of the share, but they have since proved unnecessary. I am using the 2 ethernet ports bonded, but removing one has not made any difference to the problem. I was not using the default shares and set up my own with appropriate access rights. The Sonos Media Library happily accesses the smaller share. I can’t see any difference in setup between the default shares and my shares.

It might be a Sonos setting - I’ve only been playing with the DS920+ options. I have

Play 3 + Sub Mini

Port

Play:3
Playbar + Sub
Sonos Move
Play:5 x2
Beam linked with Play:1 X2

Thanks, Keith

*Update - just checked using Android Sonos app rather than the PC App. This shows the DNLA uPNP settings which the PC App does not, so I deselected and reselected these without effect.VLC on Android sees the DS920+ servers and the NSA310.

I use the standard shares, my books are in the music folder in sub-directories m44, m4a and mp3.  Twonky, Plex and the Sonos music library all are able to access the music share, which I address as //synology.local/m4b or m4a or mp3 when setting up the Sonos music library.  The library auto-indexes daily and is readily accessible by Sonos and by other players on my Mac systems, iPods and iPhones.  I have also been able to connect to the server externally using quikconnect and can access any and all of the books for playback using the “Audio Station” app.  

The only issue I have is that although my books all play using the Audio Station and other similar apps, none of them are custom designed for books, so the apps do not recognise authors, nor chapters, but the books play perfectly.  Most of the time of course, I use the built-in Audible player on Sonos which is superb, or, I control book access via Alexa - also superb.

I have been a Synology user for a very long time - this is my third Sysnology Nas, I still have a couple of WD and Qnap servers which are also great and work well as music libraries, Plex or Twonky servers for Sonos.

Last point - I am using up to date DSM 7.1.1-42962 Update 1 - this system has been running continuously for at least 18 months with auto shut down and start up every day.

If there is anything else needed to help - just respond

 

I should note that even though I can and have connected externally to the server, it is usually firewalled into my local network for in home use only!

Note that on my system, Plex, Synology Media Server and Twonky all show up as music source options.  Is this something to do with NTLM server settings?

Badge

The SMB1/NTLMV1 settings are no longer needed for the Sonos Media Library to read the music share on the Synology DS920+.

I have tried with and without the SMB1/NTLMV1 settings to see if I can get the DLNA sources to show up as in 8858oboe’s last comment. 8858oboe hasmanaged to acheive exacly what I want to do - but no Synology DNLA sources appear in the Sonos music source option list.

There has to be a magic setting somewhere that I’m missing! I’m not aware of having done anything complicated in my Synology setup.

I did have an additional wireless router using as an access point. I have now removed this and am running with a BTHub6 only, with all PCs, cameras, doorbells and many Sonos products beeing gradually added and IP addresses checked as they were added.

The Synology DNLA sources are seen by PCs and TVs on the LAN. The PCs have SMB1 disabled.

Shares on a Zyxel NSA310 NAS (which requires SMB1) cannot be seen by Sonos or PCs without SMB1, but the Twonky media server is visible on the PCs and TV, but NOT by Sonos.

I begins to look like there is some DNLA oddity with Sonos which is stopping it from seeing these media servers. MediaMonkey servers on PCs are seen by Sonos.

FWIW - I've been using my Sonos Beam w/ a Synology DS218+ for 3 years now, no issues. 

But all of a sudden this week I can't see the media library in the Sonos app. I can remove and re-add it and it will re-index. But once it's done that the media library disappears from the sources page. 

 

Worked just fine last week. No idea what's changed. Have been through all the usual reboots etc, with no success. 

Badge

I’ve now persuaded Plex to work with the DS920+ and Sonos (required access permissions to be granted at the System Plex user level), so my vast music collection is now accessible without an intermediary PC - it was also accessible through getting a PC-based MediaMonkey to ‘translate’ the Synology Media Server (which MediaMonkey could see, but Sonos couldn’t) into a source that Sonos COULD see.

The smaller Classical collection works via the Sonos Media library pointing at a Classical share.

Still no sign of the Synology Medi server direct via Sonos, which I suspect is due to a uPNP/DNLA handling wrinkle with Sonos.

What did Sonos Customer Support say when you submitted a diagnostic, and called them with the diagnostic number?

Badge

Hi Bruce - chicken and egg. I gather I have to call them first then provide a diagnostic. Diagnostic of what? A diagnostic of something it’s not seeing seems a bit Zen-like… I will do so when I have a moment  now that I’m convinced the issue is with the Sonos DNLA rather than the Synology end. Currently Plex is working for me. Regards, Keith

Well, you can do the diagnostic first, and then call them. In my imagination there might be an error of something like ‘this connection is refused because of this response’ which they would be aware of reason X, and give you at least a suggestion to try something. Or, if it is an issue with Sonos’ DNLA connection, they at least have hard data to pass on to the engineers responsible for ‘fixing’ the bug. I know the engineers I work with much prefer hard data to anecdotal when working on their bugs. 

Reply