Sonos app won't connect to NAS Music subfolder - can it use a two word subfolder ie: My Music?

  • 11 January 2021
  • 16 replies

When I try and add my NAS drive music subfolder (called My Music) the app says ‘No share My Music on server.  If I put ‘Music’ (though not a real subfolder) it connects but clearly nothing there.  Any help? All my other devices connect flawlessly.  Thanks!


Best answer by djlacey 16 January 2021, 18:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

You may need to check the settings on the NAS, and make sure SMB v1 is turned on. It’s what the speakers use to reach the data there. The controller doesn’t have the same need, which can be confusing, but the controller also doesn’t ‘play’ the music. 

Just as a note, if the software updates on your NAS, it frequently turns off SMB v1, and you may need to explicitly turn it back on. I have had at least two, maybe three instances of that occurring with WD MyCloud. 

SMB V1 and V2 enabled. Again if I show path as ‘Music’ it has no issue though no real folder.  It’s labeled My Music which it appears cannot map to using the Sonos app?

No clue, you’ve exhausted my extremely limited knowledge. 

Thanks for trying! Any other help?

Thanks for trying! Any other help?

If you put music files in the folder labelled ‘Music’, does Sonos see them OK? If so, then could the ‘My Music’ folder be a reserved folder - e.g. like ‘My Pictures’, ‘My Video’ etc. It might be reserved by the system for DNLA type use, for example. 

Does it work if you use another two word folder? e.g. Test Music?

What type of NAS is it?

I’m a moron figured it out - my mistake/thanks all!

Might be helpful to other folks if you explained what you figured out. Making mistakes does not mean you’re a moron, it means you had something you either overlooked, or needed to learn. 

Userlevel 1

Hi All - absolutely agree… I’ve been struggling for hours now trying to re-establish my WD My Cloud NAS as a music source to my S1 Sonos… has been working for years.  Recent update caused everything to stop…

I’ve re-enabled SMB1 on the NAS;

The Share on the NAS is set up “Public” so that all users have access;

I can access the Share from a Win10 client with the same username / password as I use with SONOS

SONOS tells me “Access is denied”

I’ve been going round in circles… changing settings and rebooting… some assistance would be much appreciated…


Here’s where I discussed the new WD OS:


Not sure if that will help or not. 

Userlevel 1

Thanks Airgetlam - I’ve enabled SMB 1, 2 1nd 3 on the NAS… so it looks like this:

.. are you suggesting that just SMB v1 be enabled?


Nope, that looks right from what I recall...but I’m nowhere near my NAS to double check. It suggests the issue is elsewhere, if you’ve done a full reboot of your network.

If I were you, rather than tagging on an older thread, I’d open a new topic with all your details, and then I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.

Userlevel 1

Tried with just SMB1 enabled now… didn’t help :-( //Derek

Userlevel 1

OK - saw your tip just now… will take your advice… Thx!  //Derek

Userlevel 1

Just been to the WD Community site

Found this text…


Nov 2

This issue is combination of samba 4.5.0(9/2016) removing NTLMv1 from default for security reasons, and Sonos only supporting NTLMv1. We will provide fix in a firmware release as soon as possible.
In the meantime, adding the value of ntlm auth = yes to the smb.conf will allow Sonos to authentic to the My Cloud via SMB when SMB1 is also selected in the AdminUI dashboard.

NOTE: The changes will be undone if the Samba Protocol is changed or the My Cloud rebooted…

  1. Ensure SMB1 is configured in the AdminUI as an SMB Protocol. 35

  2. Enable SSH and Login on the My Cloud 30

  3. Add this option to the global config of the smb.conf file using SSH

    vi /etc/samba/smb.conf

    ntlm auth = yes

  4. Restart Samba

    smb restart

  5. Verify the setting is still there

    cat /etc/samba/smb.conf |grep ntl
    ntlm auth = yes

  6. Add Music Library from private shares in the Sonos apps

    // 8

I changed LT LAN Manager to v1 & 2:

Seems to have solved accessing the publib Share for now… will continue digging…


Awesome catch.

I just want to thank everyone who contributed to this thread. My Sonos music library stopped connecting to my WD MyCloud NAS after a firmware update. I knew it had something to do with the settings, but my trial and error just didn’t seem to find the right combination. I’m very grateful to you all.