Libby - “unable to browse music”

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

54 replies

Userlevel 1

Just chiming into say that I’ve been trying to get Sonos and Overdrive to help me since May.  Every few months I email customer support from both companies and I get a generic email telling me they still haven’t worked out the problem. I’ve never once been able to play Libby content through my Sonos speakers, although I’ve paired/unpaired, uplugged/rebooted endlessly, and spent many hours on the phone with customer service. “Unable to browse music.” I have tried library cards from multiple library systems to no avail. “Unable to browse music.” Meanwhile I spent all this money on Sonos speakers and they can’t do the MAIN THING I WANTED THEM FOR, which is to play audiobooks for my kids.



It’s working for me again! :)

However, I don’t think it’s due to anything I did. I was away from home for a few days and when I came back and tried it, it worked. 

Before that, as part of my troubleshooting, I had: restarted my router, removed *everything* from *everything* I could think of - library card from Libby account, Libby app from my phone, Libby service from Sonos, and I refreshed my connection to Libby from within Sonos (I can’t remember quite what that’s called) and tried again after each and it still didn’t work. I got a message from “Connor” (Overdrive tech support) saying they were still working on it about a week ago. 

I’m trying to be complete in sharing what I tried because I really think nothing I did or could do fixed it - I think it was an Overdrive problem and they fixed it. It would be nice if they said something, though. I’ll ask Connor. 

Userlevel 1

YES it is now working for me as well!!! It only took 6 months, but I got this email from "Owen" at Overdrive today:


Our development team's put some Sonos compatibility changes in place based on the details you've shared and the logs they've found. Can you try playing Libby audiobooks through via Sonos once more and see what happens?


Please share the outcome and, if it's unexpected/still misbehaving, provide as much detail as you can.


Thanks for sticking it out with us! I really appreciate your help and patience.



Happy to hear that some of you have had success.  I’ve undergone all of the time consuming troubleshooting efforts that many of you have experienced in detail.  I’m still getting the “unable to browse music” response in the Sonos app.  Ugh. Sigh…...

I’ve been having this problem for the last month. It sounds like it eventually (6 months later) started working and not because of a specific step taken, is that correct? I have many books on hold that I put on hold in December and are 3 weeks away now, so disconnecting my library card is not something I want to do. 

Same issue here just following to see if someone fixes it on either end :/

Just tried setting this up for the first time. Same disappointed outcome. :(

If anyone is looking for some open-box Sonos speakers I know a Best Buy store that's going to have some because I'm going to return mine. Deal breaker!

Libby worked completely fine. Anyone start running into this issue more recently? Last time someone posted, it was about 3 months ago. I have uninstalled Libby, reinstalled it, reauthorized it. I even had to do a factory resent on my phone in the midst of Libby not working and I was hoping that would help resolve it. Nope. This is the primary app I use in Sonos and it’s really disappointing. 

Libby was working fine for me as well until about one week ago. I have read through this post and tried all of the various fixes and nothing has helped. I am still receiving the “ unable to browse music”.  I too agree that this is disappointing. 

I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Same problem here. Was on with customer service on 12/29 for more than hour. After taking all the steps mentioned here ( submit diagnostics, reinstall spots, delete Libby entirely, etc) The Sonos customer service  told me they wanted to remotely log into my laptop even though I never use that laptop to play through Sonos. I refused and it still isn’t working. Following thus for tips.


Userlevel 1

Just adding a "same issue here" comment with the hope that this issue gets some traction. I too receive "unable to browse music" when attempting to use Libby.

I’ve been trying to install the Libby service for the last 24 hours with a consistent issue: I kept getting the error message, “unable to browse music.” I keep removing and reading, giving it awhile, then checking. Same result. Any ideas? I’ve tried to unplug speakers and plug back in.

If anyone is still having this issue and wants a temporary fix, this is what worked for me.

Remove Libby from your Sonos app, uninstall the current version of Libby you have and install Libby version 4.3.1 . Add it back into Sonos and you should be able to browse and listen to your audiobooks on your Sonos device just like before 👍🏻

Remember, don't update your Libby app after reverting back LOL

After similar issues and troubleshooting, I was able to get Libby to work by opening the audiobook in Libby then go into Sonos app and browse via Overdrive/Libby and the title I opened was there and worked. I am not able to see my full loans list but maybe that'll help someone.

After similar issues and troubleshooting, I was able to get Libby to work by opening the audiobook in Libby then go into Sonos app and browse via Overdrive/Libby and the title I opened was there and worked. I am not able to see my full loans list but maybe that'll help someone.

That sounds like a excellent idea, and if I have the same trouble again, that's what I will try first! A month or so ago, everything just started working again. Possibly may have been an update? Thank you for sharing what worked for you!

Userlevel 1

*Sigh*  On the same day that Apple Music started working again, Libby stopped working.  I am now also in this dreaded “Unable to browse music” - Reauthorize loop.  Hope this gets fixed.  Anyone else having trouble?


Userlevel 2

I too have the issue of “Unable to browse music” when trying to use Libby.  It worked on Oct 1st when I finished a book.  Went to start another book Oct 3rd and it wasnt working.  Ive done the whole dance. Removed libby fully.  Added it back.  Tried reauthorizing at least 10 times. It even asked me to reauth once and I got hope it would work then but nope.  Tried rebooting every device (which is a chore in itself, if this is a troubleshooting step they should make a reboot function in the app cause getting to the power on some devices is hard).  Tried rebooting network router.  Im on sonosnet using a boost, that was rebooted as well.  Tried on iPhone, MacOS, and Windows apps same deal.  Nothing. 


Have to airplay via libby (so the app works just fine I am using it to listen to the book) out to my one sonos One that I have grouped to everything else but thats honestly not ideal.  The libby integration does kinda suck (where it sometimes restarts at the start of a chapter without warning) but airplay is not great either and Id rather not have to use two apps one to play and  one to control volume of each speaker. 


Kinda disappointed. I do wake up every morning and check thinking maybe something got fixed over night but nope.

Userlevel 2

Really wish this would somehow get resolved.  Been about a week now since I could use it. Now I guess I get what I paid for in this service (ie free) but airplay sucks. Its dodgy at best.  I still open the app and check daily, sometimes a few times a day, to no luck.

Userlevel 2

Welp it looks like its working now. Did nothing on my end. Just a solid week of going into sonos and trying over and over again.  Soooo guess complain a few times in here and it magically works?

More likely a configuration change on Libby’s servers, of some type. 

Userlevel 1
Badge +1

I almost always receive the "unable" message when I try. It usually pulls up my books on second try... until today. Nothing is different and I have rebooted samsung s21. Will try iPad pro 10. Nope. This is either Sonos or Overdrive.  PLEASE figure this out. 2 years!

What did Sonos say, when you submitted a diagnostic, and called them?

Userlevel 1

This appears to be a Libby reauthorization problem. As has been attested to elsewhere, the Libby service on Sonos wants frequent device reauthorization, sometimes weekly, sometimes daily. It is fairly random. When this happens, if you Browse to Libby, it will have no content available. What I just did now when the playback bug happened is go to the Libby settings in the Services & Voice section, and did a reauthorize. After completing that and returning to the Sonos app, it still complains, but then I again Browse to Libby, and the content shows up, and I can start playing the book again.

So maybe, at least in this case, Libby wants reauthorization, but neglects to display the dialog for it, and so trying to play the book fails.

This state does sometimes disappear. Sometimes if I wait long enough, like a day, Libby will work again. And the state can be generated by just pausing playback, then attempting to play again. I suppose the reauthorization may not be enforced while a book is playing.

So yet another Libby bug, along with the constant reauthorization requests, and not updating the current position 50% of the time, which could be a reauthorization bug as well.

I'm having the same problem. But today I have a brand new problem. I go to Sonos go to Libby and my book was there! Great and I was listening to it for approximately 1 hour and then got a new message that 

Unable to play, title of book, the connection was lost to Libby and overdrive. Or something like that you can see it at the bottom of the picture.


Whether Libby is available for me is a crap shoot. It is approximately 1/5 of the time that I'm looking for it. This was the whole reason why I got Sonos, so this is really frustrating. I talked to Libby and they say talk to Sonos I talk to  Sonos and they say talk to Libby.





Userlevel 1

Did you try forcing a reauthorization? That seems to be the root of all the problems.