Answered

Sonos Move, Alexa and 5g hotspot

  • 16 August 2021
  • 5 replies
  • 82 views

First off, I have tried to find the answer by searching this forum, so if I missed it, I apologize in advance.  
I have a Sonos Move with Alexa and several music services.  When I use it on my home network, everything works as expected.  When I take this on the road and connect it to a WiFi hotspot (5G) i cannot launch music using Alexa.  
A few points:  The hotspot has the same SSID as my home network so it just connects automatically. Alexa works “in general” , I can ask it questions and get responses. I can play music through the Sonos App.   I cannot start music by asking Alexa.  I cannot launch music through the Alexa app. The hotspot appears to provide good speed (3.86 Mbps according to speed test)

Id prefer not to use Bluetooth as I get phone calls and don’t want to disrupt the music. I’d also prefer not to use the Sonos app as my wife finds it complicated.

Am I doing something wrong?  Am I confusing it by using the same SSID?

icon

Best answer by Ken_Griffiths 16 August 2021, 20:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Just to confirm, are you using the same Sonos and Amazon Accounts too? Assuming you are, try this…

When travelling and running all on the WiFi hotspot, remove the Sonos Skill in the Alexa App and reinstall it and perhaps see if that fixes it for you.

One other thing to look at, and maybe before messing with the Sonos skill, it to see if you can cast to the Move from a music app, particularly Amazon music if you have that.  Does your Move appear on the list of speakers you can cast to?  If so, do you hear the music on the Move while  connected to your hot spot?  If you leave the Move connected to hotspot for  5-10 minutes and try again (casting a voice command), does it work now?

 

I could be off on this, but from Alexa’s point of view, the voice assistant part of the Move is one entity, and the music playing part is another.  So when you make a voice command about the weather, Alexa responds via the voice assistant, and that’s working fine.  When you make a command to play music, Alexa sends the command to the Sonos cloud , which then passes the command to your Move.  So I’m thinking that the Sonos cloud is still looking for the Move on your home network...but can’t obviously find it. So maybe it just needs a bit more time for the Sonos cloud to figure out where the Move is now?  Ken’s suggestion to reinstall the Sonos skill could force that too, although it might mess up whatever group settings you have with Sonos speakers.

 

I’ve just tested the above with my 5G router (A D-Link dwr-2101), note however in my case, I opted to use a different WiFi SSID (pre-added to my Sonos App network list) and on re-adding the sonos skill to the Alexa App (as suggested in my post above) and scanning for devices, the ‘travelling’ Sonos Roam speaker (called ‘Vortex’ in my case) is separated out from the main system by Alexa and seen in the Sonos account as a separate Sonos Household/System (even though the speaker has not been factory reset) please see screenshot attached of the setup of the sharing agreement process.

Anyhow I selected the now ‘separate’ system and everything, including the Alexa Assistant, works fine with that type of mobile setup - so all I need now is a holiday and I’m all set to go. 😂 ha ha

So removing/re-adding the Sonos skill (when all are running on the mobile WiFi) and scanning for devices should work. 🤞

Hi Ken,

First, thank you so much for all the work you have done here to help me with my question.  One quick question.  I started trying to follow your instructions above, and ran into a bit of a roadblock, so I wanted to ask before spending a lot of time on it.  It seems that the Sonos Alexa Skill can only be enabled for one network at a time (in your example you can select Vortex or your System 2).  If you select Vortex, it seems to disable everything else, which was my experience.  Is there a way to enable the skill so it works with both Vortex and the rest of your house? I would prefer to not change the skill each time I use the Roam on my hotspot and I would prefer to not “break” my house if I am using my Roam.

Hi Ken,

First, thank you so much for all the work you have done here to help me with my question.  One quick question.  I started trying to follow your instructions above, and ran into a bit of a roadblock, so I wanted to ask before spending a lot of time on it.  It seems that the Sonos Alexa Skill can only be enabled for one network at a time (in your example you can select Vortex or your System 2).  If you select Vortex, it seems to disable everything else, which was my experience.  Is there a way to enable the skill so it works with both Vortex and the rest of your house? I would prefer to not change the skill each time I use the Roam on my hotspot and I would prefer to not “break” my house if I am using my Roam.

I chose to setup the (vortex) Roam as a separate Sonos Household by using a different WiFi SSID in my case and so I had to switch the Sonos skill - but I think even if you leave it set in the same HH and try to use an identical WiFi SSID you may still have to go through the skill setup in the Alexa App and it may break your home network (even though your mobile network has the same SSID as your home router), but perhaps just try it and see what happens. It’s not a problem to put it back afterwards. Note: It’s always best to go through the skill setup process when you are actually away from the Home network (or maybe switch off the Home WiFi temporarily to test these things) and see if it does break it.