Answered

Sonos Mic not working

  • 28 March 2019
  • 6 replies
  • 4319 views

Recently purchased the Sonos One Gen 2. I don’t think the microphone has worked since I brought it. It does not light up. On have it in stereo mode with another One Gen 1. I in paired the two to see if that would work, but it didn’t.
I have tried tapping the button on the top and nothing happens. The other buttons on top work fine. The other one works perfectly. Please help.
icon

Best answer by UKMedia 28 March 2019, 11:37

Can you please Disable then Enable the Sonos skill in the Alexa App>Skills>Your Skills. The Mic isn't Enabled until your Alexa and Sonos Accounts are linked.
View original

6 replies

Userlevel 7
Badge +20
Can you please Disable then Enable the Sonos skill in the Alexa App>Skills>Your Skills. The Mic isn't Enabled until your Alexa and Sonos Accounts are linked.
Userlevel 1
I had this same issue on a pair of Ones that I have configured in a surround setup with a Playbar and Sub. All was working fine (and still did on the Ones that are in other rooms) until I had to turn off & disconnect the Playbar to paint the wall behind it.

Upon reconnection of the Playbar, the mic on both Ones being used as surround speakers no longer worked and the mic button on the top of them stopped functioning altogether. The TV's TOSLINK fiber cable was not reconnected as the TV was still removed from the wall (replacing it) and I can't imagine that getting in the way of the Alexa skill which always worked whether the TV was off or on but I'm mentioning it here in the case that you're in this same boat.

I disabled and re-enabled the Alexa skill in the Alexa app for the Sonos devices, unplugged and replugged all Sonos units in the "Living Room" surround group in the following order:
OFF = Surround Ones, Sub, Playbar; ON = Playbar, Sub, Ones
All to no avail... At this point I was truly baffled.

Oddly, after digging around in the sub-menus in the Sonos app (on my Android phone), I found that the Alexa capability had been removed from the Voice Services in the "Living Room" group. Once I added it back and got the "Hello" audio prompt from each surround speaker, the Alexa capability and microphone hardware function was back. I suppose since it deleted the "Alexa" voice service - only voice service that was active - it then disabled the hardware function of the mics as well. All I can think of is it 'glitched' when the Playbar was taken away while the other speakers in the room were still on.
Why this would delete a capability - especially a capability that the Playbar doesn't even have (I know it's the hub of everything,) is beyond me but that's what happened.

As a quick aside complaint - It truly sucks that disconnecting the Playbar seems to kill ALL Sonos devices EVERYWHERE, certainly for using voice commands. (c'mon guys, no failover to handle the Sonos-Net when the Playbar goes down??)

Seems like a strange thing to happen so I wanted to share the solution that worked for me here, as this may not always be caused by and/or fixed through the Alexa app. Hopefully this post will serve to help those who are just as baffled as I was by such a situation.

Cheers,
C
So, when I added a new Sonos One speaker to my system, I didn't realize that you had to add a voice service manually to that speaker as well. Once I followed the instructions to do that, the microphone began working.

Thanks chuckhawk.  I had a second speaker and noticed the mic light wasn’t lighting up.  I was looking at returning the device.  Seeing his ‘digging around’ paragraph, I started looking too.

 

You have to ‘attach’ your assistant to every speaker.  So if you are having this problem, go to Settings/Services/Voice (click on your assistant there) and make sure all your speakers are listed under Sonos Products.

 

Why when I added the 2nd speaker to the app it didn’t automatically add google assistant, makes no sense. 

 

Another thing that would be nice, is if you don’t have an assistant attached to the speaker, when you press the Mic button it would say something like ‘please setup an assistant in the Sonos app for this speaker’ because by default, it just makes it seem like the Mic button doesn’t work at all 

Userlevel 7
Badge +20

Thankschuckhawk.  I had a second speaker and noticed the mic light wasn’t lighting up.  I was looking at returning the device.  Seeing his ‘digging around’ paragraph, I started looking too.

 

You have to ‘attach’ your assistant to every speaker.  So if you are having this problem, go to Settings/Services/Voice (click on your assistant there) and make sure all your speakers are listed under Sonos Products.

 

Why when I added the 2nd speaker to the app it didn’t automatically add google assistant, makes no sense. 


I suspect that the reason for this is that it’s possible to have a mix of Google Assistant and Alexa activated across differing Sonos Devices and so no default settings when a new player is added.

Userlevel 5
Badge +3

Thank you very much. This sorted my issue. My problem started after installing a new router and one mic stopped working. All ok now thanks to the information here.

Reply