Alexa says Spotify needs to be linked, but it is already linked.

Userlevel 1
I have a Sonos One. I recently moved it to another plug socket in the same room and, ever since I moved it, Alexa has become unable to play music via Spotify.

When asked to play music from Spotify, Alexa says "To play Spotify, link your premium account first using the Alexa app."

In the Alexa App > Settings > Music Services, Spotify is already linked to my account (which is a premium account).

Although Alexa has become unable to connect to Spotify, I can still get Spotify music to play through the Sonos One speaker via the Spotify App.

Things I've tried:
  • I've tried unlinking and relinking my Spotify account in the Alexa app.
  • I've tried removing Alexa entirely from the Sonos One and re-adding it.
  • I've tried removing the Sonos skill from Alexa and re-adding the skill.

Does anyone have any idea what's going on here and/or what I can do to sort it out?


Best answer by Jeff S 16 November 2018, 00:49

Hi nicf,

The outage should now be resolved. If any issues continue, please submit a diagnostic report and reply in this thread with the confirmation number.
View original

13 replies

Userlevel 7
Badge +20
Hi nicf,

The outage should now be resolved. If any issues continue, please submit a diagnostic report and reply in this thread with the confirmation number.
Me too ref 1200057472
i am experiencing the same problem and alexa keeps asking me to link. ref number : 1832266146
I have the same problem has anyone resolved this issue
I have the same problem has anyone resolved this issue
Log out of the Spotify app and subsequently out of all Amazon apps (including the Alexa app) that are installed on your mobile device, and afterwards remove and re-authorise the Sonos skill.

  1. Go to your Sonos app and remove voice services from the room settings
  2. Disable the Sonos Skill in the Alexa app
  3. Go to the following page on a web browser:
  4. Then go to Smart Home > Devices > Scroll to the bottom and click Forget All
  5. Go back to the Sonos app and configure voice services
I’ve just tried all of the above and it’s still greyed out it’s becoming very frustrating Amazon was no help when I phoned them they told me it was Spotify’s problem not there’s even though it’s on amazon Alexa app
I am having same issues. I try to ask alexa to play any radio station, she tells me the station bit doesnt play it. I have tried resetting alexa, sonos and my wifi even. Removed the skills etc still nothing. Samr with spotify linked it wont wont disabled skill tried again still wont work. Says that needs to be premium which it is but doesnt work. I have plugs attachdd also which are not working now. Can turn them on by alexa app anf play music vy alrxa app but cant get it to work by voice with sonos
Same problem. Devices were all working fine until some time in the last week, then suddenly, all devices wont play Spotify or Tunein. They will all respond to "alexa, what time is it?" but when asked to "play spotify" I correctly get Alexa saying "playing Spotify" but then no audio. I can make the Spotify App connect and play audio to each Sonos with absolutely no issue. Things I tried

1) Uninstall Alexa via room settings. Re-install. Discover devices. No change.
2) In Alexa app, disable Sonos skill, and try to re-enable in the app. Login correctly, then get "Oops there has been a problem" when it tries to link to or whatever. Feels like this is part of the issue- failure of the Alexa application to correctly get a login token from the

I really do not want to factory default these things and reset them up again, because it looks like that doesn't necessarily fix it and takes a lot of time. I have 8 Sonos Ones! What a nightmare.

Submitted a diagnostic report 480479589. Also got a customer care ticket submitted.

I so incredibly frustrated with this. Like I said, I got 8 of these in October and voice performance hasn't be solid for much of the time. Is it too much to ask that advertised functionality works as promised? I mean seriously, Alexa smart control is a headline feature of this equipment?

I bought these devices instead of something like an Echo Plus because I thought premium audio was more important to me than smart functionality, but I very quickly realized that the smart functionality is far FAR more important to me and it renders the audio quality pointless if you can't rely on it.

If I can't get this working reliably soon, I'm am going to have to explore a warranty refund or something, but I don't hold much hope there since they're 6 months old and they're not physically "malfunctioning". Failing that I'm going to have the eBay the whole lot.

I have better things to do with my time than spending it relinking my "smart" speakers to music services.
And... a day later, suddenly the process where you use Alexa to disable/enable the account linking magically works today. Guess somebody fixed something, but it'd be sure nice to understand what happened via some transparency..
I have the same problem! Is there any resolution to this problem?
Userlevel 7
Badge +20
I have the same problem! Is there any resolution to this problem? First off, please Disable then Enable the Sonos skill within the Alexa App.
I have the same problem! Is there any resolution to this problem? First off, please Disable then Enable the Sonos skill within the Alexa App. I’ve tried that several times on all my devices and it still doesn’t work.
Userlevel 7
Badge +20
Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser ( or>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)
1.4/ Here is a link to my naming standards:

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.


    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings