Answered

Sonos Roam Bluetooth “Not Connected”

  • 19 September 2021
  • 2 replies
  • 190 views

Userlevel 2

Hoping for some help from Sonos experts out there!

I picked up the Roam on Friday primarily as a quality portable speaker that I take to multiple work sites. I have 3 other home Sonos devices and this seemed like a great addition with an existing Sonos system. It also is probably the best sounding speaker in its class. 

2 major issues:

  1. Wifi connectivity is limited to my home network. 
    I have wifi at my work locations. I was hoping that I could use this to connect to those networks and play music without using my iPhone. It seems it is limited to just your home Sonos wifi network. I could reconnect to the new wifi, but that is very difficult when my Sonos system is not on them. So unless there is hidden support for multiple wifi networks, I am limited to using it as a Bluetooth speaker away from home. 
     
  2. Bluetooth will not stay connected. 
    So resigned to using this as a Bluetooth speaker linked to my iPhone, I paired it easily. The issue is staying connected. If I turn the Roam off or if I lose Bluetooth connection by walking away with my iPhone it does not automatically reconnect. It is still paired, but I have to manually reconnect it under the Bluetooth settings of my iPhone. It works fine, but that is an extra step that is a real pain. 

I read many reviews and the Roam is touted for seamlessly switching from wifi to Bluetooth as a mobile speaker. Furthermore, EVERY other paired Bluetooth device I have automatically connects with my iPhone when I turn it on. Headphones, UE speakers, even an outdoor fan with a Bluetooth speaker! I know the Move has a physical button to switch from wifi to Bluetooth. My friend has it and it automatically connects to his phone when he switches it to Bluetooth. My understanding is Roam does this automatically without such a button. 

So as of now, Roam has 2 big strikes for me as a mobile speaker. I really hope there is a setting or setup issue that can resolve this. 

For the record, Roam is updated to the newest version. iPhone 11 Pro also updated as of this week. I initially set up Roam on my home wifi using the app with no issues. Then paired by Bluetooth manually after that. 

icon

Best answer by Corry P 23 September 2021, 14:05

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +17

On work locations networks are designed not to let devices “see” each other. Sonos however needs this: the phone most “see” the speaker to command it.

Userlevel 7
Badge +18

Hi @theffern 

Welcome to the Sonos Community!

@106rallye is likely correct - corporate WiFi tends to be a lot more secure around connecting devices and often will only let them communicate with the internet and not each other. 

Regarding Bluetooth, Roam is in a unique position - it can connect to both WiFi and Bluetooth, but unlike the Move it does not have a Bluetooth mode and can therefore connect to both simultaneously. Most Bluetooth speakers connect immediately to their last known host because Bluetooth is all they can do, so what’s needed from them is obvious. As your Roam doesn’t automatically know if you want it to be used on WiFi or Bluetooth, it just does what’s best for it’s battery life and saves power by not establishing the Bluetooth connection automatically. Otherwise, it would connect to Bluetooth all the time. Literally. You’d need to turn off your phone’s Bluetooth to stop it.