Question

Sonos not producing Dolby Digital 5.1 surround sound

  • 10 May 2017
  • 6 replies
  • 7134 views

Badge
I just purchased 2 Play 1's, a Sub and a PlayBase. I have connected and tuned the system successfully. Unfortunately, I am not getting Dolby 5.1 surround sound. I believe the problem might be that my TV does not pass through Dolby 5.1. I connected my PlayBase to my TV through my TV's optical audio out port (an adapter was required), but sound comes through in "Stereo" mode. I verified this on my Sonos App by looking at "Settings" and then "About My Sonos" which shows an "Audio In" note regarding my PlayBase that indicates "Stereo" not "Dolby Digital 5.1". Also, it is obvious from listening to the system that I am not receiving Dolby 5.1. My TV is a Panasonic model TCP60GT30. In my TV's user manual, it states as follows:

"You can enjoy your Home theater by connecting a Dolby Digital (5.1 channel) decoder and "Multi Channel" amplifier to the
DIGITAL AUDIO OUT terminals."

Does this mean I need a new TV, or another piece of equipment in order to get optimal sound out of my Sonos system? Any advice would be appreciated!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

I think I have the same TV as you. If I remember correctly, only broadcast TV will be output in 5.1 from the TV and not HDMI sources. I could be wrong. Instead of using the spdif out on the TV, I've plugged my 4 devices into an octava switch(mentioned frequently in these forums) and used the optical out from the switch to the playbar. I use a harmony remote to control everything. Also, i put the TV in hotel mode and was able to set the max volume of the TV to zero. You can google search how to do that. Very easy to do.
There is a monoprice switch that is much cheap and does the same thing. I had to hit the reset button on that too often to get sound back if I turned things off in the "wrong" order. This was before I had my harmony. Almost never have "wrong order" issues with the octava and the harmony combination.
Badge
Thanks very much Who Dat (...you must be a Saints fan?)! I was about to try out the cheaper Monoprice switch, but it sounds like a headache. It is much cheaper though ($65 vs the $250 for Octava). Do you find the Octava/Harmony combination that much better than the simple Monoprice (which I believe comes with a remote control, right?). I'm new to this game, so apologies if these are silly or stupid questions. I need to run a UHD DVD and Apple TV through whatever switch I end up purchasing ... does that factor in?
Hello., I just recieved the monoprice HDMI Switcher 4 in 1 out MD-415ARC from ebay...cost about 60 buck Canadian. I plugged every hdmi into it, hdmi out to tv...arc enabled...optical from monoprice switch to playbar and am now getting 5.1 with my blueray and cable tv...very happy man now! oh yeah..I have a harmony remote to..just add the monoprice switch to the device list and create activities u like...turns the switch to the appropriate input and powers it on /off without any issues...good luck!
Badge
Thanks Sinbin! Which Harmony remote did you get, and how much did it cost?
I got the harmony 650...for 59.99 canadian...i beleive that was the sale price..at bestbuy...enjoy!
Sorry to resurrect an oldish thread. To tidy up my connections a bit, I have just purchased a HDMI switcher. I have a Freesat box, DVD player & Apple TV connected to the inputs, one cable out to the ARC enabled socket on the TV & the optical out connected to my soundbase. From what I have read, this setup should provide 5.1 audio through the sondbase & 2 Sonos One surrounds. When I check the system settings though, it says I’m only getting a stereo output.
Could anyone offer any advice on this please? I have had 5.1 audio from the tv optical out before moving it through the switcher, but it seemed a bit sporadic, changing from 2.0 to 5.1 which is why I bought the switcher.
My TV just over a year old Samsung Smart, I have played around with the audio settings, but nothing seems to make any difference 😞