Answered

Sonos Arc LPCM format support so we can turn on Atmos on my Apple TV 4K

  • 23 January 2022
  • 8 replies
  • 846 views

  • Contributor I
  • 3 replies

Hi, I had the problem that dialogs were extremely soft on my Sonos Arc + Sub + 2x One surround. I already tried:

  • Enabling Speech Enhancement
  • Enabling Night Sound
  • Tuning via TruePlay
  • Disabling the 2x One Surround
  • Disabling Loudness
  • Manually tweaking EQ
  • Resetting to factory defaults and trying these things once more

The problem remained. I found several threads with people reporting the same problem, some even returning their Arc:

And they all provided the same tips and strategies that I already tried and listed abive. Some of the tips would help maybe 20%, but dialogs remained extremely soft to the point where I too considered returning the Arc. I was coming from the Playbar and never had such issues.

Then I found this post: 

 which explained that the Arc does not support LPCM which my Apple TV 4K was sending out. 

In the Apple TV 4K’s audio settings, I had to explicitly opt out of Dolby Atmos and let it re-encode all audio to Dolby 5.1, and that fixed the problems. So now I always re-encode my audio, until there is content with native Atmos, then I go into the audio settings to disable the re-encode to Dolby Digital 5.1. And when we’re done with that content, we need to setup to re-encode again.

If you want to replicate this, my setup is as follows:

  • Philips 55OLED806
  • Apple TV 4K
  • Sonos Arc + Sub + 2x One Surround
  • The Philips 55OLED806’s HDMI eARC port is connected with an HDMI 2.1 cable to the Arc. The television has eARC set to Auto (vs off) and is configured to “bypass” as to not re-encode the original signal
  • All systems up to date as per today: 2022-01-23

With this setup:

  • On Disney+, “Boba Fett” for example, works correctly and shows the Dolby Atmos logo in the Sonos App
  • On Netflix, “Riverdance” has inaudible voices and shows the “Multichannel PCM 5.1” in the Sonos App
  • When I configure the Apple TV to re-encode to Dolby Digital 5.1 in the audio settings, the movie “Riverdance” has audible voices again. The Sonos App shows: “Dolby Digital 5.1”

It is my understanding now that the Apple TV 4K transmits LPCM when the original content does not support Atmos (but the entire setup is configured to pass thru in order to enable Atmos on content that does support it). But that the Sonos Arc Does not support LPCM, resulting in a distorted experience. Which can be worked around but:

  • We now have to venture into the menu every time we switch between Atmos and non-Atmos content
  • It was hard to figure this out, less lucky users may return their Arc before finding this

My question, can Sonos confirm this is a problem, and if yes, are there any plans support LPCM in the future with an update?

icon

Best answer by GuitarSuperstar 23 January 2022, 16:56

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

I don’t have the Apple TV 4K here, but the Sonos Arc surely already supports multichannel LPCM 5.1. See screenshot from my Sonos Arc’s ‘Now Playing Screen’. 

Userlevel 7

@kvz The Sonos Arc has supported LPCM audio since November 2020 with the 12.2 S2 update. If it didn’t support LPCM, you wouldn’t be seeing “Multichannel PCM 5.1” displayed in the Sonos app.

Dialog from LPCM audio sounds great on my Arc from an Apple TV 4K and a Blu-ray player, so I don’t believe what you are experiencing is a widespread issue that affects everyone. It probably has more to do with your specific setup.

The Apple TV 4K uses a Dolby MAT encoder that converts the original Dolby Digital Plus audio from streaming services to multichannel PCM. You might consider getting a different media device that uses the original Dolby Digital Plus audio instead of LPCM. I recommend the latest Roku Ultra or an Nvidia Shield.

Thank you for clarifying the part about LPCM already being supported. So the problem is that the Apple TV 4K is sending this in a way that softens voices when non Atmos content is played(?). I don’t use any obscure device or setting, and since the Television does a bypass, the issue should lie either with the ATV or Arc or the combination of those, correct? And the fact that the Atmos logo does appear when content supports it, I don’t set an override on the ATV to re-encode, and it sounds just great, would indicate to me that the cables and most of the settings are correct. And that things fall apart for non Atmos content + not setting an override to re-encode on the ATV, would indicate some codec/format incompatibility between the ATV & Arc. That is also what you seem to think @GuitarSuperstar? I don’t have a Shield or Roku to test with, and am happy to accept those won’t yield the problem, but it would sure be nice of Arc & ATV4K would also be compatible if one tried to optimize for Atmos where possible and set things up that way.

Userlevel 7

I don’t know exactly why you are only experiencing low dialog from LPCM audio and nothing else. I am only guessing it is related to your specific setup. And since this isn’t a widespread problem that everyone is experiencing, I wouldn’t expect Sonos or Apple to address the issue. That’s why I recommend getting a different media device or using your TV’s native apps to stream non-Atmos content. You can also try redoing Trueplay tuning with a different iOS device. Different model iOS devices can produce different Trueplay tuning results.

Userlevel 7

In the ATV settings make sure things are set as follows:

Video and Audio

Audio Output: Receiver Speakers

Audio Format: Auto

Reduce Loud Sounds: Off

Sound Effects and Music: On

Audio Mode: Auto

I don’t know exactly why you are only experiencing low dialog from LPCM audio and nothing else. I am only guessing it is related to your specific setup. And since this isn’t a widespread problem that everyone is experiencing, I wouldn’t expect Sonos or Apple to address the issue. That’s why I recommend getting a different media device or using your TV’s native apps to stream non-Atmos content. You can also try redoing Trueplay tuning with a different iOS device. Different model iOS devices can produce different Trueplay tuning results.

Not sure why you’re saying it’s not widespread because for me no matter what media device I use I have to set the volume to >50% for it to be at a decent audio level. I have also seen multiple reports of this being an issue. With the 7.1 down mix issue and the low LPCM volume bug I am pretty frustrated with the lack of any updates from the sonos team. 

In the ATV settings make sure things are set as follows:

Video and Audio

Audio Output: Receiver Speakers

Audio Format: Auto

Reduce Loud Sounds: Off

Sound Effects and Music: On

Audio Mode: Auto

These were exactly my setting except for reducing loud noises which I had On. I switched it to Off for good measure but it had no effect, same problem.

i experimented further and what did fix it for me, was changing my TVs digital audio output setting from:

  • Multichannel (bypass)

to:

  • Multichannel

Now Boba Fett shows the Atmos symbol in the Sonos app while Riverdance shows: “Dolby Multichannel PCM 2.0” and has clear voices. Before, that showed “Multichannel PCM 5.1” and had inaudible voices. It switches without me having to dive into menus and had clear voices in Atmos and nonAtmos content.

I am still puzzled, I would have expected bypass to be the correct setting, and a requirement for Atmos content even. But clearly it is not for this combination of devices.

 

 

 

I do believe it’s a widespread issue. Those that I know with a Apple TV including myself have this  issue. Is that some just think you have to increase the volume quite a bit to alleviate the problem. But it shouldn’t be this way because my other soundbars didn’t have this problem.