Samsung one remote not working with Sonos Playbar (incl Workaround)

  • 4 November 2020
  • 6 replies
  • 1658 views

Hello,

 

For two weeks now I am the proud owner of a Samsung Q95T TV

When I installed the Sonos playbar to work with the Samsung One remote I followed the following instructions → https://support.sonos.com/s/article/3444?language=en_US

This worked like a charm.

 

However suddenly today the One remote no longer communicated with the Playbar, no matter what I tried (followed the instructions again , did a hard reset of my playbar etc. ) nothing worked. 

 

After browsing through the community I found a workaround (Select Samsung as home cinema brand).

 

I am nit-picking here but what I do not like is when I now press volume up/down it says Samsung instead of Sonos and of course I can perfectly live with it

But I just want to know Why do I need to select Samsung as brand to get my Sonos to work. ?

 

--------- Workaround ----------

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung (instead of Sonos)
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

----

#Shoutout to af2k for posting this Workarond at Community Post


6 replies

Userlevel 5
Badge +14

Hi @Robbert's son.

Welcome, thank you for reaching out to Sonos Community and Sharing your workaround.

If you need help with any other information, please be sure to let us know.

 

Crazy!

It felt like I was typing in a gamboy cheat code XD, but it worked!.

Thank you!

 

Work like a charm. Thank You !

Amazing! Thank you!

You sir, are a genius! 
 

Thank you for figuring it out and for sharing. 

Oh gosh thank you for posting. Been trying to figure out for six months. Sonos Support had no clue. For me, had to select Samsung and go through the four tests (not one, two or three - but the fourth), and then the Sonos remote setup (volume + push) and it finally worked. 

Reply