Question

google voice command won't play music

  • 1 October 2019
  • 4 replies
  • 685 views

Hello all,

Ive tried everything including talking to google directly and im still having issues.

My sonos one is linked to my google assistant for voice stuff and everything works ie weather, traffic, volume up/down ext. but for the life of me I cant get it to play music through voice commands. It goes like this me: "hey google play (artist) on (app)" google: "ok here's (artist) on (app).... sorry I can't do that right now". The last little bit varies a little sometimes, but ya I've tried everything. I can however go into the sonos app and select the music from there and it plays fine, Its literally just the music voice command.

List of stuff I have tried: unplugging sonos, factory reseting sonos, uninstalling music apps on phone, going through every setting and option under the sun, I even under googles instruction changed my email to all gmail accounts in regards to the apps and sonos itself.

So ya if anyone on here can help me out id appreciate it, the whole reason I got this thing was for the voice commands so if I don't figure this out imma cry.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +22
I would probably call Sonos on the phone and have them look at.
See this thread:
https://en.community.sonos.com/google-assistant-and-sonos-229109/google-assistant-music-play-back-issues-6829409

It's a known issue. There is currently nothing you can do.
See this thread:
https://en.community.sonos.com/google-assistant-and-sonos-229109/google-assistant-music-play-back-issues-6829409

It's a known issue. There is currently nothing you can do.


Great so I spent $400 on products that don't do the function I bought them for... and of course I threw the boxes away😩
At least you only spent 400. I spent over 1k