Gapless playback issues after 15.2 update


Userlevel 2

Is anyone else having issues with Gapless playback after updating to 15.2?

 

Scenario:

I have been using a loopable track on Apple Music via the built in Sonos player to play sleep sounds every night for years. This created a seamless sound with Gapless playback. 

Problem:

After the update to 15.2, there is a distinct gap between the end of the track and the beginning of the repeat making the feature unusable for sleep sounds.

 

Fix Needed

Restore previous function to allow Gapless playback on looped tracks.

and/or 

Allow reverting to a previous firmware

(Ideally allowing to revert by atleast two firmware revisions to allow people to experiment and see if a new update has fixed a previously experienced bug)


30 replies

Userlevel 7
Badge +21

I too have heard this issue with Apple Music.  It’s noticeable when there is a continuous piece of music that is split into segments. There is a slight hesitation. 
 

There will likely never be the option to revert. Allowing that is way more difficult than you’d expect. 

Is there an improvement if you enable crossfade?

Userlevel 2

Enabling cross fade causes the volume to fade in and out which is just as bad as the audible gap.

Same issue after latest update. Chatted with Sonos support on Friday and calling in on Monday to continue case with support. 
 

This issue shows up for me when I playback DJ mixes that are supposed to be a seamless mix. There’s a slight hiccup between tracks that’s insane. Only just started with the most recent update. 

Worked with Sonos support. My case ID is ********. Feel free to call Sonos and let them know you’re experiencing the same problem as my case. Waiting for engineering to address.  

 

Moderator edit: removed case number.

Userlevel 2

Oh excellent. Thanks for the update.

Userlevel 2
Badge

+1 I’m also having this issue using Symfonisk Table Lamp speaker since 15.2 update when looping a single white noise track from Apple Music :(

Userlevel 1

I’ve had the same problem, I have a few gapless tracks that I use for white noise. They have been completely useless lately due to the pause at the end of the track. I was on the phone with support for over an hour one night after they went through useless suggestions after useless suggestion. I tried to tell them over and over again that it happened immediately after the update but they wern’t having it.

All I was trying to do was report a but and it seemed like they didn’t think it was their fault or anything on their end. Eventually I gave up.

 

Nice job Sonos team….SMH

Update: I updated to 15.3 today. 

 

Still having the same issue. It’s not fixed in 15.3. 

Userlevel 2

Confirmed here, no changes with 15.3. This is really disappointing

Userlevel 1
Badge

Hey I’m pretty new but would this be impacting Atmos tracks as well? The 2019 mix of Abbey Road on Apple Music is all Atmos and the gaps are murdering the experience throughout the entire album.

Userlevel 2

I’m not a programmer but the bug started happening the same time Sonos introduced Atmos spatial audio from Apple. It may be a coincidence or it may be that Sonos changed the playback APIs to allow Atmos which could have caused this bug. 

Userlevel 2

I just updated to the newest build of 15.3 and it somehow seems that the gap is made even more prominent. This is really disappointing.

Badge

I need the gapless feature to work - has Sonos resolved this issue? 

A complaint was made a month ago according to this thread.

The Sonos technical and software team should have resolved the issue by now!

Userlevel 1

I need the gapless feature to work - has Sonos resolved this issue? 

A complaint was made a month ago according to this thread.

The Sonos technical and software team should have been resolved by now!

Thats a negative 

Badge

I need the gapless feature to work - has Sonos resolved this issue? 

A complaint was made a month ago according to this thread.

The Sonos technical and software team should have been resolved by now!

Thats a negative 

Honestly, this is not good considering the fact that Sonos support has always been excellent.

Badge

Sonos technical support / software dev team - Can you kindly tell us when this issue will be resolved?

I trust that you will not say it’s an Apple issue and even if it is, you will collaborate with them to resolve the issue effectively.

Userlevel 7
Badge +18

Hi @Jmwarren85@Samazar@dshj et al

Could I please ask you all for some example albums that you’ve found have problems playing back “gapless”? Thank you!

Userlevel 2

In my OP I was referring to the use of the following track on Apple Music as sleep sounds, set to a continuous repeat. Prior to 16.2, this provided a seamless everlasting loop, after 16.2 there’s an audible gap.

Loopable Waterfall track on Apple Music

Userlevel 7
Badge +18

Hi @Jmwarren85 

Thanks - I’ll pass this along, in addition to any more that come my way.

Userlevel 2

I just checked through some of Apple Music’s collection of Tomorrowland Sets that have been broken into tracks and they all have the same audible gap between what should be a seamless transition.

 

Userlevel 1
Badge

@Corry P An obvious and popular album is Abbey Road by The Beatles. Specifically the Atmos-enabled 2019 Mix. 

There should be no gap through most of the second half of that album

Userlevel 1

confirming that the update does not fix this issue

Userlevel 1
Badge

confirming that the update does not fix this issue

Agreed. My test album is Abbey Road (2019 Mix) and it still has gaps after the 15.4 update

+1. Using Sonos for endless-loop sleep sound tracks is a common use case, and this bug is making it basically useless. Please please fix!!

Reply