Answered

Can't add folder to music library (913)


Userlevel 3

Anyone know how to fix error 913? Mac OS 13.6.6 Cheers.

icon

Best answer by Sunocoz 16 May 2024, 02:02

View original

64 replies

Userlevel 1

I'm having the same problem!

Userlevel 3

I'm having the same problem!

Tried the chat bot this morning. Only help they can give you is to remove and reinstall the app, which I’ve already done yesterday. They suggest the only thing to do is a remote session via phone call. Tried that yesterday and was on hold for 2 hours. Going to have another go this morning.

Userlevel 2

On a Mac, the only solution I’ve found that will accept the music library is the NAS option. You need to either copy the entire apple music library to a NAS and point Sonos at the folder there with a NAS user/pass or figure some way to trick Sonos into thinking your folder is on a NAS. Good luck.

 

P.S. I think I read somewhere that this will be fixed in June sometime which is a long time to go without music library. :-(

Userlevel 3

On a Mac, the only solution I’ve found that will accept the music library is the NAS option. You need to either copy the entire apple music library to a NAS and point Sonos at the folder there with a NAS user/pass or figure some way to trick Sonos into thinking your folder is on a NAS. Good luck.

 

P.S. I think I read somewhere that this will be fixed in June sometime which is a long time to go without music library. :-(

You wouldn’t believe it I got hold of a tech within 2 minutes by calling on the stroke of opening time. Their work arounds didn’t work though, so looks like I’m waiting for them to resolve their issues. Hopefully we’re not waiting till next month lol. Thanks for your advice though. Cheers 🤘👍

Userlevel 1

I'm having the same problem!

Tried the chat bot this morning. Only help they can give you is to remove and reinstall the app, which I’ve already done yesterday. They suggest the only thing to do is a remote session via phone call. Tried that yesterday and was on hold for 2 hours. Going to have another go this morning.

Try the solution in this link!

 

i'm about to try it...let’s me see if it solve the problem….

 

It’s a shambles. I followed the instructions given to ECS3 on the link below (for my Mac) & it worked. Others report it didn’t work for them:

 

Userlevel 2

Here is the solution for Windows for the local library error bug with code (913), read the image from left to right.


 

Userlevel 1

Did precisely these steps, but it still didn’t work. Restarted SONOS and confirmed the permission is there, but it didn’t take.

Userlevel 3
Badge

Same here, but thanks to PaulRB371 and HelpingIsKind I fixed it in 2 minutes. Here’s how:

  1. I have a PC. Not a Mac.
  2. Find a music folder that you want to “share” with SONOS (i.e. navigate to the folder on the PC).
  3. Right click on the folder
  4. Select “Properties” from menu
  5. Select “Sharing” tab
  6. Click “Share...” button (opens “Network Access” window)
  7. Select your SONOS system from the pulldown menu in the center of the window.
  8. Click “Share” button at the bottom of the “Network Access” window 
  9. It took SONOS 10 minutes to add my library of 10K+ songs

 

J’avais le même problème d’erreur 913.

J’ai fais exactement comme expliqué par nk32 sur le dossier ‘music’ et le sous dossier ‘mp3’ où j’ai ma bibliothèque de chansons et ça a très bien fonctionné (après plus de 15 minutes de récupération de la bibliothèque)

Merci nk32 !!!

L’appli sur le PC fonctionne bien, par contre sur le mobile impossible de voir la bibliothèque et mes listes de lecture Sonos…..

Userlevel 2

I trust you guys at SONOS are ashamed of you, aren’t you ?

Userlevel 2

The iPhone app is a mess and now I can’t get my library to work and I’, getting this 913 error… Using the Mac app was their workaround for the app not working… What a garbage app from a garbage company.

Userlevel 2

My Sonos system is used almost exclusively for playing music in my iMac music library.  

The app updates for my iMac and my iPad have completely screwed the connection between the system and my music library, so I now have a number of black “bricks” around the the house that do absolutely nothing.

I have uninstalled and reinstalled the app on my Mac, but still get the 913 error message, and am unable to reinstate my music library on the Sonos system.

The lack of any apparent urgency from Sonos to fix this major blunder is astonishing!

Userlevel 5
Badge +9

“please be patient. We (Sonos) know that the app we forced on everyone is totally broken, but we thought it would be really funny if we could brick your huge investment in our products. We really promise that we will fix when we have time” - not really from Sonos.

Well, somehow between some of the suggesting given above and an old blind squirrel finding a nut once in a while, I was able to reconnect my Library. My main computer is a Mac, but I have a stripped down an older PC laptop that was my mother-in-laws before she passed away that acts as my music server. Old, slow, but it works pretty well. And I have the Music folder backed up to 2 independent memory devices that are not connected to the network. 

I’m just a bit worried that I opened the system to the gates of Hell by allowing outside devices do see. But after the drive was recognized, I went back into the security setting and toggled it back to the more secure setting. So hopefully, the dogs of Hades don’t come streaming in…

Now I’m just super pissed that I can’t access through the app on my iPhone, and the freaking music timer doesn’t work! WTF? I set that up to put me to sleep probably 4 nights a week. I’m a grouchy old man to begin with, and now I’m really pissed.

This was such a good system for me when I made the investment between 2016-2020 or so. I have 5 Play1, a Play3 and the Soundbar and Sub, so my expenditures haven’t been minimal.

 

Fix it Sonos!

 

 

 

Badge

Same here, but thanks to PaulRB371 and HelpingIsKind I fixed it in 2 minutes. Here’s how:

  1. I have a PC. Not a Mac.
  2. Find a music folder that you want to “share” with SONOS (i.e. navigate to the folder on the PC).
  3. Right click on the folder
  4. Select “Properties” from menu
  5. Select “Sharing” tab
  6. Click “Share...” button (opens “Network Access” window)
  7. Select your SONOS system from the pulldown menu in the center of the window.
  8. Click “Share” button at the bottom of the “Network Access” window 
  9. It took SONOS 10 minutes to add my library of 10K+ songs

 

Thank You: I Tried and It Works Perfectly

Badge

Thank you: works perfectly to resiolve the problem

Userlevel 2

So pleased for everyone with a PC.  However I can’t afford, and do not wish, to switch from my Mac to a PC, so it looks like I’m stuck with the problem until Sonos decide to get their act together.

In the meantime, just to rub it in, Sonos have sent me an email.  No, not to apologise or to let me know that a fix is on the way.  Instead they thought that I would like to know that “our most requested product is coming soon”.  Thanks for that.

My most requested product is a fix for their disastrous update...

Userlevel 3
Badge +1

My Music Library has totally disappeared. I cant even try to add it back. I fired up ye old trusty desktop controller on the PC and it did give me an option to add a music library but got the 913 error. It seemed to have deleted the existing library that was set up prior to updating the toxic hellscape of an app the released. Wish I could turn back time and not clicked to update

Userlevel 2

… Wish I could turn back time and not clicked to update

You can’t. I tried uninstalling then installing the Controller version I downloaded last Dcemeber, and which worked with my local folder. The older version checks for updates, and forces you to upgrade. If you select “Not Now”, you can’t do anything with it.

 

Thanks @nk32 for this solution. I followed the steps you laid out and it didn’t work for me initially. I had to do the following extra step, as I created a second user account to my PC ‘sonos’ so I had to:

Properties > Security > Edit > Add ‘sonos’ (Read & execute / List folder content / Read), and after re-starting Sonos app, i was able to reconnect my music library :)

Same here, but thanks to PaulRB371 and HelpingIsKind I fixed it in 2 minutes. Here’s how:

  1. I have a PC. Not a Mac.
  2. Find a music folder that you want to “share” with SONOS (i.e. navigate to the folder on the PC).
  3. Right click on the folder
  4. Select “Properties” from menu
  5. Select “Sharing” tab
  6. Click “Share...” button (opens “Network Access” window)
  7. Select your SONOS system from the pulldown menu in the center of the window.
  8. Click “Share” button at the bottom of the “Network Access” window 
  9. It took SONOS 10 minutes to add my library of 10K+ songs

 

Same issue here, tried many times and connect sonos customer service, but there is no idea for this .
But now resolved, And now is work!  Thank everyone and thanks Scrubbrush, Nk32.

I am 66 years old and have been using PCs since the early 90s. Sometimes I wish I could reclaim all the hours I have wasted fixing things that used to work and then didn’t because of updates. Thanks to all of you who have offered solutions. I think my music library is now loading but looking forward to getting back the Queue and ‘Play next’ functionality that was working just fine until the update. Don’t suppose there’s any hope of getting back the ability to control the volume via my Ipad’s buttons, but hey I can’t have everything. 

Userlevel 2

It’s a shame and obviously noticeable that Sonos does not put the same level of effort or investment into its software development business unit.  The leadership there must realize (just like Apple) that they are a software company that also sells hardware.  When they realize that and make the necessary pivot, they will hopefully become a better company.

Userlevel 4
Badge +3

Currently using Plex in the Sonos app as a workaround since my local library stopped working with the recent app update.

Too soon to tell if it’s a worthwhile option but curious if I’ll be able to get my library working again through the official route.

Reply