Can't Play Sirius Station, Associated account not found.

  • 1 October 2020
  • 6 replies


After listening to the MLB game yesterday on SiriusXM, today I can’t play Sirius statioins because supposedly can’t find account on system.  I see that the service is shown as available on the status page.  Anyone else having this issue?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

I don’t see anything on the real time status page. Have you tried deleting your account from Sonos, then adding it back in?


I have.  No change

If you’ve tried a reboot of your router already, I would recommend that you submit a system diagnostic, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.


Oddly, it works on my Sonos 3 speaker but not on the Sonos One. Any ideas about that?

That suggests there’s an issue with your Sonos One staying connected to your router. From a software perspective, both speakers are the same. I’d be tempted too unplug both speakers from power, then reboot the router, and once it comes back up, plug both speakers in to the power. That forces a reload of both the router’s software, and the speakers software, and gives the speakers new IP addresses.

I suppose it could be a hardware failure in the Sonos One, which would be why I’ve urged you to call in to Sonos directly, rather than waiting for sporadic responses here in the forums.


Thanks.  I’ll try this and then call if no resolution.  I appreciate the help.