Question

Wrong time on Sonos One and Alexa

  • 28 October 2017
  • 27 replies
  • 5853 views

When I ask Alexa what time is ti? the reply is 8 hours behind GMT. I have gone into the time and date settings for the play one but the are set at the correct time. How can I get Alexa to announce the correct time?
Terry

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

27 replies

Userlevel 2
Badge +4
Does it also give you the weather in Seattle?

Change the device’s location in settings.
Userlevel 3
Badge +4
I've been able to change the One's timezone and it now gives me the correct time, but it still gives me the weather in Seattle. It won't save changes I make to Location. I've raised an issue with Sonos support but they've been silent.
Badge
Alexa gives me the correct current time but voices calendar event times that are 3-4 hours off.
Local settings in both Sonos & Alexa are good.
Are you using a PLAY:1 or a SONOS ONE? If you are using a SONOS ONE, drill down in the Alexa settings entry for SONOS ONE and change the location and time zone.
Badge
I have correct date/time settings for all devices but Alexa is still 4 hours off on event times.
Userlevel 7
Badge +20
To be specific, there is a general date time and also a device specific one within the Alexa App - this caught me out first.
Badge
In my case those settings are all entered correctly
It was driving me nuts. I uninstalled the Alexa app. and re-installed. OK now.
Badge
Uninstalled/reinstalled Alexa but event times from my calendar are still off.
Weird. In the opposite direction, I just now created a new event through Alexa and it showed up correctly in my Apple calendar.
Not exactly a life-threatening problem but still irritating.
Userlevel 7
Badge +26
If you're still having trouble setting the time from the Alexa app, I'd recommend using the alexa.amazon.com website. Sometimes the app has some trouble communicating right.
I have three devices, all discovered, all with the correct address and time zone, I use the web Alexa address, (it's more responsive than my old IPad) but i'm given the wrong time, wrong country, and now to add insult to injury, no music. Alexa insists my Sonos skill needs enabling. It's enabled. It's linked to my Amazon account. I'm tearing my hair out here. I've sent off an incident report. What now?
Badge
As per Ryan S, I went to Alexa's web settings page. Time zone was correct but zip code & country fields were empty.
Entered info for both and that indeed solved the problem. Current time & event times now are correct.
Thanks!
I was also getting this problem along with numerous others Sonos customer support have been pretty good on Twitter to be fair, still can’t poay any music using Alexa but at least the time is right!! Here was the solution

1. If you have the Amazon shopping app on your device, sign out of Amazon shopping app.
2. Then if you do not have the Amazon shopping app, navigate to http://Amazon.com and check to make sure that you are not signed in there..
3. From the Alexa app, select Skills>Your Skills>Sonos>Disable. If you do not see Sonos, go to the next step.
4. Sign out of the Alexa app by going to Settings and scrolling all the way to the bottom.
5. Open the Sonos app from a mobile device
6. Select More>Settings>Room Settings>Sonos One Room Name
7. Select Voice Services>Sign In
8. Select Amazon Alexa>Remove Amazon Alexa from the room
9. Go back to More>Voice Services->Add Alexa
10. Follow these prompts to setup Alexa again on the Sonos One.

Then If the issue persists could we try the above steps on a different mobile controller.
Userlevel 7
Badge +26
Really good steps, Ian. What happens sometimes is if you have multiple Amazon accounts it could cause the Sonos One to try and connect with the wrong one, and get all screwed up. The Sonos app tries to default to using the account you have in your Shopping app first.

@Eastway, glad that worked.
Ryan, yes that sorted the time and location issue, just got to get the other issue Which is that Alexa won’t play at you music at all!
Appreciate the help, but Alexa hates me!
Userlevel 7
Badge +26
What service are you using, Ian? Are you getting an error message or something happening when you ask the Sonos One to play?

Mind submit a diagnostic from your Sonos system and sending back your confirmation number?
Before I followed the steps above she would say mmmm to do that you need to enable the skill, and then say discover devices which never worked. Now she says what I have requested and then says something went wrong. Eve when I try and play the tube in radio through the Alexa app I get an error message. I am using Spotify, amazon music and tune in radio!? diagnostic no is 8056397..: thanks
@ Ian...It's the thoughtful mmmm before she says that that's making me mad!
Userlevel 7
Badge +20
Is your Alexa app logged into the same amazon account is the one linked to your Sonos account when you set-up the Sonos 1?
How would I be able to find that out? When I set up my first Sonos 1, I was directed to sign in @ Amazon.com rather than Amazon.co.UK, so it's possible I'm using both. I have uninstalled and reinstalled Sonos app and Amazon app multiple times since then though.
Userlevel 7
Badge +20
If you normally use Amazon.co.uk then access alexa.amazon.co.uk on a PC browser and check if your sonos 1 is listed under Settings. Again, if you normally use .co.uk I would link your normal amazon account within the Sonos app (Must be on either Android or iOS - not PC):

>Settings>Room Settings> Select your Sonos 1 and under Voice Settings remove and then add your .co.uk account.
That seems to be the problem. Everytime I enable the Sonos skill and connect to Amazon it takes me to the US site, where I have an account with different email address.
Userlevel 7
Badge +20
That's fine but if you enter the email address associated to your amazon.co.uk domain does that work?
The Alexa app on my Ipad is unstable. To connect Sonos to Alexa is almost impossible. It just goes round and round the stages, rarely making it as far as the Amazon sign in page. I have an old Windows phone that is incompatible with Alexa. Oh joy!