Answered

Sonos no longer plays music when commanded through Alexa (Amazon Echo Dot)


Badge

Our house is filled with Sonos. We have a Sonos Play One in every room and our living room has a Sonos Playbar with two Sonos Play Ones for surround sound. We have echo dots in each room and have Alexa configured to use the Sonos speaker (in each room) as default. It has been working perfectly for years.

Fast forward to now; Alexa no longer plays music through any of our Sonos speakers. Alexa now just plays music through the echo dot instead of the Sonos speakers.

I have spent hours troubleshooting this and have done the following:

  • Disabled Sonos skill in Alexa
  • Removed Sonos speakers from Alexa
  • Power cycled all Sonos speakers
  • Added Sonos skill to Alexa and rediscovered the devices
  • Reconfigured each room (group) in Alexa to use Sonos as default

All of my Sonos speakers have excellent network connectivity and are set with a static IP. Nothing on my network has changed recently. I have verified firewall and dns logs. Recently I set Sonos to auto-update and am regretting that decision. At this point I am guesing it is either a Sonos update or Alexa issue that is causing the problem. 

There also seems to be other people experiencing a similar issue.. https://www.reddit.com/r/alexa/comments/n6n0ot/echo_devices_and_app_having_trouble/

I am at a loss. Any help is greatly appreciated.

icon

Best answer by jrm523 20 July 2021, 16:33

View original

18 replies

Sounds like an issue with your Amazon ‘groups’ … to get your echo dots to play their audio to your Sonos products you need to do the several things listed below:

  • Set the echo dot in the first section of an Amazon Alexa group to ‘enable’ the group. You should also do this with your Sonos One Alexa component. 
  • Any other speakers without Alexa components in the same room should be added to the second (middle) section of the group to cause it to ‘duck’ it’s audio when speaking to the ‘enabling’ Alexa devices.
  • Then in the third and final section of the Alexa group, add your Sonos products as the ‘preferred’ speakers that you wish the ‘enabling’ Alexa products to control/use for music playback - these are usually the same Sonos products that you see in the first and middle sections of the group. See my sample screenshot of a simple Alexa ‘enabled’ group attached to this post.
     
Badge

@Ken_Griffiths I appreciate your reply. I have completely wiped and redone my groups multiple times with no success. My groups have been and are configured as you said. I’ve had this configuration for multiple years with no issues. I am at a complete loss as to what is causing the problem.

 

 

So your ‘Office Sonos’ isn’t a Sonos One then? - or at least it has no ‘Alexa Assistant’ installed on that device according to the screenshots displayed, but your Office echo dot, in any case  should certainly Play music to the ‘Office Sonos’ speaker.
 

I assume that your ‘Office Sonos’ is either a Play:1 or Sonos One SL?

Which Music service are you using/set as your ‘default’ in the Alexa App and can you perhaps screenshot your Alexa device list and post that too?

Badge

@Ken_Griffiths My default music service is Amazon music (premium paid subscription). The office Sonos is a Play:1 model. There is no Alexa assistant built into my speaker.

Expected result: Ask Alexa (echo dot) to play music. Music automatically plays through the Sonos Play:1

Experienced result: Ask Alexa (echo dot) to play music. Music starts playing on the echo dot. The Sonos doesn't respond.

I can open the Alexa app and tell it to play music while selecting the office Sonos and it plays music just fine. So that is telling me it is capable. It's just somehow when I ask it to play music vocally that it doesn't play through the Sonos.

Apologies if I sound redundant on the information I provide. I want to ensure I provide as much information as possible to figure this out. I sincerely appreciate your help.

 

Device list:

 

In the Amazon Alexa App device list goto the ‘office echo dot’ device and select it to open its ‘properties’… scroll down and look for the section called ‘Connected Devices’ and where it says ‘Speaker built-in’ can you select that and go through the settings to change it to ‘use my preferred speaker’ … it should change the setting from using the built in speaker to using the ‘Office Sonos’ speaker instead. 

Once the setting has been changed, then try it again. 

Badge

Okay I think you may be onto something. See my screenshot below of the configuration page that you referred me to. I also included a screenshot of what happens when i select the “Learn more” link that is right beside “Use my Preferred Speaker”. I dont remember what this configuration looked like previously (before I deleted all of my devices and resynced everything). 

 

 

Ah yes, this is because you actually need a ‘Sonos One’, with a voice Assistant built-in and not a ‘Play:1’ so that’s completely my mistake. I was getting (slightly) confused as it was referred to earlier as a Sonos Play One.

Anyhow, I’m getting the impression from this now, that the interoperability between the echo and Sonos devices ‘perhaps’ may have changed slightly …and that only the later Sonos Ones can be used in the way you’re hoping. Sadly I don’t have older Play:1’s here to test if things have perhaps been altered. However let’s not give up and maybe run the test suggested below…

Can you kindly (temporarily) rename your ‘Office Sonos’ speaker to something entirely different (‘Test Speaker’ will do) from within the Sonos App "Settings/System/[Office Sonos Room Name]"  and give it a minute or so and just confirm it’s name also alters automatically and changes to ‘Test Speaker’ in your Amazon Alexa Office Group as the groups ‘preferred speaker’. Also ensure you do not have more than one Alexa group called “Office” or any group ‘similarly named’.

If it renames can you just test it again…but before doing that test, can you first sign out of the Amazon Music Service in your Sonos App Music services and then setup the Amazon Music Service again in the Sonos App, ensuring you use the exact same Amazon account credentials.

Let me know if that works - After doing this test, you can then rename your speaker back to ‘Office Sonos’ from within the Sonos App.

@Ken_Griffiths.  I think we’re conflating two different Alexa features.  The “Preferred Speaker” feature/setting means that although an echo dot (speaker A) may be picking up your voice, you want a different speaker (speaker B) to give the Alexa response.  For this feature to work, both speaker A and B have to be Alexa enabled with the voicie assistant.  In other words, speaker B can’t be a Play:1 or other speaker that doesn’t have a mic.

The “Speakers” section of an Alexa group is different.  The speakers listed in this group means that whenever you request music played to that group, it will play on the speaker(s) listed.  Alexa’s response will be on the speaker you talked to (Speaker A), but music will play on whatever speakers are defined in the group.

Worth noting that you can refer to the Alexa group by name, or if the Alexa device is a part of the sam e group, it can play by default.  Playing by default was standard before, but currently, you can set it so it will only play if you refer by name.   You might want to check to make sure the speakers in the Office group are set to Always play.

 

It gets more complex than this because the preferred speakers and and speakers defined in an Alexa group are not completely independent.  For example, you can’t set a preferred speaker (speaker B) that is different than your speakers in the group.  Also, you can’t set a preferred speaker at all if the speaker your setting (Speaker A) is an echo show, because of the video capabilities.

 

But anyways, I have seen cases where my Sonos speakers defined in Alexa groups aren’t playing correctly, even when the group is defined correctly.  I haven even given an echo dot a command to play music  and it fails to play on Sonos, playing on the dot instead….then immediately given the same exact command (with a little frustration in my voice) seconds later and it correctly plays on Sonos.  Not sure what to make of this other than it seems that the coding and connection between cloud servers etc are not as reliable as they should be.  If you are confident that settings are correct, I don’t know that I would change things around, perhaps better to just forget about it and try again later.

Thanks Danny, appreciate the input. 👍

In simple terms the user has this..

  1. A Group called “Office"
  2. The Group is Enabled/Controlled by an echo dot called “Office Echo Dot"
  3. A Sonos speaker called "Office Sonos" is added to the middle section of the group to ‘duck’ it’s audio
  4. And the "Office Sonos" is also set as ‘Preferred’ in the third section of the group.. for playback when the Play request is directed at the enabling/controlling device. (The echo dot).

I appreciate I ‘mistakenly’ wandered off course to try to make things work by using the echo dot default speaker option, but that’s because I forgot ‘Office Sonos’ was a Play:1 rather than a Sonos One and I soon realised that error, but I suspect that option would have achieved the same outcome had it been a Sonos One, albeit that’s now ‘by the bye’ anyway.

Anyhow, what I’m hoping to establish now, is if the Group is duplicated or if the similar names of ‘Office’ being in the mix of both ‘device’ and ‘group’ names, might be causing the OP the issue here, whilst also ensuring the Alexa Account and the Amazon Music Service in the Sonos App are both also using the same login credentials.. it at least may help eliminate a couple of other things before ‘perhaps’ suggesting to the OP to speak to Sonos Support Staff .. so that’s the aim of my last post. 

I just didn’t think it was time (yet) to give up on this and perhaps pass things along to the Sonos support staff, until these things had been explored/exhausted first.

Thanks Danny, appreciate the input. 👍

In simple terms the user has this..

  1. A Group called “Office"
  2. The Group is Enabled/Controlled by an echo dot called “Office Echo Dot"
  3. A Sonos speaker called "Office Sonos" is added to the middle section of the group to ‘duck’ it’s audio
  4. And the "Office Sonos" is also set as ‘Preferred’ in the third section of the group.. for playback when the Play request is directed at the enabling/controlling device. (The echo dot).

 

 

Agree with all the above, accept that I’m hesitant to use the word ‘Preferred’.  It’s used accurately ( and I used it incorrectly I think) but that word does not show up in the Alexa group settings.  The word only shows on in the settings for an echo device (in @jrm523 screenshot) in reference to the speakers listed in the Alexa group in belongs to….which is rather confusing on Amazon’s part….and is used for only defining which device Alexa speaks from.

 

I appreciate I ‘mistakenly’ wandered off course to try to make things work by using the echo dot default speaker option, but that’s because I forgot ‘Office Sonos’ was a Play:1 rather than a Sonos One and I soon realised that error, but I suspect that option would have achieved the same outcome had it been a Sonos One, albeit that’s now ‘by the bye’ anyway.

 

Amazon didn’t make this simple to understand, and doesn’t do the best job of organizing their features.  It would be better if both music playback and ‘alexa voice’ playback were set in the same place, either in an Alexa group or the settings of a specific Alexa device.

 

Anyhow, what I’m hoping to establish now, is if the Group is duplicated or if the similar names of ‘Office’ being in the mix of both ‘device’ and ‘group’ names, might be causing the OP the issue here, whilst also ensuring the Alexa Account and the Amazon Music Service in the Sonos App are both also using the same login credentials.. it at least may help eliminate a couple of other things before ‘perhaps’ suggesting to the OP to speak to Sonos Support Staff .. so that’s the aim of my last post. 

I just didn’t think it was time (yet) to give up on this and perhaps pass things along to the Sonos support staff, until these things had been explored/exhausted first.

 

Duplicate group names or mismactchined accounts could be the problem.  But again, it’s possible everything is set correctly and things just aren’t working right now.

There’s also this ‘new-ish’option in the Amazon Alexa App (see attached) in relation to ‘Groups’ and I was planning to also explore that feature with the OP too.

As you can perhaps also see here Danny, you can set the music to play on an Alexa Group speakers ONLY when the group name is included in the voice instruction …and this too could be something set in place for the OP’s ‘Office’ Group, but it’s just a case of first eliminating the issues, one step at a time, before perhaps shifting to a case of ‘wait and see’ or (as I prefer to do) suggesting that the OP speak to the Support Staff. Still some things to explore here first, I think.

Badge

@Ken_Griffiths Thanks for your ideas. I will try what you recommended later today and let you know how it works out. 

 

@melvimbe I appreciate your input as well. However, I really don't want to just leave it and hope it eventually resolves itself. This has been ongoing for days now and my fear is something was updated on Sonos or Amazon's side that is causing the problem. This is a feature that my fiance and I use daily. 

Badge

OMG! I figured it out! I changed the "Play music group setting" that you mentioned. I guess an Alexa update borked it by changing the default to require you to say the group name. I changed it to automatically play without saying group name. Thanks for taking the time to post that image @Ken_Griffiths and for taking the time to work with me. 

 

I'm so happy it's working as expected again!! 😀

OMG! I figured it out! I changed the "Play music group setting" that you mentioned. I guess an Alexa update borked it by changing the default to require you to say the group name. I changed it to automatically play without saying group name. Thanks for taking the time to post that image @Ken_Griffiths and for taking the time to work with me. 

 

I'm so happy it's working as expected again!! 😀

Good news @jrm523 👍 and thanks for posting back the outcome - the answer had to be in the Alexa Settings somewhere. It’s just a shame it was one of the last things I suggested, but will move that setting up the priority list of things to check for next time.

OMG! I figured it out! I changed the "Play music group setting" that you mentioned. I guess an Alexa update borked it by changing the default to require you to say the group name. I changed it to automatically play without saying group name. Thanks for taking the time to post that image @Ken_Griffiths and for taking the time to work with me. 

 

I'm so happy it's working as expected again!! 😀

Can you explain exactly how you got the sonos to work again as I have old (not voice controleld) sonos 1's, 3's and a 5 that are no longer recognised as preferred speakers (they are completely greyed out when I try to select them via the alexa app) . When I ask alexa to play am amazon playlist it says the sonos device (the old one with no voice control) is disconnected. 

Can you explain exactly how you got the sonos to work again as I have old (not voice controleld) sonos 1's, 3's and a 5 that are no longer recognised as preferred speakers (they are completely greyed out when I try to select them via the alexa app) . When I ask alexa to play am amazon playlist it says the sonos device (the old one with no voice control) is disconnected. 

The ‘default speaker’ for an echo device can only be a Sonos product that has Alexa built-in, like a Sonos One for example.. you can’t use a Play:1/3. You need to look at using the Alexa enabled groups instead in the Amazon Alexa App (see below and attached ‘example’ screenshot).

  1. Set your echo device to control/enable the group. (NB the device can only be used once per group)
  2. Add your chosen Sonos Speakers to the 2nd section of the group, this will ensure they ‘duck’ their audio when speaking to the controlling echo device.
  3. Add your speakers that you wish to use for audio playback to the last section of the group.

Check that the Sonos skill is installed in the Amazon Alexa App and if necessary sign out of the skill and back in again to check it’s connection and allow it to scan and discover your Sonos devices. 

Badge

OMG! I figured it out! I changed the "Play music group setting" that you mentioned. I guess an Alexa update borked it by changing the default to require you to say the group name. I changed it to automatically play without saying group name. Thanks for taking the time to post that image @Ken_Griffiths and for taking the time to work with me. 

 

I'm so happy it's working as expected again!! 😀

Can you explain exactly how you got the sonos to work again as I have old (not voice controleld) sonos 1's, 3's and a 5 that are no longer recognised as preferred speakers (they are completely greyed out when I try to select them via the alexa app) . When I ask alexa to play am amazon playlist it says the sonos device (the old one with no voice control) is disconnected. 

The setting that caused me all of the grief is pictured below. When you go to “Choose Speakers” for your Alexa Group, you have to select your Sonos and then scroll all the way down and you will see “Playback Options”. Alexa started to default on the setting that required you to say the group name any time you want to play back music. You have to change “play music on bedroom speakers” to “Always” and not the default “Only when you say the group name”. 

 

 

Reply