Have to ask twice to play Spotify music



Show first post

86 replies

Userlevel 1
Badge +1

Been happening to me for ages too. 

Userlevel 1

I have the same issue where i have to ask Google Assistant to play things twice. 

The issue also appears when i try and play spotify from the mobile app and select a sonos - i have to do it twice. 
diagnostics are 267865516

Userlevel 7
Badge +20

I have the same issue where i have to ask Google Assistant to play things twice. 

The issue also appears when i try and play spotify from the mobile app and select a sonos - i have to do it twice. 
diagnostics are 267865516

I've had this and these steps resolved it for me:

https://en.community.sonos.com/troubleshooting-228999/tips-tricks-resolving-random-issues-impacting-sonos-devices-6845346 

Userlevel 1

I have the same issue where i have to ask Google Assistant to play things twice. 

The issue also appears when i try and play spotify from the mobile app and select a sonos - i have to do it twice. 
diagnostics are 267865516

I've had this and these steps resolved it for me:

https://en.community.sonos.com/troubleshooting-228999/tips-tricks-resolving-random-issues-impacting-sonos-devices-6845346 

Hi UKMedia

Thanks for this.
I’ve created DHCP reservations for my Sonos and Google Home displays and so far so good (its worked two out of two times) but not sure if this is just due to the fact they’ve just been rebooted.

I’ll continue testing and let you know if there’s further issues. 
Thanks again. 

Userlevel 1

I have the same issue where i have to ask Google Assistant to play things twice. 

The issue also appears when i try and play spotify from the mobile app and select a sonos - i have to do it twice. 
diagnostics are 267865516

I've had this and these steps resolved it for me:

https://en.community.sonos.com/troubleshooting-228999/tips-tricks-resolving-random-issues-impacting-sonos-devices-6845346 

Hi UKMedia

Thanks for this.
I’ve created DHCP reservations for my Sonos and Google Home displays and so far so good (its worked two out of two times) but not sure if this is just due to the fact they’ve just been rebooted.

I’ll continue testing and let you know if there’s further issues. 
Thanks again. 

Just wanted to add it’s been almost two weeks and everything is working well. Thank you!!

Thought I’d pile on here as well.
 

Seeing the same problems. Seems to be an issue between Spotify Connect and Sonos. Start playing Spotify by choosing a song in the Sonos app, then ask for something from Alexa or Google Assistant (doesn’t matter which), the voice will respond that it’s going to start playing, but it doesn’t. The too many Spotify sessions error appears in the Sonos. Then ask Alexa or Google Assistant to play a second time, and it actually starts playing.

 

I’ve rebooted my network, made DHCP reservations for my Sonos speakers, unlinked and re-linked the Alexa and Google Assistant skills, even bought a Sonos Boost. Nothing works. 
 

Sonos engineers, please, please work with Spotify to fix the root cause. This is beyond irritating.

Userlevel 5
Badge +15

Hi Everyone,

We would like you to know that we are aware of this issue affecting some listeners, and that it will be addressed via a future software update.

 

I also have this issue but with Spotify connect, I don’t have any Amazon or google voice devices.

 

If Sonos has been playing from Spotify, works fine. If it’s been playing from anywhere else, I always have to ask twice (and exactly twice) from the Spotify app to get it to play.

 

diagnostic 1694048938

 

Same problem here. Hoped it would be a fault with Sonos v1 so just spent 450USD to replace a speaker just to experience the same problem again. AND this fault has happened at three different houses (my house, my cabin and my parent’s house).

 

Sonos, instead of asking everyone to go through a teadious list of actions and then get a unclear diagnositic reason, please find the common denominator for this issue and solve it (even if it’s so simple as to working with google/Amazon to confirm that music is playing otherwise send the command again within a few seconds????)

kindly respond to all of the frustrated community regarding this 

Userlevel 7
Badge +17

Hi Everyone,

We would like you to know that we are aware of this issue affecting some listeners, and that it will be addressed via a future software update.

 

@peter lindstrom Sonos’ response is almost directly above your post.

Ah my bad! Even though it was somewhat therapeutical to unload the aggravation after experiencing the same problem in S2. :)

Great to see that it’s being worked on. 

Reply