Sonos are messing me around with a refund for an item sent back under the 100-day guarantee. Advice needed.


  • bjd
  • Contributor II
  • 2 replies
Just wondering if anyone else has had a similar experience?

I sent a Playbar (£699) back for a refund over 3 weeks ago, this was part of the 100 day money back guarantee as it had been purchased 2 months earlier. The next working day i received an email to say it had been received and a refund would be issued within 7 working days.

This did not happen.

On the 8th working day i phoned to query and was told that the refund had been done (i now know this to be a lie) and the money would be with me by the end of the week and to phone and query again if i didnt get the refund.

Come Friday, no refund.

I phoned again on and i was told by someone that were looking into it and they would create a ticket for me. An hour later i received an email from Sonos opening up a case for me with the message 'Unfortunately we are not able to do the refund back to your original method of payment as the authorization that was taken from your payment has expired. Hence we would like to proceed with the refund via bank transfer.'

To be honest i don’t understand what this means and have never heard of anything like this before but anyway, i gave my bank details as requested and was then told that it would take between 10-15 working days, which seems an awfully long time to me. 5 working days later, ive had no refund and so i decided to call my bank here in the UK who said 10-15 days is nonsense and that an international money transfer should take no more than 4 days.

I dont think this is good enough from Sonos. I now have a credit card bill to pay and as im sure you will all agree £699 is a lot of money for them to be messing me about with. I have phoned again today and apparently my case has been escalated, to the financial team.

But to my utter astonishment i have received an email asking for my bank details again, from the same person (Dylan) that asked for them last week and who subsequently said it would take 10-15 days. Not only that the bank details I provided last week are further down the page on the email thread!

Clearly the refund has not been done. So, another lie

I have said if i dont have the money back by the end of next week i will be forced to make a complaint and forced to claim a chargeback with American Express. I really dont want to go this route, i love the Sonos products (the Playbar was simply too big for the room it was intended for) but im certainly going to have rethink if i buy anymore moving forward, and so should all of you if you are thinking of trying something out with 100 day returns procedure.

Id be interested to know if anyone else has had issues like this and what the outcome was ? At this stage i do not know what to do and where to go from here and Sonos are not being straight with me. £699 is a lot of money!

14 replies

Userlevel 7
Badge +20
HI bjd,

I'd like to look into this for you. I'm sending you a DM asking for some information so I can reach out to our UK product returns team. It's still early in the US but the UK team will be leaving for the weekend soon.
Userlevel 3
Badge +1
bjd wrote:

Just wondering if anyone else has had a similar experience?

!



I had a similar experience where it took over 25 days to get a refund. IME it wasn't malicious it seemed like disorganisation (or possibly understaffed). In the end I got the money and I'm sure you will too, keep bugging them.
Sononos_fan wrote:

bjd wrote:

Just wondering if anyone else has had a similar experience?

!



I had a similar experience where it took over 25 days to get a refund. IME it wasn't malicious it seemed like disorganisation (or possibly understaffed). In the end I got the money and I'm sure you will too, keep bugging them.



ok, well thats good to know. thanks for the reply.
its not so much the delay thats frustrating me, though obviously thats not ideal. its more the fact ive been given various conflicting and misleading information from Sonos staff that has annoyed me.
Badge
I’m having trouble with a refund as I write this. Returned a project essential iii turntable on July 6, it’s now the 19, and no refund. It’s supposed to be “within 7 days”. I’m getting a big runaround from customer service. No one has an answer for me. I called Amex and they are getting involved. Not cool Sonos
I too am being messed around a bit now. I wish I had read all this previously. I’ve actually decided to send the rest of my order back too as I don’t have much faith if I have problems later on.
Userlevel 7
Badge +20
stitch123 wrote:

I too am being messed around a bit now. I wish I had read all this previously. I’ve actually decided to send the rest of my order back too as I don’t have much faith if I have problems later on.



HI stitch123,

I looked up your case and it appears that the support agent sent you an email with the shipping labels attached. Can you find that email? Perhaps it's hidden in your spam folder?
This is what’s causing the problem and no one seems to understand. I placed one order for 3 items. I returned 2 items (which I’m still waiting for the money despite being over 7 working days).

I then decided that I wanted to send the other item back (of the same order). It would appear that because I’ve already sent some of that order back when the agent checks it looks like the labels have been done. But I need ANOTHER label for the rest of the order.

Initially I only wanted to return ONE item but was sent two return labels (when I only needed one as was only sending one product back at that time). I contacted the agent who said I got two because the courier signs one and gives it back to me, despite the labels having completely different numbers on them. Obviously the courier just laughed at me when I showed him. In hindsight I was probably sent two labels as the original order had two products, however all labels show ‘Sonos One’ printed on them.

This whole experience has been a bit of a mess to be honest with poor communication which seems to be the general trend in this thread. I need to send this Beam back, and I want the money from my previous return.

Update : I’ve decided to use the second label I was sent in error a few weeks ago, despite saying Sonos One on it, for My Sonos Beam. It also has the wrong collection address printed on it (The agent did ask me for an updated one but never actually updated it) but I have changed it on the DHL website. This is the best I can do with what I’m working with.
Despite customer service reaching out, nothing has changed.

Two weeks later after my Sonos Ones have been received I have had no refund.

My beam has now gone back which I had to sort out myself.

My intention was to upgrade the beam to the playbar but there’s no way that’s happening now. The customer service of this business is disgusting which I will be saying on any review site I find.

As the person above said, I’ll be dealing with this through the credit company now.
I've been trying for nearly 3 weeks just to get a return label for a Sonos Beam which I want to return under the 100 day guarantee. The only responses I've had were (a) an acknowledgement to confirm receipt of my claim, with a promise to get back within 24 hours; (b) an automated notification that my case had been closed; (c) a customer satisfaction survey. So I haven't even reached 1st base, and above comments make ominous reading for the rest of the process. Move straight to putting the transaction in dispute?
Userlevel 7
Badge +22
Did you try and call them to get it taken care of
I heard from CS today. Apparently there’s been a new customer support system put in place which has caused some problems. They apologised to me and we have sorted things out I hope (although I am still waiting for refund to clear in my bank).
Chris wrote:

Did you try and call them to get it taken care of



Yes. And was told items received and refund being processed. Guess what - still no refund as of today, and I’m now being told there is difficulty ‘tracking things down.’
Looks like I've got no hope.
Userlevel 6
Badge +22
jessica83509 wrote:

Looks like I've got no hope.



OK...So you're not the Author of this thread and I don't see any previous posts by you in this Thread. That said...what is your issue? Or are you just making a comment on the thread itself? More information/clarity would help.

PS
If you are having issues you'd be better advised to start your own thread.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings