Answered

Roam automatically ungroups after playback is stopped


As the title says. I have a Roam and a Symfonisk. I can group the Roam to the Symfonisk Bookshelf while the Symfonisk is playing, but if I stop playback on the Symfonisk for more than a few minutes, the Roam will automatically ungroup. This is incredibly infuriating since the Roam is often out of reach.

Is this a bug or by design? Is there a fix to ensure the Roam stays grouped?

Thanks

icon

Best answer by James L. 27 May 2021, 16:01

I’ve just checked with our engineering team on whether this behaviour is expected or not, and they have confirmed that this isn’t a bug and is by design. In short, if more than one Airplay enabled Sonos player is in a Sonos group, when the group is targeted, the other Airplay enabled Sonos components will drop from the group and these players need to be added back into the group. I hope that clears things up a bit.

 

Thanks James! This helps a lot. Do we know if there is any way to maintain the sonos groups and prevent the airplay targeting from breaking the existing group? I use Airplay from Apple Music as my primary music source, so it would be a shame if it only ever worked with one speaker :disappointed:

I’m afraid not. I’ll certainly pass on the feedback to our development teams that this experience isn’t ideal and you’d like to see the groups persist after starting an Airplay session.

One workaround my colleague suggested is when starting the Airplay session, make sure to select both speakers from the Airplay targets list, this should allow you to start the stream on both speakers simultaneously. 

Also, Apple Music is available in the Sonos app - so you could always use that to start the music without having to use Airplay.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

I suspect this maybe ‘by design’, but please see the below…

If I add ‘Roam’ to a group of Sonos rooms and play music and then press its rear power button, it goes to sleep and stops playing and if I wake it up again within a few minutes, it certainly returns to the group and continues playing. 

I think such grouped, but then ‘offline’ devices in Sonos may timeout after a period of time (usually 15 minutes or so, I suspect, not sure🤔? ) so maybe that’s your issue, that you are leaving the Roam asleep, or powered off for a long period, or you would prefer the time-out on such a session extended, perhaps?

I personally find that ‘auto-grouping’ my own Sonos devices using Alexa ‘enabled’ groups instead is my own preferred option, but you need an ‘Alexa group controller’ in order to do that. There are other alternatives too, like iOS shortcut using third party Apps like ‘Soro’ aswell, for auto-grouping purposes, but it would be nice if both Roam ‘pairing’ and ‘grouping’ could remain a bit more ‘sticky’ for longer, perhaps?.

I’ve looked into this closer and I believe it’s a “bug”* in the way Airplay2 stream playback is handled.

Steps to reproduce:

Speaker B = Other Sonos Speaker (eg. Symfonisk)

  • In Sonos App, group the Roam and Speaker B.
  • From an Airplay2 source, set the destination to Speaker B.
  • Roam and Speaker B will immediately ungroup. 
  • Airplay2 Stream will play on Speaker B.
  • If a Sonos source was already playing on the Roam+B group, Roam will continue playing the original source.

Likewise:

  • In Sonos App, group the Roam and Speaker B.
  • From an Airplay2 source, set the destination to Roam.
  • Roam and Speaker B will immediately ungroup.

However:

  • Selecting both Roam and Speaker B as the Airplay destination will group the speakers if they are not grouped, and if they are grouped they will remain grouped.

 

This appears that when receiving an Airplay2 stream Sonos will ungroup the speakers. However, regrouping them after the stream has already been started will allow the music to be propagated to the other speakers via Sonos instead of multiple Airplay streams. However, once the stream is stopped for a period of time, when pressing play the Airplay2 stream is “restarted” and the speakers will again be ungrouped.

Presumably this must be a known behaviour of Airplay and Sonos. The question is what can be done to resolve it?

I put “bug” in quotes because it’s quite possible this is a conflict between the Airplay spec and the Sonos spec. However, I do not believe Sonos should be ungrouping when an Airplay stream is initiated to a grouped device. I don’t see any practical reason why this would be useful to anyone.

Userlevel 7
Badge +15

Hi @mochimochi,

 

That’s some great investigation work! However, I don’t believe this a bug.

You’ll want to check a setting in your Sonos app - namely Group Non-Airplay Products.

You’ll find this in Settings → System → Airplay and make sure that it’s turned On.

Then, test out the scenarios you’ve listed above and see if anything changes :slight_smile:

 

As a side note, the grouping you’re doing in the Sonos app and the process of selecting multiple Airplay targets in the iOS menu are separate “grouping” methods. The latter being a way to send simultaneous content streams from your device directly to the Airplay enabled speakers as opposed to creating a synchronized group in the Sonos app. Changing the setting I’ve mentioned above should let you maintain the Sonos group when you target a speaker with Airplay.

Hi @James L. 

Unfortunately I can’t turn Group Non-Airplay Products option On because the option is greyed out - presumably because I have no Non-Airplay products on my network.

Open to other ideas!

Thanks

 

In the Sonos App goto "Settings/System/Airplay” and enable “Group Non-Airplay Products” and see if that resolves your issue.

(edit: sorry I don’t type as quickly as you folk).

You can work around the issue here too by selecting/grouping both speakers in the iOS Airplay listing. You will see the devices group in that list.

Userlevel 7
Badge +15

Hi @James L. 

Unfortunately I can’t turn Group Non-Airplay Products option On because the option is greyed out - presumably because I have no Non-Airplay products on my network.

Open to other ideas!

Thanks

 

I’ve just checked with our engineering team on whether this behaviour is expected or not, and they have confirmed that this isn’t a bug and is by design. In short, if more than one Airplay enabled Sonos player is in a Sonos group, when the group is targeted, the other Airplay enabled Sonos components will drop from the group and these players need to be added back into the group. I hope that clears things up a bit.

I’ve just checked with our engineering team on whether this behaviour is expected or not, and they have confirmed that this isn’t a bug and is by design. In short, if more than one Airplay enabled Sonos player is in a Sonos group, when the group is targeted, the other Airplay enabled Sonos components will drop from the group and these players need to be added back into the group. I hope that clears things up a bit.

 

Thanks James! This helps a lot. Do we know if there is any way to maintain the sonos groups and prevent the airplay targeting from breaking the existing group? I use Airplay from Apple Music as my primary music source, so it would be a shame if it only ever worked with one speaker :disappointed:

Userlevel 7
Badge +15

I’ve just checked with our engineering team on whether this behaviour is expected or not, and they have confirmed that this isn’t a bug and is by design. In short, if more than one Airplay enabled Sonos player is in a Sonos group, when the group is targeted, the other Airplay enabled Sonos components will drop from the group and these players need to be added back into the group. I hope that clears things up a bit.

 

Thanks James! This helps a lot. Do we know if there is any way to maintain the sonos groups and prevent the airplay targeting from breaking the existing group? I use Airplay from Apple Music as my primary music source, so it would be a shame if it only ever worked with one speaker :disappointed:

I’m afraid not. I’ll certainly pass on the feedback to our development teams that this experience isn’t ideal and you’d like to see the groups persist after starting an Airplay session.

One workaround my colleague suggested is when starting the Airplay session, make sure to select both speakers from the Airplay targets list, this should allow you to start the stream on both speakers simultaneously. 

Also, Apple Music is available in the Sonos app - so you could always use that to start the music without having to use Airplay.

@James L. If it’s possible to make suggestions to the team: it would be fantastic if we could add a “prevent airplay from breaking Sonos groups” toggle in the system settings.

 

As for myself, I can’t think of any situations where this would be a preferred behaviour over respecting the Sonos groupings I’ve configured. This is the single biggest issue preventing me from expanding my Sonos setup, and I imagine it will grow as Apple continues to push Airplay as the primary streaming mechanism from Apple devices. It would be great if there was a way to resolve it.

Userlevel 7
Badge +15

@James L. If it’s possible to make suggestions to the team: it would be fantastic if we could add a “prevent airplay from breaking Sonos groups” toggle in the system settings.

 

As for myself, I can’t think of any situations where this would be a preferred behaviour over respecting the Sonos groupings I’ve configured. This is the single biggest issue preventing me from expanding my Sonos setup, and I imagine it will grow as Apple continues to push Airplay as the primary streaming mechanism from Apple devices. It would be great if there was a way to resolve it.

I certainly will pass the feedback on, though I suspect the decision for this was due to a limitation in how Airplay works, or to mitigate even more undesirable behaviour. I’m just assuming, of course, as I don’t have any other information as to why this behaviour occurs.