Sonos Beam and Bose QC headphones in Samsung TV



Show first post

130 replies

Userlevel 3
Badge +2
I’ve gone back to hdmi and unplugging the cable everytime I used the headphones...
This is so frustrating... got the top of the line Samsung TV and was thinking to pimp the sound with a Sonos Beam as I‘ve been really happy with all my other Sonos products.
Hope this will be fixed very soon „unplug the cable“ might be an even more annoying answer than the problem itself. That is not an acceptable solution for a company with your ambition.
Userlevel 3
Badge +2
Still no fix??!??
Userlevel 1
Set up a profile just to reply to this thread. Not being able to use Bluetooth headphones without changing a bunch of settings or unplugging a cable is a major buzzkill, and probably will lead me to return my Beam to Amazon if it’s not sorted before my 30 day return window closes.

It’s really sad that this made it out the door Sonos, y’all need to look into your user testing strategy; I don’t know how the situation of ‘I use headphones at night so I don’t keep the rest of the house up’ never entered into the picture.
Definitely Sonos needs an update to resolve the issue on this. Its ridiculous to buy myself a $500 pair of wireless headphones to watch movies late at night only to find out that the Beam constantly kicks my Bluetooth connection off. This NEEDS TO BE ADDRESSED.
Userlevel 3
Badge +2
Thanks the reports, everyone. We've been looking into this issue. It's caused by the way the TV handles a command the Beam sends as part of the process to issue CEC commands to the TV like "off" and "on".

I'll make sure to let the team know you're running into this and that it's causing you trouble.


Any progress on this, Ryan?
I've got the same problem with my setup (Sonos Beam, Samsung Q8C 65, Bose QuietComfort 35/Sony MDR-1000X), and it's *really* annoying. Would love to see a fix for this soon.
Userlevel 7
Badge +26
Hi everyone, this is still something that's being looked at, but there isn't any news to share on if there will be a resolution at this time. Because it's caused by the way that the Beam establishes CEC control for TVs, it's a side effect of the core functionality of a feature. Currently, the best solution if you use your headphones a lot is to either disable CEC in the TV settings, unplug the Beam while using Bluetooth audio output, or use the Optical Adapter to connect the Beam to your TV instead.
Hi Ryan - I'm a new Sonos user (recently purchased a Beam, a pair of Sonos Ones, and a pair of Play:5s as we begin to set up our new home), and although I am generally happy with the products, I also find this issue frustrating. I'm hoping that Sonos pushes forward with a better solution for this ASAP.
Set up a profile and adding to this thread to voice my frustration as well.

I just wasted 30 min on the phone with Samsung figuring out why my brand new TV keeps kicking me off my wireless headphones.
They had no resolve obviously.

Can’t wait to hear about the fix and/or compensation for all of our extra time plugging and unplugging 😃
I'm another one who made an account for the purpose of telling you there definitely should be a solution to this problem. We used to have a Samsung play bar with our Samsung tv with no such problems, but switched to Sonos to let it be part of the Sonos eco system. This headphones issue was one of the issues I encountered early on, and since it worked earlier with my headphones and the same TV, I figured it was the beam's fault.

Wouldn't it be easy to add a feature in the Sonos app to turn on/off the use of Anynet? Or some code to ask the TV if headphones are connected, and if so, back off from the TV?

I sleep with just a wall separating me from the boom of the beam, and if a flatmate wants to watch TV while I sleep, now I need to use my wax ear plugs. Before he could use his Bluetooth earplugs.

Please fix this, Sonos. Yesterday would be ideal. I speak on behalf of the four users in my household.

Paul
Adding my +1. I’ve also resorted to unplugging the Beam when using Bluetooth headphones. It would be fantastic to be able to reliably use Bluetooth headphones seamlessly. I’ve got a Samsung Q6FN with the Beam connected via the ARC hdmi input. I absolutely love everything about my Sonos setup with this issue being the one exception. Thank you for being receptive to hearing our collective woes and I appreciate the time and energy put into resolving this issue.
Adding my +1 too. This issue is infuriating because some Sonos Beam are unable to reconnect to wifi after unplugging/plugging: https://en.community.sonos.com/troubleshooting-228999/sonos-beam-unable-to-communicate-with-it-6813438
Adding my +1. Would love a fix for this. It is really inconvenient to plug-unplug the ARC every time I want to use my Bluetooth headset with Munjal samsung tv.
I would be surprised if the ability to switch elegantly between the Beam and bluetooth headphones did not come up in market and product testing. It will not have been perceived to be a major issue to the typical Sonos buyer. So I am also adding my +1. Sonos please fix this.
Hi Sonos Community,

I found a unique work-around for the time being. This is what I did. I had this Taotronics Bluetooth Transmitter (link below) lying around that I use to connect multiple Bluetooth headsets to my TV. My Sonos Beam is connected to the ARC. The transmitter can connect through the Optical Audio Out.

My TV (Samsung 65" 8-Series) transmits audio from the Optical out in addition to the ARC. So for now. I mute my Sonos and connect by Bluetooth to the Taotronics transmitter instead of the TV and enjoy Bluetooth audio from my TV (that comes from the transmitter now).

This is a workaround that works!

However SONOS still needs to fix the main problem.

Here is a link to the transmitter I am using - https://www.amazon.com/TaoTronics-Bluetooth-Transmitter-Receiver-Wireless/dp/B01KO1JNCA/ref=asc_df_B01KO1JNCA/
Hi, just putting my two pennies worth in. Have the Beam and 2 play1’s connected to Sony tv via ARC. I also have this problem when I connect my Sony Bluetooth headphones for ‘quiet viewing’. No matter what I try, the Beam turns itself back on within a few seconds of sound being played. This results in sound playing through headphones and Beam! I’ve noted the responses in this thread but I certainly don’t want to be disconnecting HDMI all the time nor playing with settings within the Tv. There has to be an easier solution by way of an addition in the Sonos app to allow a ‘forced’ stop on the beam or a ‘headphone’ mode which mutes the beam?? Hope it gets resolved soon!? On another note - Beam and Play 1’s for surround sound performs exceptionally well!
Userlevel 4
Badge +7
I don't have any of the issues or even a Beam 😃 But I got a though. Not sure if it would be a good / bad idea or even possible.

My Idea:
what about if future products such as the Beam / Playbar, (any speaker that allows a TV to be connected) had a bluetooth transmitter in it to allow wireless headphones to be connected. The speaker could see that bluetooth headphones are connected, directing all audio from TV to headphones, muting the speaker (Beam/Playbar) + connected group but not affecting other ungrouped speakers in other rooms playing from other sources. ???
Badge
Same problem here too.
This issue is driving me nuts and I thought I did something wrong. So I am glad, I found this thread. Please fix this bug. I am really happy with my Sonos Beam, but this is really a big issue for me (and obviously for lots of other people as Well). Thanks
Userlevel 1
Badge
Hi, same problem for me! Had to turn off HDMI CEC on my Samsung TV to be able to use Bluetooth headphones.
I hope Sonos will make a fix to be able to switch on headphones without going through a bunch of TV menus.
Thanks!
Userlevel 1
Badge
Not just me who’s annoyed by this then! The whole point of wireless headphones is so that you don’t have to faff about with plugging and unplugging stuff. I didn’t have this issue with my previous old Yamaha soundbar and ARC so really surprised that Sonos think this is acceptable workaround.
Any updates yet Sonos? I cannot believe that having spent almost £1000 on a tv, £250 on Bose headphones and £350 on a beam (as well as 3 other sonos speakers), I cannot just select headphones and they work. I understand the ARC principle, but I’m not happy that I have to either unplug the beam or turnoff the arc function every time. ?
Userlevel 3
Badge +2
Come on Sonos! We need an update on this problem
Badge
Hi Sonos,
I write my very first message to voice my frustration and extrem disapointment.
I bought a beam with my new Samsung Q9FN TV because I have been garantied a smooth experience.
I spent all my evening upset trying to find a solution with my BT headphones, facing this issue.
Finding this thread this morning and reading that a solution is to 'unplug' the beam infuriates me. (Other workarounds do not make me happy either)

Please Sonos, be honest, and tell me if a software fix is possible? Or if this cannot be fixed by design? (regardless of when such a fix would happen)

Me, keeping using, praising and recommending Sonos products or not depends on that.

Thank you

Reply