Answered

Compatibility WiFi 6 (802.11ax) mode

  • 25 January 2021
  • 41 replies
  • 4151 views

Badge

Hi there.

I recently upgraded my router to a Wifi 6 (no extender or mesh). 

I have

3 x older Play 1s (2 as surrounds)
1 x Soundbar
3 x One SLs

I have found that, using 2.4GHz wifi, the 3 One SLs (i.e. newer hardware) work just fine however the older hardware cannot be seen on the network

UNLESS I turn off Wifi 6 mode and go into a compatibility mode… Then everything is fine. 

As a workaround, my house is Cat 5 wired (and a couple of units are placed to enable connection directly to an ethernet port. I therefore connected the Playbar to try and create a hard wired configuration… It seemed that this didn’t work either, with an inability for anything to be seen / configured by the iOS app…

My questions are therefore:
1. Am I right to assume the Play 1’s and Playbar will not work with Wifi 6?
2. Because wireless router remained on whilst trying to config in wired mode, has this prevented a wired mode setup working?
3. What is the range of using SonosNet (i.e. wired mode) vs WiFi?
(and finally) 4. Would a Boost alleviate all my woes above and thus enable me to use WiFi 6 in my house?

Appreciate someone’s help on this. 

Thanks

 

 
 

icon

Best answer by BunkMuffin 1 February 2021, 20:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Hi. You should be able to get rid of the WiFi band issues by wiring a speaker to your router. Then go into Settings, System, Network and remove all WiFi credentials. If necessary power cycle all speakers

Please then post back.

Userlevel 7
Badge +21

Sonos  requires some old WiFi tech to work and has issues with some new tech if it is turned on. I got tired of trying to keep the rules straight and of living with my newer gear not working as well as it could.

The solution is as was suggested, wire one or more Sonos main speakers (not sub or surounds) and remove the WiFi credentials from the controller. A Boost is handy if you can’t wire another Sonos not needed.

 

Not always necessary but a lot of folks find that assigning static/reserved IP addresses for their Sonos devices increases system stability, particularly at updates and power failures.

Badge

Grand.

Thanks for the advice. I suspect that I hadn’t removed all the WiFi credentials properly hence the app was looking in the wrong place. 

I’ll give that a crack once I can get the family to stop using the blasted kit ;) Update to follow...

 

Badge

So, 4 days on and the plot thickens. 

It looks like the entire system just times out of the network every now and then. I’ve found this in Wifi 6 mode of the compatibility mode as mentioned above. 

Because of the way my modem and router are physically located in the house, using the SonosNet network is a little tricky. As I think I need the Sonos device linked to my wireless router, rather than directly to the modem (via a small network switch). 

I’ve also found that Asus routers did cause some issues unless “AirTime Fairness” and “IGMP Snooping” was turned off. So I’ve done that now. 

I’ve therefore 531957540 submitted a diagnostics directly to Sonos to see if they can find anything…!

In the meantime, am I right that connecting, via my modem (not WiFi router) also via a Network Switch might explain why I cannot seem to activate the SonoNet (it just drops off the app never to be found again if I plug in an ethernet cable (note I’ve tried 3 different cables into either ethernet slot of my Playbar so ruled out a hardware issue)..!

I’ll update as and when I hear more… but if anyone else can spot an obvious thing I should try, please post a reply. 

Thanks

Ben

 

 

In SonosNet mode you are advised to turn IGMP Snooping ON in order to prevent network loops.

If your network switch is managed configure it as follows Configure STP settings to work with Sonos. Finally Remove the WiFi details from Sonos system.

 

Wire either the Playbar or the left unit in a stereo pair to the WiFi router, do not use the Sub or speakers that are set up as surrounds as the solely wired items.

Badge

In SonosNet mode you are advised to turn IGMP Snooping ON in order to avoid network loops.

If your network switch is managed configure it as follows Configure STP settings to work with Sonos. Finally Remove the WiFi details from Sonos system.

 

Wire either the Playbar or the left unit in a stereo pair to the WiFi router, do not use the Sub or speakers that are set up as surrounds as the solely wired items.

Unfortunately I can’t seem to remove the WiFi settings from the system. The option is either greyed out or, it just hangs. Any way to force the system to forget the settings?

I think I you’ve answered my query to say I must connect to the WiFi router rather than just the modem via an unmanaged (dumb) network switch?

@BunkMuffin, You didn’t disable the wireless radio on the wired unit, did you? If so re-enable it for “Disable WiFi” is disabling SonosNet.

 

Afterwards remove the WiFi details as follows: On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit.

Badge

@BunkMuffin, You didn’t disable the wireless radio on the wired unit, did you? If so re-enable it for “Disable WiFi” is disabling SonosNet.

 

Afterwards remove the WiFi details as follows: On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit.

So the modem (which is where the Ethernet cable running into the playbar) has its WiFi disabled. This is so it doesn’t interfere with my wireless router (the sky modem is crap for wireless, hence linking it via wan to a better WiFi router) which has its WiFi radio set as on.
 

Are you suggesting that the modem should have wireless radio turned on, because it is where the Ethernet signal is passing into the playbar?

No, I wasn’t referring to the modem. You should wire the Playbar to the WiFi router otherwise you won’t see it as it’s most likely on a different subnet.

Badge

No, I wasn’t referring to the modem. You should wire the Playbar to the WiFi router otherwise you won’t see it since its most likely on a different subnet.

Ok. My challenge is that the WiFi router isn’t really accessible to the playbar, certainly not permanently. The modem, however, is another thing and can be permanently connected to at least one unit (the playbar).

By temporarily connecting to the WiFi, would then being able to change the Sonos settings enable me to revert to using the modem and the sonosnet network?

By temporarily connecting to the WiFi, would then being able to change the Sonos settings enable me to revert to using the modem and the sonosnet network?

 

No. You mentioned a dumb network switch. If it supports IGMP Snooping cable the Playbar to the switch (provided that the switch is connected to the WiFi router).

Userlevel 7
Badge +21

The only thing I see missing is trying static/reserved IP addresses once you sort the issues following that post’s question out.

Badge

The only thing I see missing is trying static/reserved IP addresses once you sort the issues following that post’s question out.

Thanks for replying.

Sadly, I have done this too.

Last night I went back to basics, going through a process of resetting each part, starting with the modem… I’ll test this again today and see if I can weed out the issue....

I would like to go back to a comment in your first post:

“UNLESS I turn off Wifi 6 mode and go into a compatibility mode… Then everything is fine. “

What exactly does that mean?  Does it mean that 5GHz band is turned off, or does it simply mean that the router is happy to deal with older protocols using 2.4GHz.  If the latter, then you don’t really have a problem.

Badge

I would like to go back to a comment in your first post:

“UNLESS I turn off Wifi 6 mode and go into a compatibility mode… Then everything is fine. “

What exactly does that mean?  Does it mean that 5GHz band is turned off, or does it simply mean that the router is happy to deal with older protocols using 2.4GHz.  If the latter, then you don’t really have a problem.

Yes, what I believed I had initially discovered was placing the router into “WiFi 5 mode” solved the problem, however following further testing, this did not seem to be correct and with either setting I’ve subsequently experienced issues... 

OK.  In that case I would like to understand better (if you wouldn’t mind clarifying) what the relationships are between the modem, switch and router that you have mentioned.  What is connected to what and how?  If you can easily provided makes and models of the devices that would be helpful.

Are you sure that what you have referred to as a modem is indeed a pure modem, not a modem/router?

Badge

OK.  In that case I would like to understand better (if you wouldn’t mind clarifying) what the relationships are between the modem, switch and router that you have mentioned.  What is connected to what and how?  If you can easily provided makes and models of the devices that would be helpful.

Are you sure that what you have referred to as a modem is indeed a pure modem, not a modem/router?

No problem.

Master phone point » Sky Q router (wireless turned off) » ASUS Ax82 wireless router located in middle of house. 
I configure the Sonos by plugging into asus router.

 

My house is cat 5 wired, so I have an option to hard wire the playbar in, however, subsequent testing finds that it’s physical location means it can’t see all my other Sonos hardware via Sonos net.

Dolet me know if there are other details you want! Cheers

Is anything other than the Asus router wired to the Sky router?

There is mention of a switch.  How does that figure in the scheme?

What does ‘configure the Sonos by plugging into asus router’ mean?

Currently, is any Sonos device connected by Ethernet to anything, and if so, to what?

Thanks

Badge

The Sky router also serves a wired connection to a unmanaged switch, which serves my sky box and TV.

The Asus router serves two PCs (wired).

Currently, no Sonos is connected by Ethernet.

 

As an update from this morning… I reset everything in the early hours, then connected the playbar (with two surrounds) and a single One SL. 

Everything seemed fine and stable. 

I have just connected a Play 1 now (starting via wired and then disconnecting into wireless mode) and the whole system has again disappeared from my network. The iOS app can’t see anything. Neither can my PC. 

Could this be a firewall setting on my router?

At the risk of being today’s Captain Obvious, a Sonos controller connected to the Asus router is not going to be able to see any Sonos unit wired to the Sky router (or to its switch). They’d be on different subnets.

Equally any controller on a device wired to the Sky box or switch wouldn’t see a Sonos device using the Asus’ WiFi.

Thisis how I think you should have this set up.

  1. The only thing connected to the Sky modem/router should be the Asus router.
  2. Wifi on Sky should be turned off
  3. Any network switch should be connected to the Asus router not the Sky box
  4. Even if only as an experiment, connect a Sonos speaker by Ethernet to your router (even if you have to move a speaker).  If there isn’t a free Ethernet port on the router, use the switch.

You will need then to power off EVERYTHING to get the IP addressing sorted out. Power the Sky box fully back on first, followed by Asus, then anything wired to your network, then anything wireless.  That includes mobile devices.

I cannot guarantee this will sort it out, but your current arrangement doesn’t sound right.

Badge

At the risk of being today’s Captain Obvious, a Sonos controller connected to the Asus router is not going to be able to see any Sonos unit wired to the Sky router (or to its switch). They’d be on different subnets.

Equally any controller on a device wired to the Sky box or switch couldn’t see a Sonos device using the Asus’ WiFi.

It reads as obvious, but initially I was falling foul of this error, so thanks! 

Further to @ratty ‘s post, I think what I suggested above would make it certain that everything connected to the Asus.

Badge

Thisis how I think you should have this set up.

  1. The only thing connected to the Sky modem/router should be the Asus router.
  2. Wifi on Sky should be turned off
  3. Any network switch should be connected to the Asus router not the Sky box
  4. Even if only as an experiment, connect a Sonos speaker by Ethernet to your router (even if you have to move a speaker).  If there isn’t a free Ethernet port on the router, use the switch.

You will need then to power off EVERYTHING to get the IP addressing sorted out. Power the Sky box fully back on first, followed by Asus, then anything wired to your network, then anything wireless.  That includes mobile devices.

I cannot guarantee this will sort it out, but your current arrangement doesn’t sound right.

I think the technical phrase is I’m running a double NAT config… With wireless turned off on the Sky Router (effectively making it act like a modem). I don’t think that this is an unusual set up (many with an aftermarket wireless box will have this set up). 

I’ve also verified that the handling of IP addresses is not conflicting between the modem and the router, therefore if the TV and sky box are routed to the modem, whilst the router is wired to other components, this shouldn’t cause a conflict. 

I will try this experiment though and see where it takes me. Funnily instability happened when I introduced the Play 1 (i.e. the older kit). I will try and eliminate this factor by testing with One SLs instead….

@BunkMuffin, I’m having the same configuration: Two routers, the first one acting as modem with WiFi turned off; the second one, the WiFi router is connected to its WAN port. Therefore I have two different IP ranges → the modem 192.168.0.x, and the WiFi router 192.168.178.x. Having all my networking devices connected to the latter range the Playbase is also cabled to the WiFi router.

 

You’ve got to find a way to connect the Playbar to your WiFi router (Asus).