Question

Beam Disconnects from TV


Is anyone else having an issue with their Sonos device and their TV? I have a brand new Beam and a brand new Samsung TV, and they were working perfectly for about a week, but now the TV doesn't recognize the Beam as an audio source. Honestly, I'm just trying to figure out if my issue is with the Beam or the TV. Thanks in advance.

11 replies

Hi, I just started having the same problem. Did you manage to solve it?
I have similar problem for the last 2 weeks. Previously everything was perfect. My Sonos Beam is connected to HDMI ARC on Hisens TV
This just happened to me for the second time. Seems to be a problem for several of us. What’s Sonos going to do about it?
Without data via a diagnostic report, there's not much that could be done. I'd recommend two things. First, try a power cycle of your TV. Don't turn it off with the remote, actually unplug it from the wall for a minute. Second, submit a system diagnostic within 10 minutes of replicating this issue, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
@Airgetlam, thank you for the feedback.
I will try a power cycle tonight. I am not able to manually replicate the issue but I will be sure to submit a system diagnostic next time it happens.
I also have a Samsung TV which recognizes the Beam but the Beam will not turn on unless the Sonos app is used. I have tried waiting, restarting the TV, using the remote to change the volume and re-setting up the Beam all without success. What other options do I have to get the Beam to turn on when the TV is turned on without using the app? Thank you.
There's a setting in the room settings area. Go to Settings>Room Settings>(Room Name of the Beam)>TV> and turn on TV Autoplay. It must have been turned off at some point.
Unfortunately it happened again today when streaming Netflix through AppleTV on LG smart tv. Diagnostic no. 1968969680.
Allan Serena wrote:

Unfortunately it happened again today when streaming Netflix through AppleTV on LG smart tv. Diagnostic no. 1968969680.

Have you tried turning off HDMI-CEC controls of the 'other' devices connected to your TV HDMI ports .. just leave them in use on the Beam.

For example, you can turn the TV control off in your Apple TV settings. See this link:

https://m.imore.com/how-new-apple-tv-turns-your-tv-switches-inputs-and-controls-volume

You perhaps also need to turn such HDMI-CEC controls on any other devices that are connected to the TV too.

Hope that helps.👍
@Ken_Griffiths, thank you for your input.
My Apple TV is an older version (2 or 3 I think) but I will try it once I am in front of the TV again. Cheers.
Allan Serena wrote:

@Ken_Griffiths, thank you for your input.
My Apple TV is an older version (2 or 3 I think) but I will try it once I am in front of the TV again. Cheers.

If you have any other HDMI connected devices, then don’t forget to check those too.

In some instances a TV may also have an 'auto-detect-hdmi' feature somewhere in its settings, but I presume you will have checked for that issue. See the below links, as it used to be a problem, particularly with some Samsung and Panasonic TV's (certain models) ... I appreciate yours is an LG TV... still worth a check though.

https://us.community.samsung.com/t5/TVs/Turn-off-auto-detect-HDMI/td-p/2578

https://www.avforums.com/threads/auto-detection-of-hdmi-input.1233267/

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings