Right speaker of stereo pair always cutting out

  • 13 November 2023
  • 16 replies
  • 1370 views

Userlevel 1

I have an issue which is driving me up the wall - I have a pair of Era 100 speakers which worked perfectly well for the first month of their life but now I experience the right speaker not playing anything for up to 20 seconds if I skip to a new track - both on Tidal Connect and Spotify. Every single damn time. I’ve tried moving the right speaker to a different area with less potential interference (i.e. away from gadgets) but it will always cut out whenever I skip through a song or select a new one.

I’ve done a bit of research and I gather that setting up a manual IP address may fix the issue. However, I can find no instructions how to do this, other than posts which say “do this, do that” without actually telling you how.

Could any kind soul walk me through this please? I’m on Virgin Media and have a strong broadband speed, although I expect the service provider shouldn’t matter. I just want to know where to find the settings, which ones to click on and how to find the ip address. I don’t like asking for help but I’ve searched for 30 minutes and got nowhere.

Such a disappointment. I love the ways these speakers sound but I never expected this. 


16 replies

I would first reboot your VM router and then try separating the stereo pair and then check for any Sonos updates and swap their positions and pair the speakers the other way around. Just see what happens in that different (swapped) configuration.

I’m not convinced setting a static IP address will sort your issue, but if you want to try that afterwards and let me know which VM hub you have, I will try to get you the instructions you need, but I think pairing the other way around is perhaps worth trying first. Even trying different wireless channels may be a better idea than setting a static address, but that can be done later too.
 

Userlevel 1

Actually I think I solved it - for now at least, until it starts to go wrong again. I finally found a post that told me to do msconfig, type this ip address into a web browser to go to my router management page (which I’ve never accessed before, obviously). Changing the 2.4Ghz channel from Auto to 1 seems to have done the trick. I hope I’ve done this correctly. Though I can’t shake the feeling that tomorrow I’m going to play a song and it’s just going to do the same thing!

Userlevel 1

I would first reboot your VM router and then try separating the stereo pair and then check for any Sonos updates and swap their positions and pair the speakers the other way around. Just see what happens in that different (swapped) configuration.

I’m not convinced setting a static IP address will sort your issue, but if you want to try that afterwards and let me know which VM hub you have, I will try to get you the instructions you need, but I think pairing the other way around is perhaps worth trying first. Even trying different wireless channels may be a better idea than setting a static address, but that can be done later too.
 

Thank you. I haven’t changed the IP address, I just followed these instructions from Sonos (https://support.sonos.com/en-gb/article/change-your-router-s-wireless-channel) and changed Auto to channel 1. I’m reluctant to reboot the router and try swapping them because at the moment at least, it works! My router is a Virgin Superhub 5 and I have the top tier (outside London) broadband speed. 

 

Actually, could I ask you if you think getting an ethernet connector would make any difference? I’ve balked at getting one due to the cost but if it means having trouble-free Sonos connection I’m considering it! I’ve even thought about getting rid of Tidal and just having Spotify, thinking it was the lossless streaming that it couldn’t handle, but today even bloody Spotify was doing the one speaker only trick.

 

But anyway, touch wood changing the channel has done the trick. Thanks for your reply.

Yep, that sounds fine to me - I use their Hub v5, so if you have any issues perhaps post back and will try to help in any way I can.

Meanwhile I found this YT video that describes how to set static addresses with a ‘common model’ of VM router … it’s just for information at this stage:

https://youtu.be/Ob5SOAEdbto?si=ByI-eN6CFrhJ_Yga

Hope that assists.

Thank you. I haven’t changed the IP address, I just followed these instructions from Sonos (https://support.sonos.com/en-gb/article/change-your-router-s-wireless-channel) and changed Auto to channel 1. I’m reluctant to reboot the router and try swapping them because at the moment at least, it works! My router is a Virgin Superhub 5 and I have the top tier (outside London) broadband speed. 

 

Actually, could I ask you if you think getting an ethernet connector would make any difference? I’ve balked at getting one due to the cost but if it means having trouble-free Sonos connection I’m considering it! I’ve even thought about getting rid of Tidal and just having Spotify, thinking it was the lossless streaming that it couldn’t handle, but today even bloody Spotify was doing the one speaker only trick.

 

But anyway, touch wood changing the channel has done the trick. Thanks for your reply.

Our posts crossed - no I would not bother with the combo ethernet/audio adapter at this stage - it’s probably not necessary to wire your speakers and there are still ‘lots’ of things I can think of trying first, if the issue returns, including changing the channel-width on your WiFi bands - aswell as swapping the devices. It’s early days and the v5 hub is a reasonably good WiFi router from VM.

Userlevel 1

Yep, that sounds fine to me - I use their Hub v5, so if you have any issues perhaps post back and will try to help in any way I can.

Meanwhile I found this YT video that describes how to set static addresses with a ‘common model’ of VM router … it’s just for information at this stage:

https://youtu.be/Ob5SOAEdbto?si=ByI-eN6CFrhJ_Yga

Hope that assists.

Many thanks again for your help

Userlevel 1

Oh dear, it’s so predictable. I played a couple of songs this morning - no problem. Then, out of the blue, the right speaker takes 30 seconds to play what the left speaker is already playing. I kind of expected this to be honest.

Firstly, I tried changing my left and right speakers (after resetting the router) - no luck.

I went back to my router web page and changed the channel to 6, then 11 (as advised in the Sonos support information) - made no difference.

I changed my speakers back again, did the usual thing of removing the stereo pair then resetting the stereo pair. After 3 attempts of unplugging and plugging and then setting up a stereo pair, the right speaker problem went away. But I know it’s going to come back tomorrow. Nearly £600 for a pair of speakers that I have zero confidence in.

The only other thing that may (or may not) be worth pointing out is that on my router web page, the settings for 5Ghz are still set at Auto - I haven’t touched these, I’ve only changed the channel for the 2.4Ghz settings.

So I’m at a loss really!

@Snotters,

Here are 4 steps for you to go through - just do each step and then test to see if it resolves your problem with your speaker…

Step-1
Go back to your router configuration page and set the channel-width for the 2.4Ghz WiFi band to 20Mhz only and just leave it on channel 11 for now.
You can also set the 5Ghz channel to fixed channel 36 and just leave its channel-width as 20/40/80.

Step-2
Next, separate the Sonos stereo pair and first check for any Sonos updates (important). Next I’m going to suggest factory resetting the one problem speaker (only). Here are the instructions to do that, but whatever you do, do not reset the other speaker at this stage. (Only ever reset one speaker at a time and set it back up on the system before (ever) factory resetting another device).

Now, setup the reset speaker using the Sonos App ‘Settings/System/Add Product’ - give it a slightly different name to your first, speaker. So if your left speaker is called ‘Lounge’ (just as an example) then call this speaker either ‘Lounge 2’ or ‘Lounge R’ - then when setup is complete, goto the left ‘Lounge’ speaker and stereo-pair the right ‘Lounge 2’ speaker to it and then let’s see how that goes. 
Step-3
You can of course repeat the steps and do the same type of reset with the left ‘Lounge’ speaker, but I would just do them one at a time and see if things get resolved, only reset this ‘other’ speaker if the problem persists and do not ‘repeatedly’ reset either device…

Step-4

If the problems still continue after this, then it will then be best to submit a Sonos system diagnostic report from within the Sonos App (make sure both speakers are visible/showing in the App), note the diagnostic reference number and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter. Hopefully you won’t need to go this far but let’s see what happens doing these things one step at a time in the stages mentioned.

Hope the above suggestions resolve your issue.

Just as a quick further thought, as your speakers are using your VM WiFi, it might also be worth checking the SNR reading of both your Sonos speakers… see this support link:

https://support.sonos.com/en-us/article/understanding-the-network-details-section-in-the-sonos-app

Ideally they both need a signal strength of 45dB (that’s an ‘excellent’ WiFi connection) albeit they will still work at a lower SNR level. 

Hope that proves useful to you too.

Userlevel 1

Just as a quick further thought, as your speakers are using your VM WiFi, it might also be worth checking the SNR reading of both your Sonos speakers… see this support link:

https://support.sonos.com/en-us/article/understanding-the-network-details-section-in-the-sonos-app

Ideally they both need a signal strength of 45dB (that’s an ‘excellent’ WiFi connection) albeit they will still work at a lower SNR level. 

Hope that proves useful to you too.

Hi Ken,

 

Firstly I really appreciate your time and guidance. I'll try those steps in your previous post, but for signal strength I get 59 for the left and 69 for the right speakers. The problematic right speaker is nearer my router but also has a TV and console near it. I have tried moving it to a different area but it was the same story - worked fine for a bit and then started with the same problem 

 

So I can rule out my WiFi signal at least....

Userlevel 1

Okay, so I did a factory reset and followed your instructions Ken, and it seems okay at first play. Time will tell though - if the problem persists I will contact Sonos.

In the meantime I'm incredibly grateful for your support. Sonos obviously has a great community.

Cheers mate.

Yes, that WiFi signal strength is good to both speakers - so it’s unlikely connected to that, I guess, but it’s good to keep other wireless devices about a metre away, if practicable, or maybe put them on a different WiFi band to the one in use by your speaker. Let’s just see how things go with each of the steps mentioned… just test things between each step and see if one of them sorts it.

I have the same issue for Era 300 pair, worked fine for several months, then keeps breaking and needs constant ‘fixing’. I know wifi can be complex, but imo this issue should be resolved by sonos if they are going to be marketing pairing capabilities - it should ‘just work’ and keep on working!

I have the same issue for Era 300 pair, worked fine for several months, then keeps breaking and needs constant ‘fixing’. I know wifi can be complex, but imo this issue should be resolved by sonos if they are going to be marketing pairing capabilities - it should ‘just work’ and keep on working!

The speakers do work if they’re operating on a reliable wireless/wired network, however local networks often can and do change  - a simple reboot of the router, for example, can often switch a WiFi channel between a non-overlapping channel and cause it to overlap with other signals in some cases.

Introducing new products into the home can also alter things and cause disruption.

My suggestion is to try the router on different WiFi channels (a simple router reboot may sort it) and/or perhaps set the 2.4Ghz band channel-width to 20Mhz only and try it with a fixed non-overlapping channel 1, 6 or 11 and ensure speakers are at least one metre away from any other wireless networked device, or product, such as a Microwave Oven, Bluetooth Receiver/Transmitter, Dect Telephone, or Baby Monitor etc. and see if that resolves the issue.

Also do not use wireless range extenders, or EOP power-line adapters with Sonos, as those devices are not supported, as stated in the Sonos system requirements.

After purchasing 2 ERA100’s and setting them up as a stereo pair, everything worked great for a few weeks.  But then one or the other started to periodically cut out.  Tried all the suggestions I could find, including resetting to factory defaults numerous times, buying the Sonos Line-In Adapter, restarting the Router, etc.  Nothing worked until I finally changed my WiFi from Auto to Channel 1.  So far so good, in case anyone is still having trouble.

Nothing has changed except periodically rebooting my router. Reserving IP addresses specifically for these devices at the router level seems to be the fix; I assume they bind to an IP instead of a MAC address, but I’m just speculating. If that is the case, too bad they can’t scan for devices and find each other that way.

Reply