Play:5 (Gen 2) says needs update but won't update

  • 13 February 2021
  • 4 replies

I have a Sonos system with various Connect, Connect Amp, Play:5, and Sub components. It has worked fine for several years including various updates of all components along the way. Suddenly the Play:5 said it needed an update, but that update has failed dozens of times. I have tried hardwiring, factory resetting, uninstalling Sonos app (Android Sonos 2), unplugging all other components and trying to add the Play:5 as its own new system, etc. Nothing has worked to let me update that Play:5 or add it into my existing or a new system. Any ideas?


Best answer by Rowena B. 13 February 2021, 22:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 5
Badge +16


Welcome to the Sonos community. Thanks for reaching out to us and letting us know about your concern.

To help you out with this, let me suggest the next troubleshooting steps you can do.

  • Sequential reboot to refresh your network and all your Sonos devices connection.
    • Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
    • Once the router is back online, unplug all your Sonos devices from the power.
    • Please wait 15 seconds before you plug back them back in.
    • Force close the Sonos app from your iOS or Android device.
    • When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.
    • Open the Sonos app and see if your Play 5 is showing.
    • Test playback from and observe Sonos performance.
  • Hardwire one of your speakers to your router.
    • Open the Sonos app and see if your Play 5 is showing.
    • Test playback from and observe Sonos performance.


If it's still doesn't work, you may need to contact our support team to look into this. Our phone support has the tools to check what's going on in your system and to remotely access your device to address the issue. Please let us know if you have any further questions or concerns, we'll be glad to assist you. 

Hi Rowena. I followed your steps exactly and unfortunately the Play:5 does not show up in my system.

Userlevel 5
Badge +16

Hi @DJAinCLE, thanks for your response and for updating us.  Sorry to hear that your Play 5 is still not showing in the Sonos app. You may try to hardwire your Play 5 to your router and see if it will show in the Sonos app. If it’s still missing, please contact our support team to further check on the issue. If you have any questions or concerns, please be sure to let us know.

After working with Sonos Tech Support via phone for an hour or so, they referred my case to the Escalation Team. After arranging a convenient time to talk, Mike called me, pinpointed the issue immediately and walked me through the fix in three minutes. For some reason my router was not allowing access to that one device - the Play:5. We disabled my router's access control and the issue was resolved immediately.