Answered

Can start a stream only from one device, others won't start

  • 19 December 2023
  • 25 replies
  • 222 views

Userlevel 1
Badge
  • Trending Lyricist I
  • 17 replies

I have an odd issue which keeps me going crazy for a few months now.

 

I am using the following devices spread across our house:

  • Play:1 Bathroom
  • Play:1 Office (wired)
  • Play:1 Kitchen
  • Playbar Livingroom (wired)
  • Sub Livingroom

 

Initially I had only the Playbar wired, the rest connected through WiFi.

As I kept loosing some Play:1 repeatedly, I changed to SonosNet completely. Hence I have removed any WiFi configuration, wired Play:1 in the office too.

 

All devices show WM: 0 and I never lost any Play:1 anymore.


Unfortunately I have the situation, that I can only start a stream (doesn’t matter if TuneIn Station or Spotify) from Play:1 in the office​​. On any other device I see the “Play Icon” changing for 1 second and going back to Stop immediately.

 

What I have to do, start the stream in Play:1 office, group the other speakers into it, then remove the Play:1 in the office again. This way I can stream music in the other rooms.

 

I already have reset all devices and reconfigured them, it didn’t help.

Also I have power cycled them multiple times, also in a “staged” approach so I started with the wired ones and followed the others afterwards.

 

I am using a HPE 1920 switch that has STP configured according to best practices of SONOS. I don’t think its STP related though, as the problem also occurs if I only power on two devices (one wired and one SonosNet).

 

Attached you can find the Network Matrix and I’ve ran and submitted diagnostics: 1731400236

 

Network Matrix capture

Any ideas are highly appreciated.

Thanks

 

Additional Information: Wireless System is Aruba Instant On (one AP per floor), Firewall Ubiquiti EdgeRouter

 

icon

Best answer by sti 20 December 2023, 13:46

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

25 replies

Bathroom has a weak connection to Office. Trying to start any group from that is likely to fail. The first node in the group is the Group Coordinator, responsible for fetching the stream and distributing it to the rest of the group. It needs a good connection.

Also, Bathroom and Office see quite a lot of ambient noise. Try alternative SonosNet channels.

Userlevel 1
Badge

Thanks @ratty - appreciate your ideas!

 

I’ve tried out the other channels, I moved to Channel 1 and 11, it seems Channel 1 has “better” signal. Would you agree too?

I have - of course - excluded the SonosNet channel from my WiFi-AccessPoints to avoid any interferences.

 

Do you have an idea why I can’t start a stream from Livingroom? It is wired too, like Office. Unfortunately only Office can start a stream.

 

Network Matrix Channel 01
 
Network Matrix Channel 11

 

Channel 1 does look better. Hopefully you’re also using 20MHz channels on your APs, not 40MHz.

 

Do you have an idea why I can’t start a stream from Livingroom? It is wired too, like Office. Unfortunately only Office can start a stream.

Can’t you start a stream at all on Living Room? Even on its own? Do you get any kind of error message?

Get the IP address of Living Room and go to http://x.x.x.x:1400/tools. Type “spotify.com” into the Nslookup box and hit that button.

Userlevel 1
Badge

Channel 1 does look better. Hopefully you’re also using 20MHz channels on your APs, not 40MHz.

Alright, I’ll stay on Channel 1 then. Yes, correct, I’m only using 20MHz channels on the APs.

 

Can’t you start a stream at all on Living Room? Even on its own? Do you get any kind of error message?

No I can’t, I can’t start a stream other than from Play 1 at Office. I also don’t get any error message. The Play Icon changes for a second and immediately goes back to Stop.

 

Get the IP address of Living Room and go to http://x.x.x.x:1400/tools. Type “spotify.com” into the Nslookup box and hit that button.

 

I tried that on all of the boxes, the result is everywhere the same:

spotify.com: dns (3 ms) -> 35.186.224.25 mdns (0 ms) -> failed netbios (0 ms) -> failed

 

Thank you

Okay, so it doesn’t look like a DNS failure. Have you verified your firewall settings?

Userlevel 1
Badge

I did, nothing specific in its config. I’m allowing anything going from inside to outside.

The Sonos boxes have a DHCP reservation too, so they don’t roam around regarding IP leases.

 

I’m really running out of ideas to be honest. I was hoping that something is visible in the diagnostic logs I’ve provided.

It most probably is, and back in the day when the diag logs were user-accessible I might have been able to assist. Now it’ll need a member of Sonos staff to take a look. 

Userlevel 1
Badge

Understood, thanks. Do I have to wait for someone to read to this thread, or is there another way to engage them?


Cheers

I’ve asked ...

Userlevel 1
Badge

Many thanks @ratty !

Userlevel 7
Badge +18

Hi @sti

Welcome to the Sonos Community!

My suspicion is that the HP switch is the source of the issue. Can you please try wiring a Sonos device straight to the router, bypassing the switch? If that helps, please verify the following settings on your HPE switch:

Global Settings

Spanning Tree State

Enable

STP Operation Stage

Enable

BPDU Handling

Flooding

Path Cost Default Values

Short

Bridge Settings

Priority

4096

Hello Time

2

Max Age

20

Forward Delay

15

STP Interface Settings (for every port connected to a Sonos product)

STP

Enable

Edge Port

Auto

Root Guard

Disable

BPDU Guard

Disable

BPDU Handling

Use Global Settings

Path Cost

User Designed 10 (Set to "Default" for ports not connected to Sonos products)

Priority

128

Multicast Settings

Bridge Multicast Filtering Status

Enable VLAN ID: your ID (e.g. 1 Forwarding method for IPv4/v6: MAC Group Address IGMP)

I also notice you have Ubiquiti - please try the following:

Enabling IGMP Snooping and MDNS

  1. From the Unifi Network Application interface, click on the Settings icon from the left side menu.
  2. Click on the Network tab.
  3. Select the network Sonos is connected to. Click on the Default network name if there is only one.​​​​​​
  4. Scroll down to Advance Configuration, and click on Manual.
  5. Check IGMP Snooping and Multicast DNS.
  6. Click on Apply Changes and allow up to 3 minutes for the settings to update.

Having said all that, Badezimmer not playing doesn’t surprise me - the RSSI (Received Signal Strength Indicator) to each wired unit broadcasting SonosNet is too low. If you can move this speaker so that a straight line from it to Büro has less wall/matter on it, it could help. If you can get WiFi in this room, you might be better-off forgoing SonosNet altogether and just teaching your system the WiFi password: Settings » System » Network » Manage Networks » Update Networks. When the app tells you to disconnect ethernet at the end, be sure to disconnect both the one in Büro and the one in Wohnzimmer.

I hope this helps.

Userlevel 1
Badge

Hey @Corry P 

appreciate your insights and ideas around this issue. I’m unable to move the Sonos and hook them up to the EdgeRouter directly due to lack of available interfaces.

I went ahead and removed all wires and moved back to Wireless configuration, w/o SonosNet.

 

I did power cycle all devices after reconfiguration. Initially it looked good, I was able to start a stream from Play:1 in Kitchen, though the stream stopped after like 5-10 seconds (I didn’t precisely look at a stopwatch) :-(

 

Now I have the same situation as before, only Play 1 can start a stream, others are unable and I immediately toggle back to Stop symbol. I tried multiple TuneIn Stations as well as Spotify.

 

Enabling IGMP Snooping on the ports where the Access Points are connected didn’t change behaviour.

 

Does an updated Network Matrix provide any insights, or does it only help in a SonosNet configuration?

 

I ran another diagnostic session with the following ID: 505322067

Thanks

Does an updated Network Matrix provide any insights, or does it only help in a SonosNet configuration?

It’s really only relevant for SonosNet, though the left column might shed some light on local RF conditions.

You can check the WiFi RSSI for each device directly in the room settings, under ‘Products’.

 

Userlevel 7
Badge +18

Hi @sti 

You are still getting HTTP errors from the speakers, meaning that they are unable to access the remote sources.

I notice you have Aruba WiFi, which I have not come across before, but I did find the following advice for it (though the reported symptoms do not match yours):

Resolution

  1. Log in to the Aruba access point (username: admin, password: admin.)

  2. Select the name of the access point under Network and select Edit.

  3. Under WLAN settings, select Show advanced options.

  4. Set Broadcast filtering to Disabled.

  5. Select Next until the settings are saved.

I presume that you would need to repeat for each Access Point.

I also found this, which is a bit more involved:

Resolution

  1. Log in to the Aruba WebGUI.
  2. Select AirGroup from the left column (may be under More > Services as well.)
  3. Add a new service group labelled Sonos Services, and description Sonos.
  4. Using the Add section, add each of the following services one line at a time, clicking Add after each.
urn:schemas-upnp-org:service:GroupRenderingControl:1urn:schemas-sonos-com:service:Queue:1urn:schemas-upnp-org:service:AVTransport:1urn:schemas-upnp-org:service:RenderingControl:1urn:schemas-tencent-com:service:QPlay:1urn:schemas-upnp-org:service:GroupManagement:1urn:schemas-upnp-org:service:ZoneGroupTopology:1urn:schemas-upnp-org:service:DeviceProperties:1urn:schemas-upnp-org:service:MusicServices:1urn:schemas-upnp-org:service:AlarmClock:1urn:schemas-upnp-org:device:ZonePlayer:1urn:schemas-upnp-org:service:SystemProperties:1urn:schemas-upnp-org:service:ContentDirectory:1urn:schemas-upnp-org:service:ConnectionManager:1urn:schemas-upnp-org:device:MediaServer:1urn:schemas-upnp-org:device:MediaRenderer:1urn:schemas-upnp-org:service:AudioIn:1urn:schemas-upnp-org:device:EmbeddedNetDevice:1urn:schemas-upnp-org:service:EmbeddedNetDeviceControl:1urn:schemas-upnp-org:service:HTControl:1urn:smartspeaker-audio:service:SpeakerGroup:1
  1. Check Enable DLNA and DLNA Media Service.
  2. Click Apply and then Save Configuration.

Again, this is for fixing an issue that you don’t seem to have, but it may be worth trying if nothing else works.

Just out of curiosity (and because this method uses different connection types), are you able to play to your speakers by using the Spotify app rather than the Sonos app?

I hope this helps.

Userlevel 1
Badge

Thanks @Corry P 

This is very odd. Did the error message change compared to SonosNet before? Any chance you can share the log sections with me, so I can check the firewall too.

Yes, you‘re right I have Aruba Instant On - those are cloud managed and don‘t allow any advanced - manual - configurations as you‘ve outlined - unfortunately :-(

If I start a stream on a device, how does it relate to other devices if they‘re not grouped?

When I ran the system using SonosNet, Aruba WiFi couldn‘t interfere, so its either the Switch or the Firewall.

 

It doesn‘t matter if I start it from Sonos App, or through Spotify.

When I ran the system using SonosNet, Aruba WiFi couldn‘t interfere, so its either the Switch or the Firewall.

Are there any logs you can inspect, to see what traffic might be being blocked?

 

Userlevel 1
Badge

Okay, I’m definetly lost guys.

I just disconnected all other Sonos devices and left on only Living Room, this way there shouldn’t be any “cross Sonos device communication” happening, so no multicast - hence no filtering issues etc. Am I right?

Still the device couldn’t start either TuneIn or Spotify, Diagnostics: 913979752

 

I then moved away from Living room, because it also has a Sub associate to its room - who knows maybe this plays a role too. So I turned of the Playbar and tested with Kitchen only, thats a single Play:1

 

I suspected DNS and reconfigured DHCP to use a different DNS server (8.8.8.8) and power cycled the device, still same thing. But after hitting the Play symbol for like 8 or 10 times, it suddenly started the Spotify stream triggered out of the Spotify app. Diagnostics: 47301616

 

Any ideas?

DNS is simply a giant phone book. When you ask for Spotify, a request is sent to the DNS server: “What is Spotify’s IP address?”. A problem with DNS service might slow or prevent the initial connection to Spotify, but not have any effect once Spotify’s address is returned. If you knew the address of the Spotify server, you would not need DNS.

DNS seemed okay, 3ms to resolve spotify.com. Something else appears to be getting in the way.

Userlevel 7
Badge +18

Hi @sti 

Thanks @Corry P 

This is very odd. Did the error message change compared to SonosNet before? Any chance you can share the log sections with me, so I can check the firewall too.

Well, the only errors in attempting to play I saw in the first diagnostic was on Badezimmer, which had a very poor connection to SonosNet. Now that it has a better connection (to WiFi), I’m not seeing those errors there anymore, but I do on Wohnzimmer instead. The errors are 404 and 401 HTTP transport errors.

Looking at a different log (there are a lot of logs and I didn’t look at this one last time), however, it looks like the speaker is receiving a command to pause immediately after receiving the command to play, which doesn’t make a lot of sense. This log, which does not show errors, seems to indicate commands coming from a local device that is not a Sonos device, and is not your iPhone. It has an IP address of 172.16.20.60. Could you please let me know what it is? Thanks

Play Log

 

Yes, you‘re right I have Aruba Instant On - those are cloud managed and don‘t allow any advanced - manual - configurations as you‘ve outlined - unfortunately :-(

That’s a shame, but I had no idea if those steps would have worked or not, so no great loss.

If I start a stream on a device, how does it relate to other devices if they‘re not grouped?

As far as I know, they generally don’t care.

When I ran the system using SonosNet, Aruba WiFi couldn‘t interfere, so its either the Switch or the Firewall.

Yes, that makes sense. But with an entirely different connection method, I was hoping for different results. Do your Aruba WAPs connect via the HPE Switch? If so, the switch is still my main suspect. Why do you have a managed switch? Would an unmanaged switch do? If so, it may make things easier, though I cannot guarantee it would fix your issues, though I’d certainly like to try it.

You may find our Configure your firewall to work with Sonos help page of some use.

It doesn‘t matter if I start it from Sonos App, or through Spotify.

Thanks for trying. Have you tried other sources? Radio perhaps? If all sources act the same, the issue is more likely to be related to your local network (which seems fairly certain at this point, but it’s good to verify).

I hope this helps.

 

Userlevel 7
Badge +18

Hi @sti 

I took a look at the newest diag with only one Play:1 in it and I can see it play Spotify for 22 seconds - is that the successful attempt you are referring to? Or did it play for longer? I ask because there are a lot of repeated attempts to get it to play afterwards too.

Userlevel 1
Badge

Hi @Corry P 

Thank you for providing the logs, the actually helped very much!

 

I’ve noticed that after receiving a Play command, a Pause command is issued. Thanks to the logs I noticed that the source is different than my phone. The system in question is a SmartHome system that monitors the Sonos system too.


I have removed the Sonos integration for testing and now its working stable again.


Appreciate yours and @ratty help on this! Happy Holidays folks

 

Userlevel 7
Badge +18

Hi @sti 

Thanks for the update - although it doesn’t make much sense, it makes more sense than I thought we’d get out of this at the start!

Anyway, I’m glad we were able to figure out what was going wrong, and that you were able to bypass it. It may be worth feeding back to the manufacturer of your SmartHome system that their software was, ironically, making your home less smart, and if you let us here know what manufacturer/system it was, it may help others who have the same system.

By all means leave it for a while, though - you’ve done plenty, and it is the holiday season after all - happy holidays!

I’m curious to know what the SmartHome System is here too🤔? It maybe useful to know, in case the issue pops up in the community here in the future.

Userlevel 1
Badge

Fair point @Ken_Griffiths - it’s Gira Homeserver, probably a less common solution though.

 

I‘ll for sure update this thread once I know more, finally confirmed and resolved the issue.