Good sound but Sonos has the worst software and app EVER. And it's not even close.

  • 23 November 2023
  • 22 replies
  • 432 views

See above title.  I would never buy any Sonos product again and my advice to everyone that I speak with (and I’m a tech consultant) is never ever ever buy a Sonos product.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

What particular issues are you experiencing, that brings you to this statement? 

Great. Rather than simply rubbishing Sonos name a streamer and app/controller that you’d recommend instead.

(Hint: Native streaming service apps which can ‘cast’ are nearly always more functional than a ‘unifying’ app such as Sonos, for very obvious reasons.)

Userlevel 7

See above title.  I would never buy any Sonos product again and my advice to everyone that I speak with (and I’m a tech consultant) is never ever ever buy a Sonos product.

@opieandbambi

People like you who make blanket statements about issues with no information as to what the issues are really make me want to say things that are inappropriate. You call yourself a Tech Consultant…. how do help anyone with your attitude. So I guess your clients contact you about issues with no explanation as to what the issues are. Amazing!!!

However, if you want assistance please use common sense (Tech Consultant) and provide us with details regarding your issue(s).

Perhaps a Thanksgiving-lubricated rant?  

Userlevel 7

Perhaps a Thanksgiving-lubricated rant?  

I hope it was a good single barrell whiskey, wine or beer. But on second thought it’s the rot-gut stuff that gets most people 😂

Is a tech consultant anything like an Instagram Influencer?

Badge

<rant>

I stand with the original poster. Given the amount of money that Sonos charges they should be providing software that is massively better than what is supplied. I’ve read the arguments that they are a hardware company, not a software company, then fine - outsource the software part to someone who knows what they are doing. Specifics, you ask? Well, the source of my frustration de jour is that I just spent well over an hour attempting to creating a playlist by tediously dragging songs into the order I wanted, but when I attempted to save said set as a Sonos playlist, I got multiple error messages, followed by a system crash and loss of all my work. But that’s just this evening’s frustration. Throughout the day (and, actually, throughout the years that I’ve used Sonos, tbh) I experienced random song-skipping, pauses, crashes, and missing libraries.

And yeah, my rant may be a smidge Thanksgiving-booze fueled, but this is far from the first time I’ve experienced such snafus. Why the * can’t this company get its software * together?!?

Frustrating that there isn’t really competition in this market. Seems ripe for a start-up to come along and build similarly decent speakers that play nicely not only with third party software, but with their OWN NATIVE software, fer crissakes…

Happy Thanksgiving, y’all

</rant>

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

All of the symptoms you’ve listed are indicative of local network issues, and perhaps a corrupted download for today’s problems, but there isn’t enough data to be certain.

Have you submitted any diagnostics, and contacted Sonos for assistance with your system? 

As a counterpoint, I’ve been using Sonos for well over a decade, without issues. Perhaps I’m not exercising my system in the same manner as you do, but I would think if the issues were as endemic as you seem to be suggesting, I’d be experiencing issues as well. 

Badge

There are some dead spots in my network but I’ve added a mesh network and tweaked the position of the various pods over the years to optimize connectivity of the speakers and reach in the house. It hasn’t really made a difference. The problems are not consistent - some days Spotify, local library, and Sonos playlists will play seamlessly, other days these rando glitches will occur. 
 

When you say a corrupted download, do you mean the Sonos software? I am very good about keeping my software updated as well as the OS on my phone (on which I was having problems last night). 
 

I have submitted diagnostics in the past for similar issues (along with disappearing speakers) but nothing has ever resolved these consistent issues. 
 

I do have a lot of music pushing through the system - over 5000 songs on local library and, in the case of last nights issue I was parsing a playlist of close to 600 songs on Spotify - perhaps it just struggles to deal with the load…? Anyhoo, I appreciate you taking the time, Bruce, to write a measured response to my drunken late-night rant. And I’m psyched for you that you’ve had such a great experience over the years with your Sonos system. I wish I could say I heard that more than my story and the OPer’s. But I guess no one writes in with words of praise whereas everyone loves to get on their soapbox and rant. 😂

cheers,

Nick

Some mesh network systems can be problematic for Sonos, as they split each ‘node’ into a different subnet. I’d encourage you to try wiring one Sonos speaker to the root of you network, and see if the Sonos designed mesh works better for the Sonos system itself. 

Yes, I was suggesting a potential corruption in the download/update of your controller. Since data is stored on the speakers, and not the controller, there is no reason not to simply delete the current application, and go to the store and download a fresh version. When prompted, just be sure to ‘join existing system’.

Submitting a diagnostic is a great step, but you have to call in before Sonos will look at it. 

I don’t use Spotify, so I’m unsure what limits they’ve set on their playlists, but those errors should be reflected in the logs of the last ten minutes, and included in the diagnostics when submitted. It is indeed unfortunate that Sonos doesn’t allow us access to those directly, but I suspect there is data in them that would cause potential issues with privacy laws, so they’re restricted to the diagnostics data, and can be read by Sonos employees only.

I hope you’re able to get these issues rectified!

Badge

Interesting… Thanks for the suggestion. It would take a rather dramatic reorganization of our basement to get my Sonos Bridge (I think that’s the name of it - an old legacy piece the plugs into a receiver) jacked into my router but perhaps I’ll run a CAT10 cable across the room when the missus is away to test it out. 
 

Re-downloading the controller is easy enough so I shall certainly take up that suggestion. 
 

Thanks again for taking the time. 

-Nick

Userlevel 7

If I may. The Bridge is an outdated piece of Sonos gear and has been known to cause issues. It was replaced by the Boost several years ago. Sonos is now moving away from the Boost as well. The recommended solution to start the SonosNet is to wire a speaker to your router.

 
Note: Era series, Move2 cannot be used as such nor can any speaker used as a surround.

I think @Nick Danger means a ZPx0/Connect, as it “plugs into a receiver”.

Userlevel 7

I think @Nick Danger means a ZPx0/Connect, as it “plugs into a receiver”.

Good point as I thought the receiver reference was odd.

Badge

Sorry - you guys are correct, it’s a 2nd gen Connect, not a Bridge. I’ll try plugging it directly into my router (this is what is being suggested, correct?). Is the idea to then delete my system and start from scratch as if it’s a new system?

Full system:

1 Move

1 One (2nd gen)

1 Connect (2nd gen)

2 Play:3

 

(I also have a One SL and a Five setup elsewhere on a different system). Point is, despite my moaning, I guess I’m still a fanboy… 😂

No, you don’t need to set up anything afresh. Don’t factory reset anything. It’s unnecessary and can cause more problems.

Just plug the Ethernet cable into the Sonos, and give everything a few minutes to recognize the new signal. Sometimes, a Sonos device could need a ‘nudge’ by performing a power cycle, but unless instructed by someone from Sonos, I agree with @ratty , you shouldn’t do a factory reset. 

Badge

T+2 month update:  purchased a long enough Ethernet cable and ran it from the router to the back of the Connect and the song stopping and skipping seems to have been fixed. Components occasionally “disappear” temporarily from the controller app and volume can sometimes be sluggish but these gremlins seem minor compared to prior problems.

 

Thank you for the suggestions!
 

Given the positive results from hardwiring, I suspect snafus are related to my having two wireless networks broadcasting in the house. 

Badge

I find the system continually frustrating on many levels and I'm just doing simple stuff. For example: (for those above who want chapter and verse) I set an alarm for music to come on at 9am and this works for awhile then for no apparent reason the chime will come on at 9am. Going to settings does not show the chime programed. I just deleted the app and reinstalled and shows connected but asks me to sign in but the circle spins and 'try again' message comes up. Again these are not the only issues. Next I'll go to the laptop and try that way.

Badge

Should have added to my post that I have sonos1 x2 sonos 3 and sonos 5. I have wired one of the speakers to the router to make it work (because the wireless option didn't work) and it did for awhile but now does not. It is not user friendly. 

The chime is an indication that the Sonos system failed to reach the server that you pointed the alarm to. Rather than not play anything, it ‘alarmed’ the only way it could. 

The real question is why could your Sonos speaker not reach the server you told it to? Was it simple wifi interference that got in the way of the Sonos reaching the designated server? Or was the target server so flooded with requests at that precise moment that it refused connection? 

I’d certainly read that linked FAQ, and maybe try sliding the time on that alarm by a couple of minutes to see if it was just too many attempted connections by people at the same moment. 

Badge

Ok I'll try that. Thanks