HomeKit & Sonos One - unable to add

  • 5 November 2018
  • 19 replies
  • 11593 views

Hi all,

I just bought Sonos One and it works perfectly. Did add Apple Music service, works with Air Play, ... So far, so good.

Then I tried to add it to my Home via ...

  • Add Accessory
  • Don't Have a Code or Can't Scan?

... but my device didn't appear there even after couple of minutes.

I was searching this forum and I've found that I have to disable Group Non-AirPlay Speakers. The problem is that this option is there (control app), but it's greyed out (can't disable it). Trying to disable it in the Settings - AirPlay.



Sonos Control app version 9.2 (build 46357271), Sonos One speaker 9.2 (build 46357250), iOS 12.1.

How can I disable the Group Non-AirPlay Speakers to make it working with HomeKit?

Thanks,
Robert

P.S. I tried to disable Home in iOS, reboot Sonos One, etc. Nothing helps. This is the only thing that doesn't work for me. Rest works like a charm.

19 replies

Firstly, I don’t think the 'Group non-Airplay Speakers' is going to be the answer here, but if you want to try it, then goto the Sonos App Settings/Airplay and toggle off the switch there.

If it doesn’t work, then post back here with an update.
Firstly, I don’t think the 'Group non-Airplay Speakers' is going to be the answer here, but if you want to try it, then goto the Sonos App Settings/Airplay and toggle off the switch there.

If it doesn’t work, then post back here with an update.


As stated in the initial post (and visible in the attached image), this toggle button is greyed out = control disabled = can't do this.
As stated in the initial post (and visible in the attached image), this toggle button is greyed out = control disabled = can't do this.
Could you post a screenshot of "About my Sonos System"?
Sure thing. Attached.
Sure thing. Attached.
Sorry for the double post. Page said I have to post it again, because it failed. Seems it didn't.
'Group non-Airplay Speakers' is grayed out because the ONE is your only Sonos speaker.

Could you also post screenshots from the Home app?
Sorry I missed the fact the OP's screenshot was from their own system, I assumed it was copied from another thread.

A few things to add ..

1. It is best to have the mobile device in use on the 2,4ghz band. It’s also helpful to stand nearby the actual speaker being registered as an accessory.
2. It is sometimes useful to reboot both the router and speaker.
3. The device being used for registering the HomeKit accessory should be the one that was actuallly used to setup the Home itself.
4. The AirPlay Speakers should be authorised to play on the local network in the Settings of the HomeKit App, accessible from the icon top left corner of the main Homepage.
5. You cannot register a Sonos Speaker that has already been registered in another HomeKit Home, without factory resetting that speaker or removing it from the previous Home (A reset is currently the only option, if the previous Home has been deleted).
3. The device being used for registering the HomeKit accessory should be the one that was actuallly used to setup the Home itself.

Wow, I’m sure glad I still have my old iPhone 6 so I could add my 5.1 Beam setup to HomeKit!!
I read other articles that stated you had to sign in with the same account that made the home, but this was the first that stated it had to be the literal same device. Thanks Ken_Griffiths!

So does this mean I can never get rid of this iPhone 6 if I want to add future Sonos speakers to my HomeKit setup?! Hmm...
whistlingfool,

Yes you must keep it forever ! .. ha ha
Only joking, you can always remove the speaker and then delete/demolish your Home and create it again on another device, but I suspect that Apple will have resolved this issue by then in some future update, fingers-x'd.
Userlevel 2
Badge +3
Hi, just figured to throw in my two cents since I bought a One and had the exact same issue you're describing. I don't know if you've done this already, but all I needed to do was to reboot my phone. Home was able to detect the One after that.
I had the same issue with Sonos AMP. I rebooted my iPad Air 2 and was able to detect the AMP and add it to Home via add accessory. I previously shut down WiFi on the AMP so it wasn't a WiFi issue.
Wow, I have to say I am impressed Ken_Griffiths. I thought there was NO way the problem could be resolved by pulling out my old iPhone 6s to add the Beam to the home app. It couldn't be possible that we really had to use the original device that I created the Home with. Tell me it ain't so. But, sure enough, I tried everything else so I pull out the old phone and the Beam showed up immediately when I tried to add it as a new accessory. So, it is either that Ken is correct and it requires the original device, OR because the new phone is on the 5ghz band, and the old phone is on the 2.4. But, I don't feel like turning off the 5ghz to find out if that was the issue. Either way, at least I can add the Beam now. Thanks again Ken_Griffiths!
Hi, just figured to throw in my two cents since I bought a One and had the exact same issue you're describing. I don't know if you've done this already, but all I needed to do was to reboot my phone. Home was able to detect the One after that.

I just wanted to add in that a reboot of my iPhone XS and I was able to detect and add my Sonos one. Sometimes you miss the obvious, thanks for the tip Liron :8
I have a similar question. I have a playbase which shows up in my HomeKit. But I also have 2 other sonos play 1’s in my house that won’t show up in the Home app. Does it need to be there or does it default under the playbase? Ultimately, I want to tell Siri to play music just in my kitchen or just on my deck. It works currently with my playbase. Everything is up to date, I’ve restarted my XS Max. Everything works perfect except for this.
I have a similar question. I have a playbase which shows up in my HomeKit. But I also have 2 other sonos play 1’s in my house that won’t show up in the Home app. Does it need to be there or does it default under the playbase? Ultimately, I want to tell Siri to play music just in my kitchen or just on my deck. It works currently with my playbase. Everything is up to date, I’ve restarted my XS Max. Everything works perfect except for this.
Only the Sonos devices that are AirPlay-2 capable will show up in Apple HomeKit as accessories. Currently those devices are:
  • Sonos PlayBase
  • Sonos Beam
  • Sonos One (gen1 or gen2) (when not used as rear HT surround)
  • Sonos 5 (gen2)
  • Sonos Amp (when not used as rear HT surround)
Thanks for the tip on restarting the phone. That solved the problem with a new Sonos One that wasn’t showing in the Home app.
After an hour and a half searching for clues in the community I found a solution that worked for me. First, to get the speaker to appear on the list of available devices in the homekit app, I started playing some music through AirPlay. Once I could press on that, an error message kept popping up saying it was unable to add the device to homekit. So I used one of the simplest tips that kept popping up in the community: turn your iPhone off and on again. I couldn’t believe that would be the solution but it worked.

It worked for me after rebooting my iPhone. This iPhone was NOT used for the initial setup of HomeKit.

Reply