Airplay Password

  • 17 October 2021
  • 20 replies
  • 19829 views

Userlevel 4
Badge +2
  • Avid Contributor III
  • 11 replies

All of my Sonos speakers recently starting asking for an Airplay password even though I have the password requirement disabled in Apple’s home app. I have not been able to figure out how to disable the password prompt and can no longer use Airplay.

Anyone know how to fix?

So-and-so 2 years ago

A bit late… but if you own an AppleTV this could be the solution

 

”You may be prompted for a password to stream AirPlay audio to Sonos if you have an Apple TV or an AirPlay capable TV that requires a password for AirPlay to work on your network. Go into the AirPlay settings of your Apple TV or the AirPlay capable TV and make sure “Require Password” is disabled.”

https://support.sonos.com/s/article/1230?language=en_US

 

Using the AppleTV AirPlay password worked for me (just in case you don’t want to disable this feature).

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

20 replies

Userlevel 7

Hi @rubeo 

This may not be the case but it sounds like your iPhone is part of a corporate environment. If so click the link to resolve the issue.

 

 

Userlevel 4
Badge +2

Hi @rubeo 

This may not be the case but it sounds like your iPhone is part of a corporate environment. If so click the link to resolve the issue.

 

 

Thanks, but this doesn’t apply to any iPhones in my household. 

Userlevel 4
Badge +6

Then maybe it’s the other possibility: a bug or glitch in the configuration storage, which apparently can be chased away by hard-resetting the offending speaker(s) and re-adding it (them) to your system.  Resetting is often the last resort and always discouraged -- but you will see, if you click on many of the “Related Topics” to the right of your initial posting, that they all seem to boil down to those two possibilities in the end.  Check them out...

Userlevel 4
Badge +2

Then maybe it’s the other possibility: a bug or glitch in the configuration storage, which apparently can be chased away by hard-resetting the offending speaker(s) and re-adding it (them) to your system.  Resetting is often the last resort and always discouraged -- but you will see, if you click on many of the “Related Topics” to the right of your initial posting, that they all seem to boil down to those two possibilities in the end.  Check them out...

Does this mean losing all of my true play settings across five of my rooms? If so, that is ridiculous - especially since Sonos doesn’t allow you to back up current settings.

Userlevel 7

@rubeo 

I replied to your post a few days ago. Afterward I decided to check my Sonos for the issue with AirPlay2. Guess what...some rooms were experiencing the same issue...Airplay2 asking for a password/code.

In my case it was my two Roams and Sonos Amp with Sonos Sub used to power stereo speakers. All other rooms were OK. My fix was to (as suggested by @tracker ) reset those speakers. As the Amp was configured it does not allow Trueplay so no loss there. The Roams will auto-TruePlay so no worries there either. Any other room would require TruePlay after a reset.

I would not blame Sonos as AirPlay2 is not a Sonos developed feature. It’s licensed from Apple. As the software on your iOS device is also by Apple; therein lies where the blame should be directed. iOS software updates may affect certain Sonos speakers/components differently; as in my case. My Beam, ARC’s, Moves and Fives were not affected (i.e. requiring a password to initiate AirPlay2). However, oddly the Sonos Amp used to power speakers for a turntable was not affected:thinking: .  So some anomalies do exist for whatever reason.

Botton-line...we’re dealing with electronics that use sophisticated coding to work developed independently by Sonos and Apple. Ninety-nine percent (99%) of the time Sonos and Apple play well together; unlike TV manufacturers and their implementations of HDMI-CEC coding :persevere: .

I hope you are able to resolve the password issue to allow a seamless AirPlay2 implemetation with Sonos.

Userlevel 4
Badge +2

The only thing I’m blaming Sonos for is not having implemented a way to backup Trueplay profiles. If a foreseeable solution to this, or any, issue is to hard reset your speakers, it is a shame not to offer a backup option. I’ve spent countless hours getting my Arc setup sounding the way I like, which involved numerous tuning attempts with different model iPhones. As such, the hard reset is not a practical solution for me. 

A bit late… but if you own an AppleTV this could be the solution

 

”You may be prompted for a password to stream AirPlay audio to Sonos if you have an Apple TV or an AirPlay capable TV that requires a password for AirPlay to work on your network. Go into the AirPlay settings of your Apple TV or the AirPlay capable TV and make sure “Require Password” is disabled.”

https://support.sonos.com/s/article/1230?language=en_US

 

Using the AppleTV AirPlay password worked for me (just in case you don’t want to disable this feature).

Using the AppleTV AirPlay password worked for me (just in case you don’t want to disable this feature).

This solution worked for me. It is in Settings → Airplay and HomeKit → Allow Access → Airplay Password

 

I just came across this issue myself only today.  I cannot remember exactly when this last worked but it worked on this iphone I have (iphone 13) but i think it was when I was on IOS 15 and not IOS 16.  I have not touched any of the Sonos One speakers in my home - not done any changes of placement, no auto tuning, nothing.  Anyway today I came in from walking the dog and listening to my music I thought I would just airplay it to my Kitchen speaker to keep listening….oh no, not today.  Today it wants a password for airplay = whaaaat??!?!?  So then I tried again and again and again.  Then i thought lets try my other speakers in the house.  All Sonos One Gen 2 speakers were asking for password.  But the only Sonos One Gen 1 speaker I have worked fine for airplay.  I have Apple TV in my house and no password option so I still enabled the password and then disabled it = didn’t help.
Then i saw a forum answer that suggested resetting the Sonos One speaker.  “Do i really have to do all this again” i thought.  Sure enough lets try it and I reset the speaker and then went through the adding process and the tuning process and the adding of voice assistants.  And then I tried AirPlay from my iphone to this speaker and at last…..it actually worked.  So reseting the whole speaker seems to have worked.

Now I have to do this for 5 other speakers around the house.   great, just bloomin great!  Thanks Apple or Sonos.

I think a simple reboot (power cycle) should do this. I don’t think you need to factory reset each device. 

I did actually try that first.  Just forgot to put that in my rambling on :-D
I tried power off and on for all the speakers that I could not join to through AirPlay because I was being prompted for password.  In the end all of them had to have factory reset.  Just really annoying that’s all!

The only time I’ve seen this Airplay issue mentioned here in the community before, is where a user had registered their speakers as ‘accessories’ in a ‘Home’ in the iOS  HomeKit App and later deleted the ‘Home’/HomeKit App and/or switched to a new ‘Home’/HomeKit App on a different (new) iOS device (setup as a new iDevice), but had left the devices registered in the old iOS ‘Home’/HomeKit App and not removed their accessories from the old ‘Home’.

The thoughts/suggestions from some users at the time were perhaps some kind of Airplay authorisation token was left in situ on the speakers, which was looking for the old ‘Home’.

Anyhow I’m not sure if that is indeed what was happening, but the only ‘quick’ ways to resolve it, seemed to be to locate the old ‘Home’ on the old iOS device, assuming it had not been deleted that is … or to reset the speaker, as that (I guess) wiped-out the old authorisation token allowing the new ‘Home’ to then take over control. 

My own thoughts at the time, which was a long time ago now, was that it was possibly an Apple HomeKit issue, but I thought that the issue had been fixed. That said, if I do ever decide to delete my own HomeKit ‘Home’, I would definitely remove all accessories from that ‘Home’ before pressing the delete button.

I had the same problem. Airplay password required for every airplay speaker (not only sonos) from one day to another. Here is a solution that worked for me. 

The apple home app is included in all new apple devices. I did not use this app actively but at some point i named my home and added a smart sensor. This was done on a second apple device with a different apple ID by another family member. My phone was then requested to enter airplay codes, but the other family member had no problems.
The owner of a home in apple Home can add speakers without entering codes. The owner then needs to invite other appleID users to share these Home settings. Simply click the house/setting symbol and invite…

This worked for me. When the Home app is linked to the same home, no more airplay code/password problems. 

I’m having this issue. I upgraded to an Iphone15, airplay was working fine for the first day and a half, but ever since has been requesting a passcode. I have tried factory resetting the speakers. I have tried adding them to my home app- though I can’t because I’m still getting a request for passcode to add them. I don’t have a way to disable the passcode on my Samsung TV, but I did completely disable Apple airplay abilities on the device. 

I have contacted both Sonos and Apple to no avail. Please help 

I’m having this issue. I upgraded to an Iphone15, airplay was working fine for the first day and a half, but ever since has been requesting a passcode. I have tried factory resetting the speakers. I have tried adding them to my home app- though I can’t because I’m still getting a request for passcode to add them. I don’t have a way to disable the passcode on my Samsung TV, but I did completely disable Apple airplay abilities on the device. 

I have contacted both Sonos and Apple to no avail. Please help 

 

It’s not Sonos.  Sonos has no password facility for Airplay.  It must be the Apple device or account settings. 

I’m having this issue. I upgraded to an Iphone15, airplay was working fine for the first day and a half, but ever since has been requesting a passcode. I have tried factory resetting the speakers. I have tried adding them to my home app- though I can’t because I’m still getting a request for passcode to add them. I don’t have a way to disable the passcode on my Samsung TV, but I did completely disable Apple airplay abilities on the device. 

I have contacted both Sonos and Apple to no avail. Please help 

Just in case … have you checked the Apple Home(Kit) App settings on your current & previous iOS devices to ensure that you have ‘Require Password’ switched off? See attached,

I’m having this issue. I upgraded to an Iphone15, airplay was working fine for the first day and a half, but ever since has been requesting a passcode. I have tried factory resetting the speakers. I have tried adding them to my home app- though I can’t because I’m still getting a request for passcode to add them. I don’t have a way to disable the passcode on my Samsung TV, but I did completely disable Apple airplay abilities on the device. 

I have contacted both Sonos and Apple to no avail. Please help 

Just in case … have you checked the Apple Home(Kit) App settings on your current & previous iOS devices to ensure that you have ‘Require Password’ switched off? See attached,

Hi Ken, I don’t have that option in my home settings. I’m unable to connect the speakers to the HomeKit because it’s requesting a passcode

In the iOS HomeKit App when on the main Home Screen, I just select the ellipsis (…) top right. Then from drop-down menu select ‘Home Settings’ —> ‘Speakers & TV’ …to show the screen where a password can be set.

The password can be set on any Apple device on the subnet, make sure you do not have more than one Apple Home - you might need to check other users devices on the local network too (if that perhaps applies in your premises).

In the iOS HomeKit App when on the main Home Screen, I just select the ellipsis (…) top right. Then from drop-down menu select ‘Home Settings’ —> ‘Speakers & TV’ …to show the screen where a password can be set.

The password can be set on any Apple device on the subnet, make sure you do not have more than one Apple Home - you might need to check other users devices on the local network too (if that perhaps applies in your premises).

There are no speakers or TVs under the (…) settings. I don’t have an Apple TV or speaker to set up HomeKit with 

There are no speakers or TVs under the (…) settings. I don’t have an Apple TV or speaker to set up HomeKit with

Likely it’s an iOS device, iPhone or iPad etc. (past or present) with a HomeKit Home that’s been on the same network subnet - maybe check your old mobile (just as an example) - as @jgatie mentioned earlier, it’s not going to be a Sonos matter, Sonos has no password facility for Airplay. It might even be a (now) deleted HomeKit Home where you (or someone else) have left the Airplay devices registered to it.