Answered

SONOS Roam won't link to my account (was linked before reset)


Originally, after working for a couple years, suddenly my Roam couldn’t connect to any stations.  If I grouped it with other players, it worked fine.  Ungrouped and it can’t connect on its own.  So, I rebooted it (turned off by pressing power button for 5 seconds removed from charger).  That didn’t work.  So I figured I’d remove it and add the device back in.  I did a Reset to factory settings.  Then as I added the Roam back to my system, it made it thru all the steps (WiFi included) except the final one of Linking device to my account.  That’s where it fails now, every time.  When I login to Sonos.com, I see the Roam device (by serial number) in the list of my devices.  I now wonder if there’s a bug where it can’t link to my account because it’s already there.  Frustrating.  Anyone else been thru this?

icon

Best answer by Ken_Griffiths 7 April 2023, 21:49

View original

11 replies

If the Roam didn’t register, power-cycle it and it should show up in the S2 App in ‘Settings/System’ with a spanner icon showing by its name - simply select and follow the spanner to complete setup and registration.

Hope that works for you. If not, then maybe try quickly a reboot of the local router to get it showing in the App settings.

I’ve done that and it does show up with the wrench icon.  I then go thru the process of adding to my system, getting the chime, pressing the two buttons as the led blinks green/white, then it wants to link it to my account and after a long while - fails.   I’ll try the router reboot tomorrow, but SONOS sees it so I have low expectations.

Ha, thanks Ken_Griffiths!  I rebooted the router, then selected the ROAM with wrench icon and it finally succeeded!  Always worth trying every idea - appreciate the help!

Badge

I have the same problem and I did exactly as you did. Unfortunately the rebooting of my router did not solve the problem. I still cannot register the Roam to my account. Andre

I have the same problem and I did exactly as you did. Unfortunately the rebooting of my router did not solve the problem. I still cannot register the Roam to my account. Andre

What mobile device are you using and what version of OS is installed?

Does the Roam show up with a wrench icon in ‘Settings/System’ within the mobile Sonos App?

Also perhaps temporarily switch off any security on that mobile such as VPN, MAC Spoofing, Firewall etc. and try a reboot of the mobile aswell as the speaker.

Userlevel 2
Badge +1

I recently upgraded and bought various speakers including ERA 300s, ERA 100s, ARC, Sub Woofer and an existing One.

I thought I would set up one of the ERA 300s  first and which I got working then I had problems with my router which is a Huawei Model H112-370, this is a 5G router which I use as my phone line based internet is very slow.   Due to the problems with the 5G Router I swapped it for another 5G router which was sent to me my 5G internet provider 3 mobile.   The new router is a Huawei MC801A 5G router.  I also set up a new Sonos account to keep completely separate from my Sonos Gen 1 equipment.   I got it all working then it failed so after speaking with Sonos Support, I decided to start from the beginning.   After a few support calls I am getting fed up as I have not been able use my Sonos equipment for over a week as I cannot get it set up.  

It seems that the app carries out the whole process and it falls at the final hurdle of linking to my Sonos account.

 

I have read similar within this community but no one has come up with a definitive answer.  I have tried numerous factory resets, rebooting my router, resetting my router to factory default and still the best I get is the messages that say it cannot link to my account followed the by the wrench logo.

Any help would be greatly appreciated. 

Sonos devices have not supported LT`E routers for as far back as I can recollect, so I would maybe start by changing that one device/connection and just see where things go from there. Note some such ‘mobile’ routers may occasionally work, but clearly Sonos state the are not supported in their system requirements for a reason and I suspect you’ve possibly stumbled onto that reason.

It would make more sense to try things that are in keeping with the requirements, which are mentioned here in this link.

https://support.sonos.com/en-us/article/sonos-system-requirements

It might be the case that the ISP is perhaps blocking the access/ports you need to setup your system. You could try a different DNS perhaps if the LTE router caters for that manual change. I suggest trying the Google public DNS servers - 8.8.8.8 / 8.8.4.4 as they ‘may’ work, but there’s no guarantee it will resolve all your issues.

Userlevel 2
Badge +1

Sonos devices have not supported LT`E routers for as far back as I can recollect, so I would maybe start by changing that one device/connection and just see where things go from there. Note some such ‘mobile’ routers may occasionally work, but clearly Sonos state the are not supported in their system requirements for a reason and I suspect you’ve possibly stumbled onto that reason.

It would make more sense to try things that are in keeping with the requirements, which are mentioned here in this link.

https://support.sonos.com/en-us/article/sonos-system-requirements

It might be the case that the ISP is perhaps blocking the access/ports you need to setup your system. You could try a different DNS perhaps if the LTE router caters for that manual change. I suggest trying the Google public DNS servers - 8.8.8.8 / 8.8.4.4 as they ‘may’ work, but there’s no guarantee it will resolve all your issues.

Hi Ken,  thank you for your reply.  

When I called Sonos Support on a few calls this week, they did not refer to my router as not being compatible but I will take this up with them when I call them this coming week.

 

 

 

Hi Ken,  thank you for your reply.  

When I called Sonos Support on a few calls this week, they did not refer to my router as not being compatible but I will take this up with them when I call them this coming week.

Okay, meanwhile perhaps try swapping the DNS servers to the ones mentioned (if the router allows) and just ensure the 2.4Ghz WiFi band meets the correct standard too - 802.11b/g/n backward compatibility and security mode WPA2 Personal AES. As you may perhaps save yourself time and a call.

Userlevel 2
Badge +1

Hi Ken,

It appears that my router does not have A DNS setting and from reading on the 3 mobile website other people are having similar issues to me.

It has also been said on other forums that quite a lot of the LTE routers do not have DNS settings so it looks like I will have to use try and get the previous LTE router direct replacement.

I will update if I make any progress.

 

 

Userlevel 2
Badge +1

Hi Ken,

It appears that my router does not have A DNS setting and from reading on the 3 mobile website other people are having similar issues to me.

It has also been said on other forums that quite a lot of the LTE routers do not have DNS settings so it looks like I will have to use try and get the previous LTE router direct replacement.

I will update if I make any progress.

 

 

i managed to get my Sonos Speaker devices registered by using my landline based broadband which I was not using and had not yet cancelled.   My previous 5G router must had allowed registration.  

Once I have unpacked and registered all my other Sonos speakers, I will then attempt to change them to the 5G router which should allow it to be used for streaming of music.

My opinion is that the 5G providers want to make it difficult for subscribers to use their 5G services for streaming??

I would like to thank Ken for his excellent guidance.

Reply