Sonos Roam bluetooth always Drops!


Badge

See many similar post but none are real solutions.

What needs to be done to have sonos roam to be reliable and functional at least once
Bluetooth keeps dropping. Closing youtube on chrome also kills off the audio completely although my mp3 player is still playing in the background.  

Grouping with roam also always ungroup by itself. Really frustrating cos NONE of the function works reliably.

I am using the bluetooth for my PC - Intel NUC Phantom Canyon.

I am using router RT-AC88U with airtime fairness disabled. Plus I already have help from Sonos support prior to configure my router to enable Beam + Sonos One .

Ckohbox 6 days ago

I managed to get it going ….., seems to work for the past few days.
1. On the SONOS app, enable “Always Auto-Connect”
2. Disable “Idle Auto-Disconnect”
3. Disable “Turn off more quickly when not in use to save battery life”

Reload your PC after you have changed the settings.

View original

19 replies

Badge +17

Hi @Jeff.W.,

 

There are a number of factors to consider when trying to troubleshoot bluetooth issues, including the source device, content and distance between the device and the speaker.

 

  • Do the dropouts occur consistently, and regularly?
  • Does it only happen on a certain type of content/media?
  • How far away from your NUC is the Roam?
  • Do the dropouts occur when Roam is paired to another device, such as your phone?

As an aside, the Bluetooth connection will have little to nothing to do with your network, so we want to focus on the direct connection between the NUC and Roam.

Badge
  • Do the dropouts occur consistently, and regularly?

Multiple times in a day

  • Does it only happen on a certain type of content/media?

it happens even when just playing only mp3 on a media player (on bluetooth) 

  • How far away from your NUC is the Roam?

less than 1 meter. I even went to the extent to delete all the other bluetooth connection on my NUC. Roam is the only device connected via bluetooth to my NUC.

  • Do the dropouts occur when Roam is paired to another device, such as your phone?

My use case is with the NUC that’s why I have only paired 1 device (and only 1) with Roam.

Badge +17
  • Do the dropouts occur consistently, and regularly?

Multiple times in a day

  • Does it only happen on a certain type of content/media?

it happens even when just playing only mp3 on a media player (on bluetooth) 

  • How far away from your NUC is the Roam?

less than 1 meter. I even went to the extent to delete all the other bluetooth connection on my NUC. Roam is the only device connected via bluetooth to my NUC.

  • Do the dropouts occur when Roam is paired to another device, such as your phone?

My use case is with the NUC that’s why I have only paired 1 device (and only 1) with Roam.

Thanks for the quick reply!

 

I’d like you to test a couple of things, to help determine what’s failing in this situation.

  • Please make sure the Bluetooth drivers on your NUC are up to date.
    • If the failures still happen after this, please submit a diagnostic and reply with the confirmation number.
  • Please also test Roam with another Bluetooth source and observer whether the failures continue.
    • If they do - submit another diagnostic and reply with that number.
Badge

All my NUC drivers are up to date. Constantly install whatever updates comes to my way.

Let me run the diagnostics when the next failure happens

Thanks.

 

Badge

Diagnostics num ber 49779886

Badge +17

Thanks for that, Jeff.

 

I understand your situation better now. If I’m not mistaken, the dropouts are occurring on the Beam + One SLs when grouped with the Roam, while playing Bluetooth content?

I don’t actually see any signs of dropouts in the last 4 days on the Roam itself, indicating that the signals being received are exactly what it expected (i.e. no dropped packets or parts of the content where it expected some to be sent). If the dropouts are only occurring on the Roam itself then the issue lies with the NUC/the content on the NUC.

 

I do see some signs of audio interruptions on your Beam, which indicate an issue with the wireless connection between the Roam and Beam preventing a consistent transmission of data and causing the dropouts. I don’t see any major signs of wireless interference between the two rooms, but I can’t tell the distance or objects between them, as the detailed connection stats don’t exist between the two rooms in the diagnostics we have.

 

Our customer care team may be able to work with you if you’re able to work with them live over the phone to best stabilise the connection between them.

Badge

i think recent days there wasnt any dropout meaning situation where music got cut and disconnected while playing music

However within today only an hour or 2 ago, the bluetooth stopped connecting to roam when i left it idling without playing any sound or music. i would consider that as a dropout too.

I have to manually go into my PC to manually connect it again every time this happens

Badge +17

i think recent days there wasnt any dropout meaning dropped while playing music

However within today, the bluetooth stopped connecting to roam when i left it idling without playing any sound or music. i would consider that as a dropout too.

How long was it idle for? If it was idle for more than 15 minutes then this is expected from most sources, and not a dropout. For your most recent disconnection, I can see the disconnection event and it was initiated from the source device (NUC) due to inactivity.

Badge

I have a Harman Kardon Oynx 3 that i stopped using cos i bought the Roam. The Harman Kardon never disconnect on the NUC like how Roam does. Harman Kardon is always connected even if I leave it idling.

I am just using this in comparison as both are bluetooth audio devices.

Badge

today bluetooth dropped with music was playing..

Diagnostics 1424430186.

honestly, it depressing that it is unreliable. for the price, it is not really acceptable.

I have had the same issue since I bought it 7 months ago. submitted diagnostic but till today, no fixes. Can someone from Sonos tech investigate the issue and reply to end this unpleasant issue?

Did you call in with your diagnostic number?

yes, I did.

 

What did Sonos say about the diagnostic? Perhaps knowing that might help us understand more of what the issue might be. Right now, we’re assuming you have a Roam, and that you’re  having Bluetooth issues, but beyond that, we have nothing to even base a guess on. 

Badge

I gave up. I sold it off to a friend at less that half its original price.

As you can see from reply above, it is an expected feature that bluetooth drops after more than 15 mins of idling time. and its not considered a dropout.

New class of definition being created here only applicable to sonos.

Yes, I have a Sonos Roam and the Bluetooth drops if it is not in use for few tens of minutes. I will have to reconnect it manually. Same issue with Jeff W.
The last call I had with Sonos (if I can recall correctly) was that there is no solution but will work on one. 

 

Userlevel 1

The auto-disconnect after 15 minutes of no audio is a problem for me, because once it has disconnected from my PC, the only way I have found to reliably reconnect it is to restart my PC. I don’t want to do that multiple times a day.  I noticed Sonos has an option to ‘Idle Auto-Disconnect’; I disabled that, which should help the disconnection issue. Now I just need to figure out how to re-pair my Roam. It refuses to re-pair with my PC. Keeps asking for a PIN.. which I enter… and then it just says “couldn’t connect.. try connecting again”. Did that a few times, didn’t help :(

Userlevel 1

update; I chatted with support and they were unable to help resolve the Bluetooth connectivity issue. I returned them. Here is a video of me troubleshooting, in case anyone’s interested in seeing the frustration involved. Video

I managed to get it going ….., seems to work for the past few days.
1. On the SONOS app, enable “Always Auto-Connect”
2. Disable “Idle Auto-Disconnect”
3. Disable “Turn off more quickly when not in use to save battery life”

Reload your PC after you have changed the settings.

Reply