Answered

Sonos Move disappearing on Airplay

  • 23 April 2022
  • 53 replies
  • 2026 views

I have 2 Sono Move speakers.  One in the kitchen and one in my room.  In the last few days I have noticed that in the Airplay menu on my iPhone / iPad only one would show up and rarely both.  Both speakers however show up to be connected in the Sonos app.  I would have to shut the missing speaker down (long press the power button) and turn it back on to have it showing on Airplay.  I’ve not changed anything with my home internet network.  Anyone has the same problem?

icon

Best answer by Airgetlam 27 April 2022, 14:24

View original

53 replies

I have 2 Sonos Ones and a Sub Mini as my Living Room system. I also have a Sonos Move that I have to connect to the system separately. I recently got a new modem and so changed my network settings. Since then either the Living Room system, or the Move, or both constantly drop off Airplay. They are still connected to the app, but just drop off all my Airplay lists on all my devices.

When I unplug them and turn them back on, they reconnect for a couple of hours, then drop off again. It’s driving me mad! I’ve tried various sequences of unplugging the modem, unplugging the speakers, unplugging both, but nothing works for more than a few hours. Sounds like the same problem. Hoping someone finds a solution! 

Airplay issue - see this link here and the information mentioned by Sonos Staff:

https://en.community.sonos.com/general-feedback-and-conversation-229090/suddenly-cannot-find-airplay-on-sonos-move-6879260?postid=16637363#post16637363

 

Thanks Ken,

I tried factory resetting all my speakers and re-installing the app, but it didn't make any difference. The speakers reconnected to Airplay for a few hours, but when I woke up the next morning, they had all dropped off Airplay again. All I can do is unplug and restart them all every time I want to use them. It's bloody annoying.

I’ve tried everything and I give up. I guess there is no solution. Sonos just makes faulty products that don't work properly. Sigh.

Thanks Ken,

I tried factory resetting all my speakers and re-installing the app, but it didn't make any difference. The speakers reconnected to Airplay for a few hours, but when I woke up the next morning, they had all dropped off Airplay again. All I can do is unplug and restart them all every time I want to use them. It's bloody annoying.

I’ve tried everything and I give up. I guess there is no solution. Sonos just makes faulty products that don't work properly. Sigh.

That’s okay, always happy to try to assist, but I think Sonos is the last place to point your finger…If that were the case then all my Sonos speakers, and I have a fair few, would not be working with Airplay and in fact they do all work fine here. I’m certainly not seeing an issue and both my son and daughter, in their own Homes, use Spotify and Apple Music Apps (respectively) with Airplay from their iPhones and one of my friends uses it too (probably more than me) and things have been fine - My guess is that it could be your router and it’s compatibility with the Bonjour service, or perhaps more likely you have not done the reset after the recent Apple fiasco with their (now withdrawn) HomeKit update, as widely mentioned online and by a member of Sonos Staff here (and plenty of others too):

https://en.community.sonos.com/general-feedback-and-conversation-229090/suddenly-cannot-find-airplay-on-sonos-move-6879260?postid=16637363#post16637363

I did also look on the Apple forums and here too are the things that some Apple iOS users have suggested in the past to fix Airplay issues on HomePod and other 3rd party speakers…

  • Restart all devices and try to AirPlay again
  • Toggle off Bluetooth, or if already off, try turning it on, on the sending device.
  • Turn off Cellular Data
  • Disconnect from any other Bluetooth devices (like speakers, headphones etc.)
  • Connect all to the same WiFi network access point
  • Reset your network settings on your iDevice in Settings > General > Reset > Reset Network Settings
  • Disable ‘Private Address’ MAC Spoofing in the iOS Network connection 
  • Disable WiFi calling.
  • Update iOS, and speaker firmware/software
  • Move your devices away from other electronics and closer to the main router
  • Renew your devices DHCP lease via the router configuration pages or better still, reboot the router.
  • Switch off any Security/VPN software installed on the sending (mobile) device

Anyhow I hope that assists you to fix things and hopefully it will go onto eventually persuade you that Sonos do not make faulty products that do not work properly, in my own personal experience, the issues can quite often actually lie elsewhere.

Reply